2 środowiska .NET Framework


(Szarex2 0) #1

Był już temat o dwóch Javach to ja zapytam teraz o środowisko .NET Framework.

Kieruje się zasadą że programy korzystające z Internetu staram się mieć zawsze jak najbardziej aktualne. Mam swój ulubiony czytnik RSS, który do poprawnego działania wymaga .NET Framework. Więc instaluje najnowszego Frameworka. Jeśli chce jednak zainstalować Delphi 2005 Personal Edition muszę zainstalować chcąc czy nie chcąc .NET Framework 1.1 dostępny razem z instalatorem Delphi. Inaczej instalator nie puści mnie dalej. Teraz mam pytanie - czy 2 środowiska .NET nie będą się jakoś gryźć i czy możliwe jest najpierw zainstalowanie Delphi 2005 Personal z .NET Framework 1.1 a potem zmuszenie go do korzystania z najnowszego .NET-a?


(fiesta) #2

nie będą, a niektórzy nawet zalecają posiadanie wszystkich wersji, gdyż do końca nie są ze sobą kompatybilne.


(Ryszard Adamek) #3

Masz racje wszystkie Frameworki sa potrzebne. Mam wersję 1.1 2.0 i 3.0 a podczas aktualizacji z witryny microsoft ściągnęły sie nawet driverki do 1.0 Wszystko sie okazuje i wychodzi jak sie instaluje programy. Np. wersja 2.0 potrzebna jest do Nero, 1.1 do NortonGhost i do grafiki itp.


(Skiff) #4

Należy zaznaczyć, że jeżeli instaluje się wersję 3.0 to ona zawiera w sobie wersję 2.0. Wersja 1.1 jest całkowicie oddzielna i trzeba instalować osobno.