Attansic L 1 Gigabit Ethernet + Debian Etch - problem


(Baxu69) #1

Witam.

Mam pewien problem, wczoraj postanowiłem ze zainstaluję sobie Debiana Etch z KDE.

Na początek zainstalowałem na VirtualBoksie i śmigał aż miło. Potem chciałem go zainstalować na dysku. To nie jest moja 1 przygoda z Linuksem. A więc podczas instalacji nie wykrywa karty sieciowej (Attansic L 1 Gigabit Ethernet 10/100/1000Base -T Controller taką posiadam zintegrowana w ASUS P5K), pominąłem krok z wyborem sterowników do niej bo na liście takowej nie ma i instalowałem dalej wszystko się pięknie ładnie zainstalowało. Uruchamiam Debiana i w ogóle KDE się nie ładuje tylko tryb tekstowy. A na VB KDE uruchomiło się od razu.

Macie może jakieś sugestie do tego?

'Dodam, że jak wpisuje w konstoli startx wyskakuje komunikat "Fatal error - No Screens found" czy jakos tak..


(matiit) #2
  1. Co do trybu tekstowego - jaka karta graficzna?

  2. Co do sieciówki - spróbuj Debiana Lenny, ma nowsze jądro więc tam powinny być sterowniki do tej karty.


(Baxu69) #3

GF 8600 GT, w xorg poprawnie znajduje karte graficzną :>


(matiit) #4

Mówię Ci próbuj z Lennym.

Powinno kartę sieciową wykryć

A jak będzie tryb tekstowy nawet to instalujesz sterowniki...

http://kaka.ovh.org/?p=61


(Rkolodziejak) #5

Aby karta zaczęła działać potrzebujesz modułu atl1 Mam identyczną płytę i kompilowałem ten moduł pod debianem z kernelem 2.6.15 jednakże nie obyło się bez kombinacji.

Moduł ten wbudowano w jądro od wersji 2.6.20-rc5 czyli praktycznie od 2.6.21 i wtedy jeśli nawet nie działa automatycznie wystarczy go załadować.

Jeśli dobrze pamiętam w Etchu jest 2.6.18 więc bez wbudowanego modułu atl1.

Zatem jeżeli posiadasz kernel poniżej 2.6.21 musisz sobie moduł skompilować. Następnie modprobe atl1 i dopisać go do /etc/modules.

Sprawdź również czy przypadkiem nie masz tego modułu w /lib/modules/"wersja kernela"/kernel/drivers/net/atl1.

Informacje na temat sterownika znajdziesz tu --> http://atl1.sourceforge.net/

Lepiej i szybciej będzie zainstalować Lenny''ego (jak wspomniał kolega matiit wyżej)


(matiit) #6

Czyli jak nie chcesz kompilować to zrób jak pisałem i Zainstaluj Lennego :slight_smile:


(Baxu69) #7

Dziękuje :smiley: Lenny dopiero śmiga:D - Temat do zamknięcia :slight_smile: