Błąd poza zakresem pracy przy grach 3d-Ubuntu 9.10


(pac-man) #1

Witam serdecznie

Mam zainstalowane Ubuntu 9.10PL Karmelkowy Koliberek. Sterowniki do grafiki mam zainstalowane. Od pewnego czasu gdy chce włączyć jakąś grę np. American Army to monitor robi się czarny i wyskakuje błąd poz zakresem pracy i jakieś częstotliwości np. 80Hz. I tu rozpoczyna się mój problem gdyż nie mam pomysłu jak go rozwiązać. Dodam jeszcze ze mój monitor to LG Flatron L1753S.

Z góry dzięki za pomoc

Pozdrawiam :smiley:


(Sli512) #2

Monitor obsługuje rozdzielczość gry i odświeżanie ?


(pac-man) #3

Ja Windowsie wszystko śmigało:) także raczej powinien obsługiwać.


(Henio Mazurek) #4

Też coś takiego lubi mi wyskakiwać. Rozwiązania problemu nie znalazłem ale jego obejście.

Uruchom winecfg, potem zakładka Grafika, zaznacz "Emuluj wirtualny pulpit", ustaw rozdzielczość ekranu. Uruchom grę, powinno działać. Jeśli masz jakieś inne aplikacje pod Wine to radziłbym tą grę zainstalować np przez PlayOnLinux i odpowiednio dla niej skonfigurować Wine inaczej może się zrobić bałagan.


(pac-man) #5

tylko że ja mam wersje dla Linuksa i przy innych grach 3d ten sam problem wyskakuje


(Henio Mazurek) #6

Sorry, to mnie zmyliło.

To inaczej. Sprawdź wartości odświeżania dla konkretnej rozdzielczości swojego monitora (znajdziesz je na płytce z instrukcją). Potem wygeneruj modeline dla źle obsługiwanej rozdzielczości, tutaj instrukcja

http://forum.slackware.pl/viewtopic.php?t=9807

a tutaj podobny temat

http://naszamandriva.pl/forum/viewthrea ... owstart=20

Pamiętaj żeby nie przesadzić z odświeżaniem bo można uszkodzić monitor.

Jeśli to nie pomoże to więcej pomysłów nie mam.


(pac-man) #7

Tylko że ja kurcze nie mam już tej płytki :? a gdzieś w internecie da się to znaleźć??


(Henio Mazurek) #8

Wystarczy poszukać.

http://www.fixdevice.com/manuals/file/31804.html

Na stronie 21 masz tryby odświeżania, np

Oznacza, że dla trybu 1280x1024 przy odświeżaniu w pionie 60 Hz odświeżanie w poziomie (hsync) powinno wynosić 63.981kHz (u mnie jest to 63,60 ale działa poprawnie). Resztę doczytasz w pierwszym linku. A z drugiego linku (ostatni post) dowiesz się za jakie rozdzielczości się zabierać.


(pac-man) #9

dobra mam płytkę od kolegi. I tam mam jak ty podałeś. Tylko że teraz mam problem bo nie wiem za bardzo jak się za to zabrać nie wiem jak ustawić te przedziały o którym mówią w tym poradniku chodzi o jakieś pole hsync


(Henio Mazurek) #10

Najpierw dobrze byłoby wiedzieć w jakiej rozdzielczości gra startuje, innych rozdzielczości, jeśli działają OK lepiej nie ruszać. Potem w terminalu wpisujesz (przykład dla rozdzielczości 800x600 i odświeżania 60Hz)

gtf 800 600 60 -x

Otrzymasz coś takiego

# 800x600 @ 60.00 Hz (GTF) hsync: 37.32 kHz; pclk: 38.22 MHz

  Modeline "800x600_60.00" 38.22 800 832 912 1024 600 601 604 622 -HSync +Vsync

Wartość hsync (odświeżanie w poziomie, tutaj 37.32 ) powinna być identyczna lub podobna do tej z instrukcji. Sprawdź na wszelki wypadek. Jeśli będzie się sporo różnić to gdzieś jest błąd. Potem w terminalu jako root wklep

gedit /etc/X11/xorg.conf

Pod "Section Monitor" dopisz to co jest w drugiej linijce (od Modeline), czyli tutaj

Modeline "800x600_60.00" 38.22 800 832 912 1024 600 601 604 622 -HSync +Vsync

W "Section Screen" pod SubSection z kolei

Modes "800x600@60"

Jak to dokładnie wygląda w xorg.conf jest w instrukcji (pierwszy mój link). Jak w terminalu wklepiesz

nazwa_gry --help

to coś się pojawia? Jeśli tak to sprawdź czy wyświetlają się jakieś opcje grafiki.


(pac-man) #11

Gra się uruchomiła ale w małym oknie z dwoma kursorami ale zanim to się stało wyskoczył znowu ten sam błąd a tu wycinek z konsoli:

root@piotr:/home/piotr#

root@piotr:/home/piotr# armyops --help

Cheat protection disabled

open /dev/[sound/]dsp: Device or resource busy

Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".


(Henio Mazurek) #12

Dźwięk był? W jakiej rozdzielczości gra się uruchomiła? Można było zmienić jej rozdzielczość? Poszukaj pliku konfiguracji gry, powinien być w ukrytym folderze gry w Twoim katalogu domowym. Stamtąd powinieneś móc ją ustawić tak by działała. Ewentualnie pozostaje uruchamianie w oknie (w konfigu gry powinna być taka opcja).


(Gabrielmichalski) #13

pac-man

Uruchamiasz grę z root'a, czy tylko zbieżność nazw widzę?

Jeśli z root'a, to prawdopodobnie masz już odpowiedź na Twoje pytanie :slight_smile:


(pac-man) #14

A to ma jakieś znaczenie jak uruchamiam?


(Henio Mazurek) #15

Raczej tak. Uruchamiaj jak zwykły użytkownik. Poza tym uruchamianie aplikacji posiadających luki (gry na pewno takie mają) pod rootem jest niewskazane.

Wczoraj sprawdziłem kilka gier na okoliczność błędu "poza zakresem pracy". W ExtremeTuxRacer przy rozdzielczości 800x600 mi wywaliło ten błąd. Poszukałem folderu gry w moim katalogu. Zmieniłem rozdzielczość i wszystko się uruchamia. Więc jeśli nie chcesz zbytnio kombinować też tak zrób.


(pac-man) #16

Aha czyli mam wejść w folder z gra i tam w jakimś pliku coś pozamieniać?