Blad przy instalacji ubuntu 11.04

Witam,

Z gory przepraszam za brak polskich znakow, ale nie wiem gdzie to na tym systemie ustawic :stuck_out_tongue:

Chce zainstalowac UBUNTU 11.04. Dochodze do momentu wyboru partycji. Przed instalacja na windowsie zrobilem partycje na ktorej bedzie linux. No i chce zainstalowac ten system i mi wywala blad:

http://iv.pl/images/55978510640024189319.png

Kilka razy pracowalem na LINUX MINT ale na komputerze znajomej. Teraz chce zainstalowac UBUNTU Na moim laptopie i nie wiem jak. Zawsze wywala mi ten blad.

Prosze o odpowiedz.

Na moje oko, Linux na NTFS nie pójdzie… :wink:

Daj ext4 i będzie działało.

Klikalem tak jak widac na screenie, i dalej to samo:

http://iv.pl/images/83055313328621296500.png

Punkt montowania daj na /

No i jeszcze takie jedno małe pytanie - ile pamięci RAM ma ten laptop?

ej zaraz… Po co Ci 7gb na /boot? Dodatkowo nie widzę partycji / czyli katalogu głównego, ani swampu (Jeżeli masz wystarczająco dużo pamięci to nie musisz z niego korzystać).

ed: poczytaj : http://gorzow-wlkp.pl/linux/podzialdysku.php i http://jakilinux.org/pierwsze-kroki/sys … e-i-dyski/

Po zmianie na ‘’/’’ wyskakuje takie cos, nie wiem o co chodzi :wink:

http://iv.pl/images/12390297399158664926.png

RAM 2GB, procesor 1.9 AMD DUAL CORE, DYSK HDD 160GB

No to dajesz SWAP i po problemie.

Dobra, napisz dokładnie, które partycje chcesz przeznaczyć na linuksa i co znajduje się na każdej z nich obecnie. Narazie nic nie rób. Napisz ile laptop posiada pamięci RAM?

Zielony jestem w sprawach linuxa - CO TO SWAP ? :wink:

To, czego ci brakuje - przestrzeń wymiany.

RAM 2GB.

Chce zainstalowac na /dev/sda2 - partycja ~7gb. Nie powinno niby nic na niej byc, ale nie wiem skoro pokazuje ze jest ~3gb zajete…

Nie znam sie totalnie nic na linuxie, wiec prosze o pomoc… :wink:

Śmiem twierdzić, że te 7 gb to trochę za mało.

System plików bl. 1M B użyte dostępne %uż. zamont. na

/dev/sda2 20158M 3644M 15491M 20% /

/dev/sda1 246835M 9239M 237596M 4% /mnt/windows

/dev/sda3 200494M 5871M 184439M 4% /home

Ja mam mniej więcej tak :slight_smile:

7GB malo… Ale juz wiecej dac nie moge, potrzebuje miec na winde duzo pamieci bo na niej glownie pracuje. LIinux ma byc do zapoznania sie z systemem i ew. zmiany w przyszlosci :wink:

Co ma teraz zrobic? Kliknac dalej, czy cos zmienic jeszcze?

Uruchom Windows. Wykonaj defragmentację wszystkich pozostałych partycji Windowsa, sprawdź co masz na /dev/sda3. Następnie z poziomu live-cd linuksa uruchom GParted. Po uprzednim upewnieniu się, że są puste usuń partycje /dev/sda2 oraz /dev/sda3 => Zastosuj. Następnie utwórz nową partycję rozszerzoną => Zastosuj. W jej obrębie utwórz dwie partycje logiczne:

  • partycję SWAP ( 512 MB) -> system plików linux-swap => Zastosuj

  • partycję w systemie plików ext4 -> reszta wolnego miejsca (z tego wydzielonego) => Zastosuj.

=================

Podczas instalacji dla partycji /etx4 wskażesz punkt montowania => / ; a dla partycji 512 MB (swap) wskażesz punkt montowania => swap.

=================

Jeśli nie możesz usunąć ostatniej partycji NTFS z powodu braku miejsca, nie twórz swap, instaluj tak jak jest …

Nie moge tak zrobic, bo na sda3 mam RECOVERY Windowsa .

Dobra, zostaw w takim razie /dev/sda3 w świętym spokoju. Moja ostateczna koncepcja jest taka, żeby partycja systemowa linuksa, czyli " / " była wielkości conajmniej 10 GB a partycja swap wielkości 512 MB. W tym celu z poziomu Windows, narzędziami dla Windows (bo tak chyba tworzyłeś te partycje NTFS) wydziel sobie z partycji /dev/sda1 jeszcze przynajmniej 3,5 GB wolnego miejsca (obszar niepodzielony). Potem z poziomu Ubuntu live-cd usuń /dev/sda2 => Zastosuj. Powstanie łączne miejsce niepodzielone na partycje o wielkości 3,5 GB + 7,3 GB i wtedy utwórz partycję rozszerzoną, a w jej obrębie utwórz dwie partycje logiczne tak jak pisałem w jednym z poprzednich postów (512 MB na swap, reszta na /). Linuks zainstalowany na partycji wielkości 7,3 GB bez /home i /swap dość szybko się zapcha przy pierwszej lepszej aktualizacji i może działać niesprawnie.

Zainstalowałem normalnie tak jak miałem wcześniej napisane - na “/” przy normalnej 7GB partycji sda2. Wyskoczył błąd podczas instalacji:

http://iv.pl/images/58843555540535062853.png

Może mi ktoś napisać co teraz zrobić?

Zacytuj komunikat, który zobaczysz po rozwinięciu okienka “Error Details”.

Albo użyj WUBI, dzięki niemu zainstalujesz ubuntu na partycji Windows, bez kasowanie jej zawartości i usuwania Win-a. Na początku na zapoznanie jest to świetne rozwiązanie.