Błąd przy konwertowaniu pliku RPM na DEB za pomocą Aliena

Witam serdecznie, chcę przerobić pakiet rpm na deb za pomocą aliena. Dokładnie to chodzi o plik javy: jre-6u19-linux-i586.rpm.

System to Ubuntu 9.10 GNOME.

Niestety, przy konwertowaniu pojawia się:

incorrect format: unknown tag

Warning: Skipping conversion of scripts in package jre: postinst postrm prerm

Warning: Use the --scripts parameter to include the scripts.

chown: nie ma dostępu do `jre-1.6.0_19//usr/java/jre1.6.0_19/lib/charsets.jar': No such file or directory

failed chowning /usr/java/jre1.6.0_19/lib/charsets.jar to 0:0: Illegal seek at /usr/share/perl5/Alien/Package/Rpm.pm line 265, line 38.

Robię wszystko na 100% dobrze, jestem tego pewny. Dla pewności napiszę, że plik ma uprawnienia dla mnie, a poza tym próbowałem też pod rootem i lipa.

Po co się męczyć jak można z repozytorium zainstalować:

sudo apt-get install sun-java6-jre

Tak, wiem o tym, ale nie jest to najnowsza wersja. Sposób instalacji jaki podany jest na stronie java nie działa, nawet w przypadku zwykłego pliku bin zamiast rpm. Ponieważ to będzie zwykłe wypakowanie, a system i tak nie zobaczy tej wersji Javy.

Tylko bardzo proszę nie wyjeżdżać mi tutaj z wypowiedziami typu: a po co najnowsza wersja, co w niej takiego super itp.

Zarówno bin jak i rpm, deb czy inny pakiet czy to ze strony producenta czy z repozytorium tylko i wyłącznie wypakowuje zawartość pakietu. Żeby Java działała musisz stworzyć dowiązania symboliczne do plików Javy, więc niepotrzebnie męczysz się z konwertowaniem pakietu rpm do deb, bo rpm i tak nie zainstaluje Javy tylko rozpakuje pliki.

Pozdrawiam!

Aha ok dzięki, udało mi się zrobić dowiązanie Javy do systemu. Po wpisaniu w terminalu java -version wyświetla się, że mam wersję 19 :).