Blokada kernela nouveau


(Piotrkijak) #1

Witam, w którym miejscu pliku menu.lst muszę zamieścić wpis rdblacklist=nouveau nomodeset - pod kernel /boot/vmlinuz-2.6.35.6-45.fc14.i686 ro root=UUID=0dcb8a32-5643-4$ czy initrd /boot/initramfs-2.6.35.6-45.fc14.i686.img?


(nintyfan) #2

Zmień linijkę,którą wskazałeś, jako pierwsza na taką postać:

kernel /boot/vmlinuz-2.6.35.6-45.fc14.i686 rdblacklist=nouveau nomodeset ro root=UUID=0dcb8a32-5643-4 ...

Znak dolara w twoim wypadku oznacza, że nie skopiowałeś pełnej linijki. Dalsza jej część została obcięta. Nie jest to problem, ale nie usuwaj linijki, którą masz zmienić. Po prostu dopisz rdblacklist=nouveau nomodeset w odpowiednie miejsce.


(Piotrkijak) #3

Dobra, już wszystko ogarnąłem...


(roobal) #4

Masz menu.lst czy grub.cfg? Jeśli grub.cfg to:

su -c "sed 's/GRUB\_CMDLINE\_LINUX\=""\/GRUB\_CMDLINE\_LINUX\="rdblacklist=nouveau nomodeset"/g' /etc/default/grub > /etc/default/grub.new && mv -v /etc/default/grub.new /etc/default/grub"

Potem aktualizacja konfiguracji

su -c update-grub

Pozdrawiam!


(Piotrkijak) #5

Dzięki roobal, ale tak jak pisałem, uporałem się z tym i sterowniki są już zainstalowane. :wink: W sumie mam jeszcze dwa pytania. Czy da się jakoś przywrócić bootscreen, bo po instalacji sterowników przy starcie mam czarny ekran z paskiem na dole? Mam Fedorę 14, a moja karta graficzna to Nvidia Geforce 7300GT. Drugie moje pytanie brzmi: co trzeba zrobić, aby obraz był rozciągnięty na cały ekran, bo mam ustawioną rozdzielczość 1280x1024 odświeżanie 60MHz i po prawej i lewej stronie mam czarny pasek grubości ok 1/1,5 mm


(roobal) #6

Spróbuj

echo "FRAMEBUFFER=y" | su -c 'tee /etc/initramfs-tools/conf.d/splash'

su -c 'update-initramfs -u'

su -c update-grub

Pozdrawiam!


(Piotrkijak) #7

Dzięki, zaraz spróbuję. Byłbym wdzięczny jakbyś mi jeszcze odpowiedział na drugie pytanie, bo odpowiedziałeś nim przeedytowałem posta.

-- Dodane 07.11.2010 (N) 18:43 --

Polecenie nie zadziałało. Wyalliło błędy:

tee: /etc/initramfs-tools/conf.d/splash: Nie ma takiego pliku ani katalogu

FRAMEBUFFER=y

[root@localhost Piotr]# su -c 'update-initramfs -u'

bash: update-initramfs: nie znaleziono polecenia

[root@localhost Piotr]# su -c update-grub

bash: update-grub: nie znaleziono polecenia


(roobal) #8

Niestety nie mam pojęcia, nie miałem zbytnio do czynienia z kartami Nvidii, zawsze w ręce wpadało mi coś od ATI ale może pomogłoby ustawienia rozdzielczości w xorg.conf ale z racji, że najnowsze wersje Xservera nie muszą korzystać z tego pliku, to trzeba go sobie wygenerować i tam ustawić rozdzielczość ręcznie, być może to coś da :slight_smile:

Widocznie w Fedorze nie ma tego katalogu albo jest w innej lokalizacji.

Pozdrawiam!


(Tormiasz) #9

Zainstaluj sobie nvidia-settings, tam są różne opcje dotyczące kalibrowania ekranu (a może przez przyciski na monitorze coś ustawisz?).