Brak Akceleracji 3D w OpenSuse 10.3 - GeForce 8600


(Feelek3) #1

Witam.

Zainstalowałem sterowniki, zgodnie z tą instrukcją:

1.Wchodzimy do centrum sterowania YAST

2.Wybieramy zakładkę "Oprogramowanie" i wybieramy opcję "Źródła instalacji"

3.Zaznaczamy opcję HTTP i klikamy dalej

4.W ramce "Nazwa serwera" wpisujemy: "download.nvidia.com" a w ramce "Katalog na serwerze" wpisujemy: "/opensuse/10.2"

5. Zatwierdzamy i wychodzimy do głównego okna YAST

6. Klikamy opcje "Zarządzanie oprogramowaniem"

7. W ramce Szukaj wpisujemy "nvidia" i czekamy na rezultaty

8. Wybieramy pakiety: "x11-video-nvidia" i "nvidia-gfx-kmp-default" i je instalujemy

9.Zamykamy "Zarządzanie oprogramowaniem" i YAST i restartujemy kompka ;)

w 6 punkcie nie było tej opcji, ale była podobna "repozytorium oprogramowań"

w punkcie 8 wybrałem nowsze wersje pakietów, żeby pasowały do mojego GPU, pakiety się pomyślnie zainstalowały, niestety po restarcie kompa, nie ujrzałem żadnych zmian, a w opcjach Karty graficznej nadal pisze że nie mam akceleracji 3D. Gdy chce uruchomić Efekty graficzne, wszystkie funkcje są niedostępne :frowning:

Proszę o pomoc.

Pozdrawiam.


(matiit) #2

Pakiety się zainstalowały poprawnie?

Jak tak to pokaż wynik polecenia:

grep nv /etc/X11/xorg.conf

(Feelek3) #3

Odpowiedź na to polecenie dostałem takie:

linux-21gn:/home/felek # grep nv /etc/X11/xorg.conf

  Driver "nvidia"

(matiit) #4

hmm, to może jednak masz 3d?

zobacz:

glxinfo | grep direct

(Feelek3) #5

Odpowiedź jaką dostałem na komende:

"glx | grep direct" To:

"direct rendering: No"

To oznacza że nie ma akceleracji, prawda?

odziwo XGL działa, i to nawet dobrze :slight_smile:


(matiit) #6

XGL?

Jesteś pewien tego co piszesz :)?

XGL zabiera sobie akceleracje, poza tm nie jest już używany, tym bardziej na kartach NVIDIA, używa się AIGLX.


(Feelek3) #7

Ha! jestem pewien :slight_smile:

Albo ja mam coś z głową, albo program się myli:

Oto screen:

zrzutekranuqv6.th.png

No dobra ale wciąż chciał bym się dowiedzieć jak odpalić akceleracje w tym systemie :slight_smile:


(Fisiu) #8

Jak ma działać skoro dla openSUSE 10.3 jako ścieżkę do sterowników NVIDIA podałeś "/opensuse/10.2" → patrz 1. post.

Zedytuj repozytorium w Yast i zainstaluj odpowiedni sterownik, zgodny z Twoją wersją kernela.


(Feelek3) #9

Fisiu , masz mnie aż za takiego głupku, oczywiscie że takie coś zrobiłem, tylko że nie opisałem tego w 1 poście.

Ma ktoś jeszcze jakiś propozycje, bo sobie kupiłem CEDEGE ale nie mogę grać bo nie mam akceleracji ;/


(Fisiu) #10

Bo ja mam szklaną kulę i wiem co robiłeś... napisałeś A, zrobiłeś B więc czego Ty oczekujesz?

Podaj lspci -nn, cały xorg.conf i Xorg.log.

a i jeszcze uname -a i rpm -qa | grep nvidia


(Feelek3) #11

lspci -nn :

00:00.0 Host bridge [Class 0600]: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub [8086] (rev 02)

00:01.0 PCI bridge [Class 0604]: Intel Corporation 82945G/GZ/P/PL PCI Express Root Port [8086] (rev 02)

00:1b.0 Audio device [Class 0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086] (rev 01)

00:1c.0 PCI bridge [Class 0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086] (rev 01)

00:1d.0 USB Controller [Class 0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086] (rev 01)

00:1d.1 USB Controller [Class 0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086] (rev 01)

00:1d.2 USB Controller [Class 0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086] (rev 01)

00:1d.3 USB Controller [Class 0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086] (rev 01)

00:1d.7 USB Controller [Class 0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086] (rev 01)

00:1e.0 PCI bridge [Class 0604]: Intel Corporation 82801 PCI Bridge [8086] (rev e1)

00:1f.0 ISA bridge [Class 0601]: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge [8086] (rev 01)

00:1f.1 IDE interface [Class 0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086] (rev 01)

00:1f.2 IDE interface [Class 0101]: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller [8086] (rev 01)

00:1f.3 SMBus [Class 0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086] (rev 01)

01:01.0 Multimedia video controller [Class 0400]: Conexant CX23880/1/2/3 PCI Video and Audio Decoder [14f1] (rev 05)

03:00.0 VGA compatible controller [Class 0300]: nVidia Corporation GeForce 8600 GT [10de] (rev a1)

xorg.conf

# /.../

# SaX generated X11 config file

# Created on: 2008-05-08T14:01:24+0200.

#

# Version: 8.1

# Contact: Marcus Schaefer , 2005

# Contact: SaX-User list 

#

# Automatically generated by [SaX2] (8.1)

# PLEASE DO NOT EDIT THIS FILE!

#


Section "Files"

  FontPath "/usr/share/fonts/misc:unscaled"

  FontPath "/usr/share/fonts/local"

  FontPath "/usr/share/fonts/75dpi:unscaled"

  FontPath "/usr/share/fonts/100dpi:unscaled"

  FontPath "/usr/share/fonts/Type1"

  FontPath "/usr/share/fonts/URW"

  FontPath "/usr/share/fonts/Speedo"

  FontPath "/usr/share/fonts/PEX"

  FontPath "/usr/share/fonts/cyrillic"

  FontPath "/usr/share/fonts/latin2/misc:unscaled"

  FontPath "/usr/share/fonts/latin2/75dpi:unscaled"

  FontPath "/usr/share/fonts/latin2/100dpi:unscaled"

  FontPath "/usr/share/fonts/latin2/Type1"

  FontPath "/usr/share/fonts/latin7/75dpi:unscaled"

  FontPath "/usr/share/fonts/baekmuk:unscaled"

  FontPath "/usr/share/fonts/japanese:unscaled"

  FontPath "/usr/share/fonts/kwintv"

  FontPath "/usr/share/fonts/truetype"

  FontPath "/usr/share/fonts/uni:unscaled"

  FontPath "/usr/share/fonts/CID"

  FontPath "/usr/share/fonts/ucs/misc:unscaled"

  FontPath "/usr/share/fonts/ucs/75dpi:unscaled"

  FontPath "/usr/share/fonts/ucs/100dpi:unscaled"

  FontPath "/usr/share/fonts/hellas/misc:unscaled"

  FontPath "/usr/share/fonts/hellas/75dpi:unscaled"

  FontPath "/usr/share/fonts/hellas/100dpi:unscaled"

  FontPath "/usr/share/fonts/hellas/Type1"

  FontPath "/usr/share/fonts/misc/sgi:unscaled"

  FontPath "/usr/share/fonts/xtest"

  FontPath "/opt/kde3/share/fonts"

  InputDevices "/dev/gpmdata"

  InputDevices "/dev/input/mice"

EndSection


Section "Module"

  Load "dbe"

  Load "type1"

  Load "freetype"

  Load "extmod"

  Load "glx"

EndSection


Section "ServerFlags"

  Option "AllowMouseOpenFail" "on"

EndSection


Section "InputDevice"

  Driver "kbd"

  Identifier "Keyboard[0]"

  Option "Protocol" "Standard"

  Option "XkbLayout" "pl"

  Option "XkbModel" "microsoftpro"

  Option "XkbRules" "xfree86"

EndSection


Section "InputDevice"

  Driver "mouse"

  Identifier "Mouse[1]"

  Option "Buttons" "5"

  Option "Device" "/dev/input/mice"

  Option "Name" "ImPS/2 Generic Wheel Mouse"

  Option "Protocol" "explorerps/2"

  Option "Vendor" "Sysp"

  Option "ZAxisMapping" "4 5"

EndSection



Section "Monitor"

  Option "CalcAlgorithm" "XServerPool"

  DisplaySize 340 270

  HorizSync 31-64

  Identifier "Monitor[0]"

  ModelName "1280X1024@60HZ"

  Option "DPMS"

  VendorName "--> VESA"

  VertRefresh 50-60

  UseModes "Modes[0]"

EndSection



Section "Modes"

  Identifier "Modes[0]"

  Modeline "1280x1024" 102.62 1280 1312 1472 1632 1024 1028 1032 1048 -HSync -VSync 

EndSection



Section "Device"

  BoardName "GeForce 8600 GT"

  BusID "3:0:0"

  Driver "nvidia"

  Identifier "Device[0]"

  VendorName "NVIDIA"

EndSection



Section "Screen"

  DefaultDepth 24

  SubSection "Display"

    Depth 15

    Modes "1280x1024" "768x576" 

  EndSubSection

  SubSection "Display"

    Depth 16

    Modes "1280x1024" "768x576" 

  EndSubSection

  SubSection "Display"

    Depth 24

    Modes "1280x1024" "768x576" 

  EndSubSection

  SubSection "Display"

    Depth 8

    Modes "1280x1024" "768x576" 

  EndSubSection

  Device "Device[0]"

  Identifier "Screen[0]"

  Monitor "Monitor[0]"

EndSection



Section "ServerLayout"

  Identifier "Layout[all]"

  InputDevice "Keyboard[0]" "CoreKeyboard"

  InputDevice "Mouse[1]" "CorePointer"

  Screen "Screen[0]"

Xorg.log : Takiego pliku nie ma ani w szukajce, ani jak wklepałem do terminala to nic nie wyświetliło. uname -a:

Linux linux-21gn 2.6.22.5-31-default #1 SMP 2007/09/21 22:29:00 UTC i686 i686 i386 GNU/Linux

rpm -qa | grep nvidia:

x11-video-nvidiaG01-169.12-0.1

nvidia-gfxG01-kmp-default-169.12_2.6.22.17_0.1-0.1

Pozdrawiam


(Fisiu) #12

Co do Xorg.log to chodziło mi o → /var/log/Xorg.0.log

Zobacz jaką masz wersję kernela i porównają ją z wersją sterownika NVIDII który zainstalowałeś. Dodaj repozytorium update (http://download.opensuse.org/update/10.3/) do Yast i zaktualizuj kernel.

Po aktualizacji kernela zrób restart systemu.

Powinna już działać akceleracja 3D.