Brak pliku READREG.EXE - problem ze sterownikami

Witam, mój pierwszy post tutaj. Mam pewien problem. Otóż miałem ohydnego wirusa, po wybraniu użytkownika zostałem przekierowany do pulpitu, wczytał się jedynie pulpit - bez ikon - a ja po kilku sekundach zostałem wylogowany. Nie wiedząc co zrobic z tym fantem sięgnąłem po płytkę instalacyjną Windows, zebrałem wszystkie sterowniki do kupy i rozpocząłem misję “Reinstalka”. Wszystko poszło gładko - formatowanie, instalacja. Problem czyhał gdzie indziej. Otóż przy próbie instalacji Sound Blastera do głośników 5.1. O ile instalacja przeszła pomyślnie, to niespodzianka kryła się po restarcie systemu. System wyskoczył z taką informacją ‘System Windows nie może odnalezc pliku READREG.EXE’. Nie działa karta dźwiękowa, nie jest w ogóle wykrywalna. Inne sterowniki nie robiły takich problemów - karta główna zainstalowała się normalnie. Dodatkowo przy próbie włączenia jakiejś piosenki, WinAmp pokazuje taki błąd:

NullSoft DirectSound output v2.47 (d) error

Nieprawidłowy sterownik DirectSound. 

Zainstaluj odpowiednie sterowniki lub wybierz inne urządzenie w konfiguracji.

Kod błędu: 88780078

Dodam, że nigdy takich problemów nie było, a ja jestem świeżo po reinstalce Windowsa.

Proszę, pomocy!

1.Sprawdż Start -> Panel Sterowania -> System -> Sprzęt -> Menedżer urządzeń czy nie ma wykrzyknika

lub znaku zapytania. Jak jest to PPM / prawym przyciskiem myszy /i Aktualizuj sterownik… lub Właściwości - Aktualizuj sterownik…

Jeżeli się nie zaktualizuje to włóż płytkę CD ze sterownikami od komputera i aktualizuj j/w.

  1. Uaktualnij biblioteki DirectX 9. 0 c :

viewtopic.php?f=7&t=213229

Możesz inaczej tak jak piszę w tym temacie :

viewtopic.php?f=11&t=241785

  1. Polecam kodeki z tego tematu, czyli K-Lite Codec Pack Full + Real Alternative :

viewtopic.php?f=2&t=241954

Jeżeli karta nie jest wykrywalna to być może będziesz jeszcze musiał zainstalować sterowniki do

chipsetu płyty głównej.

Wszystko w tematach.

Błąd w winampie jest spowodowanym tym że nie wykrywa właśnie żadnej dźwiękowej.

Kolega wyżej podał wiele rad i radzę wszystko przejżeć.

Zobacz jeszcze czy w BIOS’ie masz wyłączoną dźwiękową…

Problem w tym, że nie ma odpowiedzialnego za sterowniki pliku READREG.EXE. Nie wiem co mam robic : :frowning:

Zapoznaj się proszę z tą stroną i zmień tytuł na

konkretny. Inaczej temat poleci do śmietnika.

Próbowałem wszystkich metod podanych przez XMana. Żaden z nich nie poskutkował.

Co mam robic w tej sytuacji?

To pewnie jest powodowane nieprawidlowym wpisem w pliku system.ini.

Sprawdż w Start -> Panel sterowania -> System -> Sprzęt -> Menedżer urządzeń czy nie ma wykrzyknika

lub znaku zapytania jak jest to włóż płytkę do napędu CD ze sterownikami od komputera i w tym miejscu PPM / prawym przyciskiem myszki / Aktualizuj sterownik… lub Właściwości - Aktualizuj sterownik…

Jeżeli masz drugi napęd to włóż płytkę Windows XP i tak j/w.

Drugi sposób - instaluj z tą płytką/płytkami…

Mówiłem:

Próbowałem wszystkich sposobów i nie dało rady!

Przeczytaj dokładnie od początku do końca ten temat :

viewtopic.php?f=19&t=230120

w system.ini pewnie nieraz nie ma wpisu readreg.exe

Nie wiem o co chodzi. Nie po raz pierwszy instaluje u siebie Windowsa i nigdy takiego problemu nie było. Dzisiaj postanowiłem zreinstalowac go po raz kolejny. Najpierw zainstalowałem Chipset płyty głównej, potem Sound Blaster. Problem napotykam dopiero po restarcie. Wyskakuje okienko z błędem - “System windows nie może odnalezc pliku READREG.EXE”. Pierwszy raz mam problem z tym plikiem. Dodam, że wcześniej żadnych problemów przy instalacji systemu, a tym bardziej karty dźwiękowej nie było.

@Xman, jak już wspominałem - Próbowałem WSZYSTKICH sposobów.