Czy instalować NET.Framework?


(Margor10) #1

Witam!

Mam pytanie: mniej więcej wiem czym jest platforma NET.Framework, ale chciałbym się dowiedzieć czy istnieje konieczność instalowania jej ze względu na bezpieczeństwo? Nie programuje nic na tej platformie, ale się zastanawiam czy brak zainstalowanej platformy ma wpływ na bezpieczeństwo, bo wszystkie dostępne aktualizacje pod win200Professional już zainstalowałem i pozostała mi jedynie NET.Framework i nie wiem czy instalować. A może jej brak przyczynia się do jakieś "luki w systemie" albo przeciwnie....

Proszę o porady.

Pozdrawiam.


(Ryszard Adamek) #2

Instaluj śmiało. Ja mam wszystkie wersje pod XP. Np. wersja 1.1 potrzebna jest do NortonGhost a 2.0 do Nero 7. Wiele programów korzysta z nich i sa raczej potrzebne. Nie zapomnij o DirectX

Złączono Posta : 13.02.2007 (Wto) 0:13

Potem wejdż na stronę aktualizacji microsoftu (nie wiem czy pod 2000 jest taka) i ściągnij poprawki do Net.Framework i pliki językowe.


(walker123) #3

Pewnie że instalować.

-Obowiązkowo jeśli grasz w jakieś gry online. (znaczy gry Multpilayer)


(fiesta) #4

Nie, ale jest ona potrzebna do uruchomienia programów napisanych z wykorzystaniem tej platformy.

Ostatni Ekspert K.Ś. zaleca posiadanie wersj 1.1 2.0 i 3.0 gdyż nie są ze sobą kompatybilne.


(pysiu) #5

i zacznij lepiej od wersji 1 bo później nie chce się instalować :wink:


(Elenka1984) #6

Czemu... normalnie można zainstalować najpierw wersję 2.x, a potem 1.x... albo najpierw 3.0 a później 2.x... wiem -> doświadczenie życiowe...

Jak się ma zainstalowaną wersję 2.x, a jakiś program używa 1.x, to śmiało można doinstalować właśnie tę wersję... Nic się nie zepsuje...

A instalować można a nawet trzeba... bo np. niektóre aplikacje napisane przy użyciu Framework 1.x nie pójdą na Framework 2.x i nie mowa o aplikacjach programistycznych


(pysiu) #7

no bo włąsnie chciałem zainstalować i 1 mając 2i 3 i komunikat ze posiadasz nowsze i nie mozna instalować :frowning:


(Margor10) #8

Dzięki wszystkim za pomoc!

Zainstalowałem NET.Framework 2.0 + poprawki i pliki językowe.

Myślę, ze to wystarczy - przynajmniej na jakiś czas :wink:

Byłem przekonany, że ta platforma nie jest konieczna, ale Wasze posty uzmysłowiły mi, że instalacja tej platformy jest konieczna - z uwagi na poprawność działania niektórych programów.

Teraz mam nowy problem - konto użytkownika w win2000 - i proszę o pomoc! Podaję link: http://forum.dobreprogramy.pl/viewtopic ... highlight=

Pozdrawiam.