Czy NET framework 3.5 zastąpi wersje 1.1 i 1.1 sp?


(system) #1

Posiadam obecnie NET framework 1.1 i 1.1 sp obecnie potrzebuje do aplikacji net framework w wersji 3,5. Na stronie microsoftu pisze aby wcześniejsze wersje odinstalowac przed instalacja 3,5, ale jak odinstaluje to nie wiem czy cos sie nie posypie. Jak to jest z tym net framworkiem 3,5 posiada w sobie wersie 1, 2, 3? Kiedys mailem podobny problem ale wtedy na forum radzili mi ze wyzsze wersjie nie zawieraja w sobie nizszch wersji, cyzli trzeba instalowac wersje 1.1 potem 1.1 sp, 2.0, 3,0 i 3,5.


(mktos) #2

Nie musisz odinstalowywać 1.1 by zainstalować 3.5.

3.5 nie zawiera w sobie wersji 1.1.


(Agatonster) #3

Fiku$miku$ ,

Poradnik dla Ciebie

Proszę poprawić tytuł tematu na konkretny, mówiący o problemie.

Proszę poprawić pisownię w opisie problemu. W celu dokonania korekty proszę użyć przycisku Edytuj przy poście otwierającym ten temat.

Zignorowanie zalecenia będzie skutkowało usunięciem tematu do Kosza.


(system) #4

To dlaczego na stronie microsoftu pisze, żeby odinstalować wcześniejsze wersje przed zainstalowaniem 3,5?


(Kuczkowiak) #5

Wersja 3.5 w zupełności starczy , nie potrzeba jest instalować tego tak jak opisali Ci to na innym forum.

Szczerze mówiąc to ja bym tej wersji 1.1 nie odinstalowywał bo są to jednak biblioteki , a system po odinstalowaniu bibliotek może się wysypać,ale jak tak radzą fachowcy M$ ... :expressionless:


(djkamil09061991) #6

Ale po instalacji net framework 3.5 widoczne są w dodaj usuń programy również net framework 2.0 i framework 1.

Sam miałem wersje 2.0 odinstaloawłem ją , zainstalowałem 3.5 i po instalacji w dodaj usun programy miałem 3.5 i z 4 wpisy starszych wersji frameworka których wcześniej nie miałem. Tak więc ma on strarsze wersje


(system) #7

Pod tym linkiem jest NET framework 3.5 http://www.microsoft.com/downloads/details.aspx?FamilyID=333325fd-ae52-4e35-b531-508d977d32a6&displayLang=pl i tam pisze

WAŻNE:

Jeśli na komputerze instalowane były wcześniejsze wersje wstępne programu .NET Framework 3.5, przed uruchomieniem tej instalacji należy je odinstalować, korzystając z apletu Dodaj lub usuń programy.

znalazłem też inny link... pod tym pierwszym jest NET framework 3.5 a pod tym? http://www.microsoft.com/downloads/details.aspx?FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7&displayLang=pl to jest NET framework 3.5 wraz z Service Pack 1 czy sam Service Pack 1?

Już się zgubiłem tak dziwnie popisane na tej stronie micro$oftu, pod tym pierwszym linkiem plik redystrybucyjny waży 192,7MB a pod tym drugim linkiem plik waży 231,5MB.

Czyli mam ściągnąć z jednego i drugiego linku czy tylko z drugiego?

P.S. widzę że z tym NET workiem to wolna amerykanka się dzieje, jedni mówią, żeby nie usuwać poprzednich wersji a na microsofcie coś innego piszą, i kogo tu słuchać :expressionless: Wyjaśni mi ktoś sensownie jak to z tym jest?


(Giglok) #8

Witam

Jeśli chodzi o wynalazki MS pod nazwą .NET Framework, to sytuacja jest trochę zagmatwana i nic dziwnego, że pojawiają się takie pytania.

Począwszy od .NET 2.0 kolejne wydania bibliotek zawierają w sobie starsze wersje, ale z jednym wyjątkiem - nie zawierają bibliotek z .NET 1.1.

Czyli jeśli mamy zainstalowaną wersje 3.5, to nie musimy instalować przykładowo 2.0 .

Dlatego, jeśli mamy zainstalowaną wersję 1.1 i używamy oprogramowania, które z tego korzysta a następnie odinstalujemy tą wersję i zainstalujemy nowszą, to część funkcji tego oprogramowania przestanie prawidłowo działać.

Jedyne rozwiązanie to pozostawienie zainstalowanego 1.1 i dodatkowo instalacja dowolnej innej wersji. Prawie zawsze takie połączenie działa jak trzeba (zdarzają się jednak czasem problemy zwłaszcza w oprogramowaniu bazodanowym - MS coś popsuł i programy używające 1.1 i bazy danych mssql 2000 po instalacji .net 2.0 i nowszych zaczynają szaleć).

Czyli w skrócie odpowiedź dla OP:

  • zostaw 1.1 bo 3.5 go nie zastąpi

  • doinstaluj 3.5 - wszystko będzie działać prawidłowo.

Bardzo często spotykam się z taką sytuacją.

PS. Jeśli masz zainstalowane nowsze wersje - np. 2.0, 3.0 - możesz je śmiało odinstalować. 1.1 zostaw.


(djkamil09061991) #9

ale w czym masz problem. Odinstaluj wszystko co związane z frameworkiem a następnie zainstaluj frameworka 3.5 i będzie ok. Ostatnio sam tak robiłem, nie ma co się martwić nic się nie stanie


(system) #10

Ok już mi się rozjaśniło trochę :] 1.1 i 1.1 sp muszę mieć, bo to specjalnie ściągałem, bo mam system w wersji EN a chciałem zmienić na PL i dlatego musiałem instalować 1.1

Ok. to z którego linku mam ściągnąć?

  1. http://www.microsoft.com/downloads/deta ... layLang=pl

  2. http://www.microsoft.com/downloads/deta ... layLang=pl

?

w 1 jest net framework 3,5 a pod 2 jest service pack 1, czy service pack 1 wraz z net framework 3,5? Który link mam ściągnąć?


(Giglok) #11

musisz pobrać obydwa i instalować w takiej kolejności jak podałeś.

ewentualnie wystarczy pobrać tylko pierwszy a drugi zostanie zainstalowany automatycznie przez Windows Update.


(system) #12

Hmm a czy przypadkiem ten drugi link nie zawiera tego co ten pierwszy? Bo ja zainstalowałem ten drugi czyli Service Pack 1 i zainstalowało mi się:

net framework 2.0 service pack 2

net framework 3.0 service pack 2

net framework 3.5 SP1

Jeszcze jedno pytanie, jeżeli system mam w wersji EN + spolszczenie to muszę instalować te net frameworki w języku polskim? To samo tyczu sie aktualizacji, czy muszę ściągać aktualizacje w wersji PL czy EN?


(Kuczkowiak) #13

Musisz instalować aktualizacje w takim języku w jakim masz system , czyli ENG


(system) #14

Czyli lepiej jak będę pobierał przez windows update, wtedy automatycznie sobie dobierze system.

Z drugiej strony lepiej chyba mieć system w wersji EN ze spolszczeniem, bo więcej jest poprawek w wersjach EN niż PL


(Kuczkowiak) #15

Ręcznie jak pobierasz aktualizacje lub oprogramowanie M$ też możesz sam ustawić język.