Czy Ubuntu wykryje mój sprzęt?


(Sidh Mor) #1

Witam, przepraszam, że piszę kolejny temat a przed chwilą jeden napisałem, ale ten jest całkiem o czym innym, z Linuxem miałem już troszeczkę, bardzo mało do czynienia, zainstalować go potrafię, ale pytanie, czy wykryje mój sprzęt, i nie będę musiał instalować żadnych sterowników, prócz do modemu SpeedTouch. A wiec tak, grafa: GeForce 7300, płyta główna Gigabyte k8ns, i czy w niej wykryje od razu kartę dźwiękową, kartę sieciową i kontrolery usb? Wszystko zintegrowane, prócz grafiki. Do grafiki wiem, że są stery, ale czy nie będę musiał do płyty głównej instalować, głównie chodzi o dźwięk. Z góry dzięki, i przepraszam za problem.


(aro1978) #2

Wszystko powinno śmigać normalnie bez instalacji dodatkowych sterowników. Ale jeśli masz wątpliwości to uruchom Ubuntu z płyty i sprawdź czy wszystkie urządzenia funkcjonują poprawnie. Oczywiście stery do grafiki będziesz musiał zainstalować swoją drogą.


(Sidh Mor) #3

Ok, dzięki. Mam nadzieję, że łatwo pójdzie mi instalacja wszystkiego i sterów do grafy, jak będzie taka potrzeba.


(matiit) #4

Jak już zrobisz internet to sterowniki się powinny zainstalować same,.


(Sidh Mor) #5

No ok zobaczymy, jak będę instalował linuksa.


(Fisiu) #6

A po co jest niby wersja LiveCD? Uruchamiasz system z płytki i już wiesz co działa out-of-box a co nie.


(Carooxx) #7

Tak jak wyżej, stery tylko do grafiki i modemu.

Bardzo słuszna uwaga. Jeżeli już masz płytkę z Ubuntu, to nie musisz od razu instalować, system po prostu działa z CD (przynajmniej powinien^^). W ten sposób najłatwiej możesz sprawdzić czy będziesz miał dźwięk, czy będzie wykrywać USB itp. Właściwie przed instalacją każdego Linuksa, posiadającego możliwość botowania z CD/DVD warto sprawdzić jak wszystko działa.

Nie ma problemu :wink:


(Sidh Mor) #8

No i git, Neostrada działa, jeszcze pasowała by sterowniki do kary graficznej ściąngąć.

Dzięki za pomoc.


(matiit) #9

Aplikacje, terminal i wpisujesz sudo

restricted-manager

Powinien wykryć że Twoja karta potrzebuje sterowników... Jak nie wykryje to sprawdź czy nie są już czasem zainstalowane... wpisz

glxinfo |grep direct

(Sidh Mor) #10

yyy...

A skąd będę wiedział kiedy się zainstalował ten sterownik? Bo teraz wpisałem to, i nic, tylko, w oknie, coś czerwonego się pokazało, po prawo, że się nie da ich zainstalować, czyli po prostu ich nie ma w linuxie Czyli tych sterów nie ma, i muszę je oddzielnie zainstalować, co za tym idzie ściągnąć je...

to będzie, tak proszę o sprawdzenie bym na darmo nie ściągał grafa to geforce 7300.Więc ściągam te:

http://www.nvidia.pl/object/linux_displ ... 12_pl.html

klikam by je sciagnac i pojawia sie to

http://pl.download.nvidia.com/XFree86/L ... 2-pkg1.run

no i ok, co z tym zrobić? Czy mam to zapisać na dysk prawy i zapisz jako i dwa razy kliknąć?

http://www.nvidia.pl/content/license/dr ... 2-pkg1.run


(Fisiu) #11

W ubuntu jest restricted-manager. Poszukaj dobrze w menu: System → Administracja.


(Sidh Mor) #12

Przeszukałem, ale nie ma tam nic do mojej grafiki.

hmm... a jak wpisuje do terminalu wyskakuję takie coś:

http://img296.imageshack.us/my.php?imag ... hotzg8.png


(Fisiu) #13

To zaznacz kwadrat w kolumnie "Enabled"!


(Sidh Mor) #14

No, tak też robię, aż taki tępy to nie jestem, ale wyskakuję takie coś: http://img174.imageshack.us/my.php?imag ... ot1uh0.png


(matiit) #15

Może w terminalu wpisz sudo restricted manager

ale najpierw wpisz sudo apt-get update


(Fisiu) #16

Wygląda na to, że coś nie tak jest z repozytoriami. Jaką masz listę?


(Sidh Mor) #17

Nie czaję, Co to jest? I gdzie to sprawdzić?


(matiit) #18

Lista czyli plik /etc/apt/sources.list -pokaż.


(Rkolodziejak) #19

Dokładnie tak jak mówią koledzy powyżej - masz nie zaznaczone wszytkie repozytoria.

Jeżeli nie wiesz co to jest - najpierw się dowiedz bo sam sobie utrudnisz korzystanie z linuxa.

Ale żeby cię nie zniechęcać...

sudo cp /etc/apt/sources.list /etc/apt/sources.list_kopia

sudo gedit /etc/apt/sources.list

następnie kasujesz wszystko z pliku i wklejasz to:

deb http://pl.archive.ubuntu.com/ubuntu/ gutsy main restricted

deb-src http://pl.archive.ubuntu.com/ubuntu/ gutsy main restricted


deb http://pl.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted

deb-src http://pl.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted


deb http://pl.archive.ubuntu.com/ubuntu/ gutsy universe

deb-src http://pl.archive.ubuntu.com/ubuntu/ gutsy universe

deb http://pl.archive.ubuntu.com/ubuntu/ gutsy-updates universe

deb-src http://pl.archive.ubuntu.com/ubuntu/ gutsy-updates universe


deb http://pl.archive.ubuntu.com/ubuntu/ gutsy multiverse

deb-src http://pl.archive.ubuntu.com/ubuntu/ gutsy multiverse

deb http://pl.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse

deb-src http://pl.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse


deb http://pl.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

deb-src http://pl.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse


deb http://archive.canonical.com/ubuntu gutsy partner

deb-src http://archive.canonical.com/ubuntu gutsy partner


deb http://security.ubuntu.com/ubuntu gutsy-security main restricted

deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted

deb http://security.ubuntu.com/ubuntu gutsy-security universe

deb-src http://security.ubuntu.com/ubuntu gutsy-security universe

deb http://security.ubuntu.com/ubuntu gutsy-security multiverse

deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse

Potem na koniec...

sudo apt-get update

sudo restricted-manager

i ma działać.

:slight_smile: