Debian Sid AMD64 - źle rozpoznaje partycje swap


(mati75) #1

Witam!

Mam dość nie typowy problem. Mianowicie wszystkie systemy linuksowe poprawnie rozpoznają swap tylko nie debian. Tak rozpoznaje gparted: mlzrzut_ekranu69.png, a tak gnome system monitor: mlzrzut_ekranu193.png

Formatowanie nic nie daje spowrotem pojawia się nie rozpoznane. Partycja jest dobra, ponieważ Linux Mint znajdujący się na tym samym dysku, poprawnie rozpoznaje i wykorzystuje swap. Po formatowaniu oczywiście zmieniłem uuid w fstab.

Pozdrawiam!


(matiit) #2

Partycja działa ok, więc to może tylko i wyłącznie wina gparted. Jaka wersja?

Zobacz jak cfdisk widzi partycję.


(mati75) #3

cfdisk poprawnie widzi. GParted wersja 0.4.5.


(dragonn) #4

Daj:

fdisk -l

Jako root, jeżeli tam jest wszystko okej to znaczy że to bug w gparted. Pocieszę cię że u mnie też jest taki bug :smiley: :

screenshot6e.th.png

Czyli na 100% to bug w gparted, ale system jej normalnie używa, bo w fdisk jest dobrze. Ale kiedyś tak nie było, pewnie winna jakaś aktualizacja.


(matiit) #5

U mnie tego buga nie ma. Wersja 0.4.6, więc pewnie jak w debianie pojawi się aktualizacja do najnowszej stabilnej to będzie ok.


(roobal) #6

Ja na Sid x86 mam to samo ale się tym nie przejmuję, bo mi wszystko działa jak należy. Natomiast GParted z GParted LiveCD widzie swap normalnie.

Pozdrawiam!


(mati75) #7
debian-mateusz:/home/mateusz# fdisk -l


Disk /dev/sda: 320.1 GB, 320072933376 bytes

255 heads, 63 sectors/track, 38913 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Disk identifier: 0x3bef74b8


   Device Boot Start End Blocks Id System

/dev/sda1 1 1020 8192000 1c Hidden W95 FAT32 (LBA)

Partition 1 does not end on cylinder boundary.

/dev/sda2 * 1021 11346 82943595 7 HPFS/NTFS

/dev/sda3 11347 36354 200876760 5 Extended

/dev/sda4 36355 38913 20555167+ 83 Linux

/dev/sda5 11347 24349 104446566 7 HPFS/NTFS

/dev/sda6 24350 28932 36812916 83 Linux

/dev/sda7 28933 36228 58605088+ 83 Linux

/dev/sda8 36229 36354 1012063+ 82 Linux swap / Solaris

Dobre rozpoznaje.

Myślałem, że znowu z moim dyskiem gorzej, ze 2 tygodnie temu musiałem całe /dev/sda5 odzyskać, bo partycja była uszkodzona :expressionless:

Też zauważyłem, że na ubuntu 9.04 live cd poprawnie działa.

Problem rozwiązany. Dzięki wszystkim za pomoc.

Pozdrawiam!