Dlaczego tak wysoki %CPU przy jednym aktywnym procesie?


(ximve40) #1

Bardzo irytuje mnie wysokie wykorzystanie CPU 35-45% i ciągła praca wentylatora w czasie,gdy mam włączony tylko pulpit i nic innego nie robię.

Wentylator chodzi non stop,raz ciszej,raz glośniej,a temperatura CPU sięga 70-75 stopni C!

Myślałem,że to wina zanieczyszczenia wentylacji itd.Dalem laptopa do czyszczenia,ale nic nie pomogło.

W menedżerze zadań zauważyłem,że,jak tak się dzieje uruchomione są da procesy:proces bezczynności(ok.65%) i svchost.exe(ok.35%).

Z svchost.exe powiązane są uslugi: upnphost - Host urządzenia UPnP

SSDPSRV - Odnajdywanie SSDP

SCardSvr - Karta inteligentna

FontCache - buforowanie czcionek

Tak dzieje się,jak mam połączenie z internetem(LTE Plus-modem Huawei E398),ale nie otwieram nawet przeglądarki.Nie zauważyłem jeszcze,czy tak samo jest po odłączeniu modemu.

W Biosie ustawioną mam konfigurację dla CPU frequency - dynamicaly switchable,power management - performance.

Chyba CPU nie powinien być aż tak obciążony?!(jak to piszę wentylator wyje,CPU 42%,temp.71 st.C!)

Jak próbowałem zakonczyć proces svchost.exe to wszystko było niestabilne i wieszało się.

Mam laptopa Toshiba Tecra850,Intel i5 2,5GHz,SSD OCZ Vertex 2 180GB,RAM 8GB,Win7 Ultimate 64bit.

Co z z tym można zrobić?Ten hałas jest nieznośny...


(Deruzejaku) #2

IMO możesz powyłączać te usługi próbnie tym bardziej, że żadna z nich nie jest krytyczna dla systemu, albo pojedynczo wyłączać te usługi żeby zobaczyć która jest za to odpowiedzialna :wink:.

To pewnie pomoże na użycie CPU ale ciągle będziesz miał problem z głośną pracą wentylatora i wysoką temp pracy w stresie. Po specyfikacji kompa wnosząc stary nie jest więc teoretycznie nie powinien mieć problemy z łożyskami wentylatora choć jest to poniekąd możliwe, wysoka temperatura może być skutkiem nie tylko zapchanego radiatora, ale też chociażby braku / starej paście termo-przewodzącej pod radiatorem procesora, więc sprawdziłbym pastę i wymienił na nową dobrej jakości (tubka dobrej pasty z drobinkami srebra na 1 użycie jakieś 15 PLN) i sprawdziłbym czy radiator gdzieś nię nie poluzował albo nie odkształcił.

W sumie to niedawno spotkałem się z i5 desktopową która osiągała w idlu jakieś 60̊C i ponoć wg wypowiedzi pod blaszką miała ona mieć silikon do odprowadzania ciepła od rdzeni, może to ten sam problem odnośnie temperatury.

Możesz napisać jeszcze jakiego programu używasz do pomiaru temperatury i ile stopni pokazuje hardware monitor w BIOSie.


(ximve40) #3

Wyłączyłem na razie Host UPnP i Karta inteligentna i jest znacząca różnica,wentylator nie hałasuje i użycie CPU 9% jak to piszę,temp.40 st.C.

Nie wiem tylko,jak będzie po restarcie,czy za każdym razem trzeba będzie wyłączać te usługi,czy je wyłączyć na stałe ? Na razie wszystko działa stabilnie :slight_smile:

Co do radiatora,to pasta byla jakaś do niczego i teraz jest nowa,ale nie wiem jaka.Układ chłodzenia sprawdzał zaufany informatyk i ma być wszystko ok.Laptopa kupiłem w styczniu z salonu,tokże stary raczej nie jest.

Wcześniej nie zajmowałem się pomiarami temp.itp.dlatego ściągnąłem w ciemno jakiś Speccy(Piriform-od Ccleanera) i CPUCool-nawet ma ciekawe opcje,ale nic w nich nie grzebalem :wink:

W Biosie nie ma nigdzie temperatury hardware....Bios u mnie jest mało skomplikowany i nie ma za dużo opcji,chyba,że ich nie znajduję,bo nie chcę czegoś zepsuć.Niektóre funkcje od nowości są disabled,więc ich dotychczas nie ruszałem.

Na razie dzięki za podpowiedź,zobaczę,jak będzie dalej :slight_smile:


(Deruzejaku) #4

Te serwisy możesz wyłączyć na stałe przestawiając je w services.msc z Automatic na Disabled, wtedy od następnego uruchomienia nie będą się wczytywać.

Osobiście do sprawdzania temperatury używam AIDA64, ale jeśli używałeś dwóch programów i odczyty były takie same to raczej wskazują dobrze.

Swoją drogą możesz ściągnąć AIDA64 i odpalić test stabilności systemu żeby sprawdzić jak bardzo laptop nagrzeje się w stresie, jeśli temperatura przy pełnym obciążeniu przekroczy jakieś 90C to będzie nie najlepiej bo układ chłodzący nie radzi sobie z odprowadzaniem ciepła, 40C w idlu to normalna wartość więc tu jest dobrze.


(ximve40) #5

Dzięki bardzo,wydaje mi się,że jest dobrze :slight_smile:

Ściągnąłem AIDA64 i w teście stabilności temp.nie przekroczyła 70 st.C przez 15 minut,ale wentylatory huczły na maxa.

Tak chyba ma być. :lol:


(Deruzejaku) #6

Dobrze jest, 70C w pełnym stresie to dobry wynik więc nie ma się już czym przejmować :smiley: