Dv6640ew vs. fedora i suse - problem z kernelem i dźwiękiem


(Dp) #1

Witam,

wojuje od dluższego czasu z instalacją linuksa na moim laptopie (hp pavulon dv6640ew, tak wiem, to złom, ale lepszy rydz niż nic.) Próbuje różnych dystrybucji ale na każdej jest jakiś problem dla mnie nie do przeskoczenia.

Fedora 10: po instalacji nie działa regulacja prędkości procesora, hibernacja i regulacja jasności matrycy. Problem stwarza brak kilku opcji w konfiguracji kernela, wiem które trzeba dodac więc próbuje zrekompilowac kernel, wg tego przepisu:

https://fedoraproject.org/wiki/Building_a_custom_kernel

ale problem pojawia się przy poleceniu:

rpmbuild -bb --with baseonly --without debuginfo --target=`uname -m` kernel.spec

a konkretnie, po okolo 10 minutach pracy tego polecenia nagle wywala:

make: *** [.tmp_vmlinux1] Error 1

błąd: Błędny stan wyjścia z /var/tmp/rpm-tmp.rcWOq6 (%build)



Błędy budowania RPM-a:

    Błędny stan wyjścia z /var/tmp/rpm-tmp.rcWOq6 (%build)

i koniec zabawy. Nie wiem co z tym zrobić. Pisałem na różnych forach fedory ale nikt nie potrafi albo nie chce pomoc, no i jestem w kropce.

openSUSE: Po instalacji i rekompilacji kernela wszystko śmiga jakbym chciał ale jest problem z dzwiękiem. Kiedy laptop pracuje na baterii i coś odtworzy dzwięk jakis, nie ważne czy to kadu, foobar, amarok, czy alsamixer z glośników słychać naprawdę głośny trzask, jakby stare głośniki włączyć. jak wylacze to co gralo, po okolo 5 sekundach słychać cichy trzask, jakby glośniki sie wyłączyły. i ponownie, cokolwiek bym nie właczył to wpierw glośne bum i dopiero gra. Problem występuje na suse 11.0 i 11.1rc1, na 10.3 nie ma tego. Także i w tym przypadku ani na polskim ani na oficjalnym forum suse nie otrzymałem pomocy, dlatego pisze tu, bo moze ktos na tym świecie wie jak to naprawic...

co ciekawe, na ubuntu 8.04 działa wszystko jak należy i to "out of box", na 8.10 juz nie. ale ubuntu nie chce bo mnie denerwuje, druga Vista sie z tego zrobila.