[Excel/OpenOffice Calc] Porównanie kilku kolumn i podmiana


(Nkuchnia) #1

Na wstępie zaznaczę że obecnie korzystam z OpenOffice. Ewentualnie mogę

Witam. Mam następujący problem. Plik exportu i importu danych w pewnym sklepie www wygląda następująco.

image_id: 3494

Niestety kolumny kategoria,cena,nazwa są niezbędne do importu danych.

A ja potrzebuję funkcję która znajdzie W Arkuszu z Obrazka powyżej wartość kolumny Symbol i odnajdzie go w arkuszu ze zdjęcia poniżej

image_id: 3495

jeśli wartość z kolumny Symbol w Arkuszu 1 = Wartość z kolumny Symbol w Arkuszu 2 to Podmieni dane z kolumny Dostępne w Arkuszu 1 na dane z Arkusza2 z komuny dostępne

W arkuszu 2 jest około 1200 wierszy w arkuszu 1 będzie ich maksymalnie max 500.

Finalnie wynik działania powinien być taki.

image_id: 3496

Przykładowy plik.

http://www.sendspace.pl/file/280a074af532dd79c4a0d66

Proszę o pomoc


(Gregorsi) #2

O coś takiego ci chodzi?

=WYSZUKAJ.PIONOWO(A2;Arkusz2!$A$1:$B$860;2;0)

(Nkuchnia) #3

Sorrki za takie pytanko ale. Gdzie to wkleić żeby zadziałało ? ;>


(Gregorsi) #4

W Arkusz1 w komórkę H2 na przykład.


(Nkuchnia) #5

"Błąd: Nieprawidłowa nazwa"


(Gregorsi) #6

OpenOffice?

To tak.

=WYSZUKAJ.PIONOWO(A2;Arkusz2.$A$2:$B$860;2;0)

(Nkuchnia) #7

Prawie działa ;] Zerknij proszę do tego pliku Dlaczego w pewnym momencie zaczął wpisywać w Arkuszu 1 #N/D choć taki numer znajduje się w Arkuszu 2

http://www.sendspace.pl/file/fb469531e94693388803485


(Gregorsi) #8

Domyślam się ze nie znalazł odpowiednika w Arkuszu2.

Trzeba by opisać kontrolę błędów.

Zaraz zerknę.

-- Dodane 02.12.2010 (Cz) 13:58 --

=JEŻELI(CZY.BŁĄD(WYSZUKAJ.PIONOWO(A2;$Arkusz2.$A$1:$B$860;2;0));"nie znalazłem";WYSZUKAJ.PIONOWO(A2;$Arkusz2.$A$1:$B$860;2;0))

-- Dodane 02.12.2010 (Cz) 14:00 -- Moment, jeszcze zakres trzeba zmienić. -- Dodane 02.12.2010 (Cz) 14:04 -- Wklej w B2 i powinno być ok.

=JEŻELI(CZY.BŁĄD(WYSZUKAJ.PIONOWO(A2;$Arkusz2.$A$1:$B$10000;2;0));"nie znalazłem";WYSZUKAJ.PIONOWO(A2;$Arkusz2.$A$1:$B$10000;2;0))

(Nkuchnia) #9

Dziękuję Ci BARDZO !!