Filmy w rozdzielczości 1080


(Bond87) #1

Nie wiem, czy dobry dział, ale niech będzie tu.

Zaznaczam, że nie jestem jakimś super znawcą.

Mam problem z odtwarzaniem filmów full HD. Weźmy przykład "Avtara?. Film x264, rozdzielczość 1920 x 1080. Film ogólnie działa płynnie, ALE:

  • zdarzają się kilkusekundowe zacinki obrazu i dźwięku

  • lecz większym problemem jest to, że dźwięk wyprzedza obraz.

Nie uważam, żebym miał za słaby komputer do oglądania filmów hd, (na YT chodzą płynnie), sprzęt ma kilka lat, ale szukałem w sieci i czytałem, że na słabszych kartach graficznych działają ok.

Moja konfiguracja jest w podpisie, monitor połączony z grafiką kablem DVI, dość grubym, mam zainstalowane kodeki z paczki K-lite kodec pack oraz CoreAVC Proffesional.

Pozdrawiam i proszę o pomoc.


(PaPuX) #2

Twój sprzęt jest na granicy możliwości odtwarzania tego rodzaju kompresji z tą rozdzielczością.

Przy kompresjach x264 jest spory bitrate i duże przetwarzanie zmiennoprzecinkowe.

Opóźnienia dźwięku to typowy objaw niewyrabiania się procesora.

Do tego typu filmów używa się procesorów 4 rdzeniowych i kart graficznych z przyśpieszeniem sprzętowym.

Proponuje sprawdzić obciążenie procesora podczas odtwarzania filmu.


(MaRa) #3

:o :o :o

U mnie filmy FullHD DivX bez problemu chodzą na Core2Duo 1.8GHz i grafice GF210. Wcześniej miałem sprzęt z CeleronemD 2,66 (2005 rok) i GF6200a, też chodziły. U kolegi te same filmy chodzą, ma Pentium4 3GHz i Radeon x1300.

Właśnie sprawdziłem krótki filmik FullHD h264 1920x1080, bez problemu się odtwarza, obciążenie procesora 17%. W filmach DivX dochodziło do 30%.

H264 wymaga wydajnego sprzętu przy kodowaniu, ale dekodowanie nie obciąża zbytnio.

Problemy prawdopodobnie wynikają z odtwarzacza, nie każdy program poprawnie odtwarza każdy film, nawet jeśli teoretycznie wspiera dany format.


(Bond87) #4

Włączyłem podczas filmu menadżer urządzeń i pokazuje obciążenie procesora około 50%. Czyli jak interpretować ten wynik?

tak samo jest na Media Player Classic i na Windows media Player 11

Co ciekawe mam jeszcze "Incepcję" w tej rozdzielczości i formacie, sprawdziłem, tam działa wszystko płynnie i nic niczego nie wyprzedza oraz nie ma zacinek.

To ja już nie wiem :frowning:


(Bambosz107) #5

Może weź pod uwagę korzystanie tylko z jednej paczki kodeków - KLite? Ja ich używam, jestem bardzo zadowolony. Nie potrzebujesz do nich już żadnych innych, być może, że twoje się "gryzą" ze sobą. Nie zaszkodzi też aktualizacja sterowników do karty graficznej i DirectX, dla świętego spokoju.


(Bond87) #6

Jak napisałem w pierwszym poście, mam zainstalowane kodeki z paczki K-lite kodec pack oraz CoreAVC Proffesional.

A sterowniki do karty aktualizowane w poniedziałek były.


(PaPuX) #7

Jak napisałem sprawdzić obciążenie procesora podczas odtwarzania oraz bitrate jakim dysponuje film który nie działa płynnie.


(Bambosz107) #8

Tak jak mówiłem, wyrzuć CoreAVC Proffesional, zostaw samo K-Lite (oczywiście w najnowszej wersji).


(Bond87) #9

Napisałem w drugim swoim poście, ok 50%

Dane filmu działającego dobrze:

Całkowita przepływność bitów : 7.180 Kb/s

Przepływność bitów : 6.180 Kb/s

Szerokość : 1.920 pikseli

Wysokość : 1.080 pikseli

Proporcje obrazu : 16:9

Szybkość wyświetlania klatek : 23,976 kl/s

Audio

Format : AC-3

Format/Informacja : Audio Coding 3

Film nie działający dobrze:

Runtime ..: 02:41:42

Size .....: 10.9gb

Video ....: 1920x1080 (X264 @ 23.976fps)

Bitrate ..: 8171kbps

Audio ....: DTS 1509kbps

Source ...: Retail R2 Blu-Ray

Lang .....: English

Subs .....: English, English(forced)

Może jakiś niewłaściwych do tego filmu kodeków używam, wiem, że audio TDS zabiera sporo zasobów, ale na słabszych kompach takie filmy działają raczej.

Jeden z nie działających dobrze filmów:


(Bond87) #10

Jak napisałem w 1. poście nie jestem ekspertem i proszę o wyrozumiałość :wink:

Więc jak mam użyć mocy swojej karty,, co to znaczy? :slight_smile:

Bo i jeszcze jedno, zainstalowałem teraz VLC Media Player, obraz jest z dźwiękiem schynchronizowany, ale co chwila jest przycinka i przeskok.


(Bond87) #11

Pisałem jakiego! Czytacie chociaż co ja piszę, czy tylko wybiórczo?

Media Player Classic, teraz wgrałem VLC,


(Krzysztofjaroszek) #12

Ja bym najpierw poszperał w necie, oto pierwszy z brzegu link z googla http://www.noweprogramy.com/index.php?str=artf&no=716.

Chyba wszystko jasne, jedno jest pewne bez wsparcia GPU nic nie zrobisz.

-- Dodane 22.01.2011 (So) 22:01 --

zapomniałem dodać, że jeśli wszystkie darmochy zawiodą zapoznaj się z tym

http://www.mirillis.com/en/products/splashpro_features.html


(Bond87) #13

Napisu nie widzę niestety, a po zaznaczeniu wszystkiego w filtrach wewnętrznych mam pokaz slajdów zamiast filmy.

Widzę, że już se pooglądałem :expressionless:


(Bond87) #14

Wypróbuję.

-- Dodane 22.01.2011 (So) 22:55 --

Problem rozwiązany.

Przy DTS trzeba było zaznaczyć zamiast pierwszej, tę opcję:

46130362.png

I kilka "next" dalej były do wyboru dwie opcje odnośnie x264, jedna była NIE zalecana, więc zaznaczyłem tę drugą i teraz działa, obraz idzie w parze z dźwiękiem i nic się nie zacina.

Ale za wszelkie sugestie i podpowiedzi bardzo Wam dziękuję :wink:

Macie całusa od tej Pani z mojego avatarka :slight_smile:

-- Dodane 22.01.2011 (So) 22:57 --

Użycie procesora około 10%

-- Dodane 23.01.2011 (N) 10:17 --

A jeszcze mam pytanie. Windows XP obsługuję DirectX w wersji 9.0c maksymalnie. 10 i 11 to już półka siódemki. Czy np. po zainstalowaniu Windows 7 jakość odtwarzanych filmów będzie wyższa?