Firefox - zawieszanie się programu (wszystko czarne)


(piosol) #1

Witam,

posiadam problem z FF w wersji 35. We wcześniejszej wersji problem też występował. Od czasu do czasu firefox się zawiesza. Często na FB gdy oglądam jakiś film. Wyłączenie wszystkich pluginów nie pomaga. Pracuję na zintegrowanej grafice w i7 4790k. Posiadam win 8.1 ze wszystkimi aktualizacjami oraz najnowsze sterowniki do grafiki. Proszę o pomoc.


(Bogdan_G) #2

W zaawansowanych opcjach, ogólne, odznacz korzystanie z akceleracji sprzętowej, jeśli dostępna.


(mrFreeze) #3

Masakra jeżeli chodzi o najnowszego FF. Korzystałem o lat a teraz wciąż problemy u mnie z Flash Playerem głównie. Zaktualizuj FF do 35.0.1 i flash playera http://fpdownload.macromedia.com/get/flashplayer/current/licensing/win/install_flash_player_16_plugin.exe Chyba ostatnia aktualizacja rozwiązała problem.


(piosol) #4

 

A czym takie zachowanie przedlądarki może być spowodowane?


(Bogdan_G) #5

Chodzi o niekompatybilność nowego Firefoxa ze starszymi sterownikami grafiki. Mozilla sama namawia do aktualizacji starszych sterowników. To stało się z chwilą wprowadzenia kdeku cisco do nowych wersji. Znajdziesz go w dodatkach. Najlepiej w dodatkach zaznaczyć - nigdy nie aktywuj. Wyłączenie akceleracji sprzętowej ma sens, żeby nie robiło błędów w Firefoxie z grafiką. Napiszę to inaczej. Mam stary pc z XP i laptop acer 4.5 roku. Producent laptopa dotąd nie aktualizował sterowników, a do XP na pc, to już sporo lat, ostatnia wersja sterowników do grafiki ma też pięć lat. Mógłbym od producentów podzespołów wyszukać choćby do laptopa nowsze sterowniki, ale rzecz w tym, że sprzęty działają, czyli HD video, aplikacje do obrazów i tam wszystko, co potrzebuję, net, biuro itd. Dla jednego Firefoxa nie będę zmieniał sterowników, nie mając gwarancji, czy np w grach nie będzie problemów. No, ale jest taki twór Firefox i można ominąć wszystko, co może sprawiać problemy. Dopóki można, bo inaczej FF będzie tylko wspomnieniem.

 

Prawie w połowie tej strony, Mozilla pisze o potrzebie aktualizacji sterów grafiki. Dotyczy to wersji 33.01, czyli od tej, co zaczęło się dziać, czyli błędy w wyświetleniu pasków, w menu, błędy wyświetlania okien, czy wyświetlania wideo:

http://translate.google.com/translate?hl=pl&sl=auto&tl=pl&u=https%3A%2F%2Fwww.mozilla.org%2Fen-US%2Ffirefox%2F33.0.1%2Freleasenotes%2F


(piosol) #6

Ale ja mam w miarę nowy procek i najnowsze sterowniki od karty graficznej :frowning: Skoro Mozilla nie może poradzić sobie z Intel HD Graphics 4600 to chyba nie jest dobrze :frowning:


(Bogdan_G) #7

A sprawdź. Kliknij w pomoc i w informacje dla pomocy technicznej. Masz tam wyszczególnienie - Grafika. Na pc pisze u mnie: Okna ze sprzętowym przyspieszeniem grafiki - 0/2 Basic (OMTC) Zablokowane dla zainstalowanej wersji sterownika grafiki. Zalecana jest aktualizacja sterownika do wersji 6.1400.1000.5218 lub nowszej. Tak samo pisze w Renderer WebGL i jeszcze przy Direct2D. Ja musiałem wracać do starszych sterowników, bo działają najlepiej.

 

Ciekawe - co u Ciebie pisze? Jeśli sterownik grafiki masz zgodny z Firefoxem, to pozostaje sprawdzić, jaki masz directx w systemie i jakie masz zainstalowane wersje visual studio C++. Ponadto, od ustawień systemowych zależy też wyświetlenie animacji i tam takie. Ustawienie na najlepszą wydajność, często powoduje niepoprawne wyświetlanie 3D i 2D. To takie sprawy, że wyłączenie w systemie, przenosi się na błędy działania aplikacji. Czasem pomaga powrót do zaawansowanych domyślnych ustawień, czyli - niech system Windows wybierze optymalne ustawienia.

 

Nie tylko Firefox lubi, gdy jest ustawiony “na sztywno” rozmiar stronicowania. Najlepiej ustawić dwa razy 1024MB. Co znaczy na sztywno, to Google Ci powie. To potrzebne do ustawienie bufora, zresztą, poszperaj o tych sprawach w necie.


(piosol) #8

Info z mojego PC:

  • Okna ze sprzętowym przyspieszeniem grafiki: 1/1 Direct3D 10;
  • Renderer WebGL: Google Inc. – ANGLE (Intel® HD Graphics 4600 Direct3D9Ex vs_3_0 ps_3_0);
  • Włączone Direct2D: true;

Na chwilę obecną zmieniłem wartość “layers.offmainthreadcomposition.enabled” na FALSE i na razie wszystko działa dobrze.