Grub nie wyświetla się po instalacji Linux Mint


(Artix57) #1

Cześć!

Mam problem. Zainstalowałem Minta 8 i nie wyświetla mi się Grub. Na dysku zainstalowany jest jeszcze WIndows 7 (sprawdzałem jest w stanie nienaruszonym). Przy włączeniu komputera widnieje dobrze mi znany napis ,,GRUB LOADING'' ale włącza się od razu Mint


(mati75) #2

RC1 czy final?


(Artix57) #3

Pobrane z oficjalnej strony czyli final :wink:


(mati75) #4

Wykonaj w mincie

sudo update-grub2

i powinno pomóc.


(Artix57) #5

Nie pomogło. Terminal wyrzuca

Generating grub.cfg ...

Found Debian background: linuxmint.png

Found linux image: /boot/vmlinuz-2.6.31-14-generic

Found initrd image: /boot/initrd.img-2.6.31-14-generic

Found memtest86+ image: /boot/memtest86+.bin

done

Reset i nic... troszkę dłużej trwało przejście do Minta ale...


(kamil_w) #6

A nie pokazuje się coś jeszcze w międzyczasie? Bo z tego co kojarzę, to w nowym Mincie, żeby pokazało się menu wyboru systemu należy wcisnąć ESC po załadowaniu Gruba.


(Artix57) #7

Pokazuje się takie coś: _ i miga


(mati75) #8

Trochę to dziwne, bo też nie wykrywał innych systemów. Po tym poleceniu wykrył. Nie sformatowałeś całego dysku?


(Artix57) #9

Nie. Specjalnie sprawdzałem. Partycja z Windowsem jest OK

EDIT: A może coś nie tak z plikiem konfiguracyjnym?


(Scofield111) #10

Nie pamiętam ale chyba w tym pliku było ukrywanie gruba /etc/default/grub

Pokaż jego zawartość:

sudo gedit /etc/default/grub

(Artix57) #11
#

# DO NOT EDIT THIS FILE

#

# It is automatically generated by /usr/sbin/grub-mkconfig using templates

# from /etc/grub.d and settings from /etc/default/grub

#


### BEGIN /etc/grub.d/00_header ###

if [-s /boot/grub/grubenv]; then

  have_grubenv=true

  load_env

fi

set default="0"

if [${prev_saved_entry}]; then

  saved_entry=${prev_saved_entry}

  save_env saved_entry

  prev_saved_entry=

  save_env prev_saved_entry

fi

insmod ext2

set root=(hd0,7)

search --no-floppy --fs-uuid --set d3edc0ce-15b9-4090-8cac-593338b38fb0

if loadfont /usr/share/grub/unicode.pf2 ; then

  set gfxmode=640x480

  insmod gfxterm

  insmod vbe

  if terminal_output gfxterm ; then true ; else

    # For backward compatibility with versions of terminal.mod that don't

    # understand terminal_output

    terminal gfxterm

  fi

fi

if [${recordfail} = 1]; then

  set timeout=-1

else

  set timeout=10

fi

### END /etc/grub.d/00_header ###


### BEGIN /etc/grub.d/05_debian_theme ###

set menu_color_normal=white/black

set menu_color_highlight=black/white

### END /etc/grub.d/05_debian_theme ###


### BEGIN /etc/grub.d/06_mint_theme ###

insmod ext2

set root=(hd0,7)

search --no-floppy --fs-uuid --set d3edc0ce-15b9-4090-8cac-593338b38fb0

insmod png

if background_image /boot/grub/linuxmint.png ; then

  set color_normal=white/black

  set color_highlight=white/light-gray

else

  set menu_color_normal=white/black

  set menu_color_highlight=white/light-gray

fi

### END /etc/grub.d/06_mint_theme ###


### BEGIN /etc/grub.d/10_linux ###

menuentry "Linux Mint 8 Helena, linux 2.6.31-14-generic (/dev/sda7)" {

        recordfail=1

        if [-n ${have_grubenv}]; then save_env recordfail; fi

	set quiet=1

	insmod ext2

	set root=(hd0,7)

	search --no-floppy --fs-uuid --set d3edc0ce-15b9-4090-8cac-593338b38fb0

	linux	/boot/vmlinuz-2.6.31-14-generic root=UUID=d3edc0ce-15b9-4090-8cac-593338b38fb0 ro quiet splash

	initrd	/boot/initrd.img-2.6.31-14-generic

}

menuentry "Linux Mint 8 Helena, linux 2.6.31-14-generic (recovery mode)" {

        recordfail=1

        if [-n ${have_grubenv}]; then save_env recordfail; fi

	insmod ext2

	set root=(hd0,7)

	search --no-floppy --fs-uuid --set d3edc0ce-15b9-4090-8cac-593338b38fb0

	linux	/boot/vmlinuz-2.6.31-14-generic root=UUID=d3edc0ce-15b9-4090-8cac-593338b38fb0 ro single 

	initrd	/boot/initrd.img-2.6.31-14-generic

}

### END /etc/grub.d/10_linux ###


### BEGIN /etc/grub.d/20_memtest86+ ###

menuentry "Memory test (memtest86+)" {

	linux16	/boot/memtest86+.bin

}

menuentry "Memory test (memtest86+, serial console 115200)" {

	linux16	/boot/memtest86+.bin console=ttyS0,115200n8

}

### END /etc/grub.d/20_memtest86+ ###


### BEGIN /etc/grub.d/30_os-prober ###

if [${timeout} != -1]; then

  if keystatus; then

    if keystatus --shift; then

      set timeout=-1

    else

      set timeout=0

    fi

  else

    if sleep --interruptible 3 ; then

      set timeout=0

    fi

  fi

fi

### END /etc/grub.d/30_os-prober ###


### BEGIN /etc/grub.d/40_custom ###

# This file provides an easy way to add custom menu entries. Simply type the

# menu entries you want to add after this comment. Be careful not to change

# the 'exec tail' line above.

### END /etc/grub.d/40_custom ###

(Scofield111) #12

Nie grub.cfg tylko pokaż to co się pojawi w edytorze gdy wpiszesz to:

sudo gedit /etc/default/grub

(Artix57) #13

Sorki pomyłka :wink:

# If you change this file, run 'update-grub' afterwards to update

# /boot/grub/grub.cfg.


GRUB_DEFAULT=0

GRUB_HIDDEN_TIMEOUT=0

GRUB_HIDDEN_TIMEOUT_QUIET=true

GRUB_TIMEOUT="10"

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX=""


# Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console


# The resolution used on graphical terminal

# note that you can use only modes which your graphic card supports via VBE

# you can see them in real GRUB with the command `vbeinfo'

#GRUB_GFXMODE=640x480


# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true


# Uncomment to disable generation of recovery mode menu entrys

#GRUB_DISABLE_LINUX_RECOVERY="true"

(Scofield111) #14

Wykomentuj linijkę:

GRUB_HIDDEN_TIMEOUT=0

czyli dodaj: # na początku linijki, tak aby było jak tutaj:

#GRUB_HIDDEN_TIMEOUT=0

Zapisz plik i przed restartem systemu w terminalu wpisz:

sudo update-grub

(Artix57) #15

Nic z tego ;(


(Scofield111) #16

A

sudo update-grub2

i restart ?

A jak nie to spróbuj coś pokombinować z opcją bo ja pomysłu już nie mam :frowning:


(Artix57) #17

Tak zrobiłem. Sprobuję jeszcze z tym.

EDIT:

Zrobiłem tak:

i GRUB się włączył ale nie ma tam Windowsa. Dodał bym go ale nie wiem jak te partycje bo mam trochę numery pomieszane.


(kamil_w) #18

numer partycji możesz podejrzeć w gparted

tak mi się przynajmniej coś kojarzy


(Artix57) #19

Tak, ale coś mi się o uszy obiło, że w GRUBie się jakoś inaczej liczy.


(marcin82) #20

Grub liczy od zera, nie wiem jak w wersji 2.0.