GTK problem


(Przemock) #1

Potrzebuję zainstalować gtk+-2.6.0. Przy instalacji pojawił się komunikat, że potrzebne jest Glib>=2.6.0. Zainstalowalem wiec glib-2.6.0 ale błąd nadal występuje. Proszę pomozcie

Oto komunitkat jaki otrzymuje:

error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pan go >= 1.7.0) not met; consider adjusting the PKG_CONFIG_PATH environment variabl e if your libraries are in a nonstandard prefix so pkg-config can find them.

Prosze pomozcie!!


(Wiki Yu) #2

to znaczy że potrzebujesz:

"Glib" nowsze lub równe 2.6.0

"atk" nowsze lub równe 1.0.1

"pan go" nowsze/równe 1.7.0

i któregoś z nich wciąż nie ma


(Przemock) #3

Tak, ale jest problem. Przy instalcji atk pokazuje się komunikat, że nie ma Gliba większego niż 2.5.7. Co robić?

GLIB 2.5.7 or better is required. The latest version of

GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed

but not in the same location as pkg-config add the location of the file

glib-2.0.pc to the environment variable PKG_CONFIG_PATH.


(Czarno to widzę...) #4

Uaktualnij rpm-a z opcją --force (ewentualnie także --replacepkgs), a później doinstaluj brakujące rzeczy.

Zainstaluj też pakiety -devel.

A może warto byłoby zainteresować się apt-getem? Wtedy program sam rozwiązałby za Ciebie zależności...


(Przemock) #5

A moglbys mi dokladnie powiedziec jak dziala apt-get? Jestem zielony z Linuxa, napisz jak zainstalowac cokolwiek apt-getem w Knoppixie.


(Czarno to widzę...) #6

Działa tak samo, jak Dodaj/Usuń programy w Windows, z tym że masz dużo większy wybór, a programy instalują się z sieci.

apt howto

Tu znajdziesz wiele przydatnych informacji


(Przemock) #7

To jak np. zainstalowac GTK za pomocą apt-get?


(Czarno to widzę...) #8

apt-get install gtk