Ikony programów zainstalowanych na c: na biało; reszta ok


(LonngerM) #1

Witam

Dziś dostałem nowe ramy, wyłączyłem laptopa otwarłem obudowę, wyciągnąłem kości... no i niestety te kości nie pasowały (mała pomyłka, zresztą nie ważne), więc włożyłem stare kości tak jak były zamknąłem obudowę, uruchomiłem ponownie komputer i...

I zauważyłem, że ikony na pulpicie i w menu start się troszkę "zepsuły" tzn. Ikony programów zainstalowanych na dysku C są w formie białych prostokątów, programy na dysku D - wszystko ok, ikony systemowe - wszystko ok (screen).

fc4407827915b373m.png

Próbowałem wyłączyć AERO, usuwałem "IconCache.dll" lecz to nic nie pomaga... ktoś ma jakieś pomysły?


(Łukash) #2

Chodzi oczywiście o IconCache. db

Spróbuj takiego triku .C:\Users\AppData\Local\ i usuń plik "IconCache.db".Stwórz nowy plik tekstowy i zmień mu nazwę i rozszerzenie na "IconCache.db" .We właściwościach pliku ustaw atrybut Tylko do odczytu > Restart systemu > Następnie usuń atrybut Tylko do odczytu i...przy dobrych wiatrach zaskoczy :wink:


(Jakubdelik) #3

miałem też taki problem wyczyściłem http://www.dobreprogramy.pl/CCleaner,Pr ... 13061.html i po resecie wróciło do normy


(LonngerM) #4

Tak, tak chodzi o "IconCache.db" mała pomyłka;P

Spróbowałem obu sposobów i żaden nie zadziałał.


(Łukash) #5

Sprawdź klucze rejestru czy maja takie wartości jak podam:

klucz nr 1:

HKEY_CLASSES_ROOT\lnkfile\shellex\IconHandler

wartość:

{00021401-0000-0000-C000-000000000046}

klucz nr 2:

HKEY_CLASSES_ROOT\piffile\shellex\IconHandler

wartość:

{00021401-0000-0000-C000-000000000046}


(LonngerM) #6

@Łukash

Mam dokładnie takie wartości rejestru.


(Łukash) #7

-o Odkryj ukryte pliki i foldery oraz ukryte pliki systemowe .Pojawią się na pulpicie dwa pliki desktop.ini .Podaj ich zawartość.

Czy te ikony działają normalnie ,program odpala po kliknięciu ?


(LonngerM) #8

Pojawił się jeden:

[.ShellClassInfo]

LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21769

IconResource=%SystemRoot%\system32\imageres.dll,-183

Programy działają normalnie, uruchamiają się poprzez te skróty.


(Łukash) #9

Tak ten plik z tego co widzę ma wyglądać.

Oraz pobierz i odpal http://www.thewindowsclub.com/repair-fi ... in-utility > Additional Fixes > Fix corupted desktop icons.

-- Dodane wtorek, 1 lut 2011, 19:33 --

A może to ma jakiś związek ze strzałką skrótu na ikonach ? Coś zmieniałeś ,usuwałeś strzałkę ?


(LonngerM) #10

Tak owszem, zaraz po instalacji systemu który był... jakieś 4 miesiące temu programem sunrise seven


(Łukash) #11

Próbowałeś tego http://www.thewindowsclub.com/repair-fi ... in-utility .I spróbuj może przywrócić strzałkę #-o


(LonngerM) #12

Fix nie dał rady, a po przywróceniu strzałek to prócz białych prostokącików dodatkowo mają strzałeczkę...


(Łukash) #13

A jak usuniesz skrót np do CCleaner i zrobisz nowy skrót na pulpit ręcznie to co się dzieje ?


(LonngerM) #14

Już podczas wyszukiwania lokalizacji nie widzi ikon, tak samo jak w menu start - wygląd taki sam jak na pulpicie


(Łukash) #15

Może to brutalne ,ale spróbuj przywrócić system.


(LonngerM) #16

Spróbujemy... ale za 30 minut, muszę zrobić kopie plików których nie mogę utracić - ostatnie dwa dni pracy (33 GB)


(Łukash) #17

Spróbuj i daj znać .


(LonngerM) #18

Coś było dziś instalowane (jakaś aktualizacja) ale po przywróceniu systemu nic się nie poprawiło.


(Łukash) #19

Masakra normalnie :o .Ja nie mam na to pomysłów ,może ktoś inny będzie miał ,jeżeli nie to sprawdź instalację naprawczą http://www.sevenforums.com/tutorials/34 ... stall.html ,to już musi zaskoczyć #-o


(LonngerM) #20

To już spróbuję jutro... dziś daje sobie spokój... albo poczekam już jak dostane te prawidłowe ramy i wtedy walnę formata... już nie mam ochoty się z tym bawić...

Łukash dzięki za pomoc do końca:)