Instalacja najnowszego Mozilla Firefox (3.5.2) na Ubuntu


(Dawiddek55) #1

Witam.

Jestem mega zielony i mam ubuntu. Jak widze mam FF 3.0.8 a jak wiemy jest już 3.5.2 Pobrałem sobie z DP FF na linuxa jednak są tam pliki instaacyjne które jak wiem trzba skonfigurować tak by dal sie zainstalować ( kompilacja chyba) czytałem o tym na google ale nie za bardzo wiem jak mam zainstalować.

w dodaj/usuń jest 3.0.8 a w terminalu pisze że mam najnowszą wersję


(Marcin_S) #2

Ściągasz wersję z firefox.pl, rozpakowujesz do wybranego folderu i uruchamiasz plik firefox, bez żadnej kompilacji.


(Monczkin) #3

Jaką wersję ubuntu? 8.10 czy 9.04?

Zaktualizuj system, nowa wersja powinna się zainstalować z repozytoriów.

Jeśli nie, to spróbuj tego

http://czytelnia.ubuntu.pl/index.php/20 ... erpliwych/


(roobal) #4

Ostatnio rozchwytywany jest ten FF 3.5 :slight_smile: Tu masz rozwiązanie tego samego problemu :slight_smile: http://forum.linux.pl/viewtopic.php?id=14705

Pozdrawiam!


(Dawiddek55) #5

9.04

już ostatnio zaaktualizowałem i po resecie mogłem się pożegnać z linuxem.

zaraz sprawzę linki-dzięki.

-- Dodane 26.08.2009 (Śr) 15:21 --

działa, ale to jest 3.5b4-a nie 3.5.2 ale mniejsza już o to i jest po ang. a we wtyczkach jest spolszczenie ale nie kompatybilne (tak pisze)


(Brtx) #6

O masz. Zrób jak pisze Marcin_S w drugim poście albo roobal w linku i będzie po polsku i w wersji jakiej chcesz...


(matiit) #7

Njalepszy pomysł jednak to aktualizacja systemu.


(Marcin_S) #8

Nie wiadomo jedynie, czy w repozytoriach jest najnowsza wersja Firefoksa.

Niestety, ale w repozytoriach Ubuntu często są dosyć stare wersje programów.


(mati75) #9

Jest w repozytoria "update".


(Phanyx) #10

Ostatnio natrafiłem na problem z tym, że firefox pomimo tego, że 3.5.2, spolszczony itd. przedstawiał się jako Shiretoko (jego nazwa kodowa), czego taki biedny onet.pl nie mógł przeboleć (nie rozpoznawał przeglądarki) i nie wyświetlał tego zamulającego paska na boku ;p

Weź sobie nie rób problemów i ściągnij normalnie ze strony domowej FF pl na linuksa, skopiuj np. do /opt (musisz przez sudo) i dorób sobie symbolic linka do firefoksa: sudo ln -s /opt/(katalog ff)/firefox /usr/bin/firefox

Skoro jesteś "zielony" to nie zapominaj, że z konsoli w linuksie pliki wykonalne z katalogu, w którym jesteś odpala się tak: ./plik, a nie jak w windowsie: plik.

Czyli krótko:

cd ~/Pulpit

wget http://mozilla-mirror.3347.voxcdn.com/pub/mozilla.org/firefox/releases/3.5.2/linux-i686/pl/firefox-3.5.2.tar.bz2

tar -xvjf firefox-3.5.2.tar.bz2

sudo mv firefox/ /opt/firefox

sudo ln -sf /opt/firefox/firefox /usr/bin/firefox

I z menu już możesz odpalić.


(Dawiddek55) #11

thx wszystkim za odpowiedzi.


(roobal) #12

Jeśli jest w /usr/bin lub /usr/local/bin czy nawet /opt lub podobnym to wystarczy wpisać w terminalu nazwę binarki. I to działa zawsze, jeśli chodzi natomiast o /opt lub tym podobne to właśnie kiedyś VBox mi się tam instalował i też odpalał, gdy wpisałem tylko nazwę binarki i tak samo z innymi plikami, natomiast skrypty odpala się najczęściej w sposób ./skrypt :slight_smile:

Pozdrawiam!


(Brtx) #13

Tak... a wszystko tak naprawdę zależy czy w zmiennej PATH masz ścieżki do /usr/bin i tak dalej. Jeśli wywoływane binarka czy skrypt tam są (np.: w /usr/bin), można je sobie wywołać wpisując plik a będąc gdziekolwiek w katalogach. Jeśli pliku nie ma w ścieżkach zmiennej PATH musimy wywołać go:

  1. Albo podając pełną, bezwzględną ścieżkę do pliku

  2. Albo przechodząc do katalogu z plikiem (cd) i wykonując ./plik

@roobal - rodzaj pliku (skrypt vs binarka) nie ma tu żadnego znaczenia, VBox uruchomił się bez ./, ponieważ stowrzył symlinka w /usr/bin, który domyślnie jest dodany w zmiennej PATH w wielu dystrybucjach.


(system) #14

Najprościej jest ściągnąć skrypt Ubuntuzilla...

Szczerze polecam, bo sam używam...


(Chillout) #15

U mnie wreszcie zadziałało wykonując to w terminalu:

Firefox uaktualniony do najnowszej wersji.

Pozdrawiam.


(Dawiddek55) #16

o- może to sobie zastosuje i będzie dziaało bo to moje Shiretoko 35 to szkoda gadać....

-- Dodane 31.08.2009 (Pn) 9:56 --

działa :slight_smile: