Instalacja urządzenia HP - błąd krytyczny 1603


(Shark13) #1

Witam

Chciałem sobie zainstalować urządzenie wielofunkcyjne HP Photosmart C3180 na drugim laptopie: Lenovo ThinkPad R500 z systemem Vista Business 32bit. Na początku instalacji pojawia się komunikat informujący o błędzie krytycznym 1603. Instalkę z oprogramowaniem urządzenia pobrałem ze strony HP. Próbowałem problem rozwiązać korzystając ze wsparcia na stronie HP, ale albo porady nie pomagają, albo nie mogę lub nie umiem ich zastosować. I tak:

Porada nr 1: zarejestruj składniki Windows: - pliku Atl.dll nie mogę zarejestrować, ponieważ wpisując w polu "Uruchom" regsvr33 Atl.dll wyskakuje błąd

  • nie wiem jak wyrejestrować i zarejestrować ponownie instalatora Windows bo wpisując w wyszukiwaniu msiexes/unregister nic takiego nie znajduję

Porada nr 2: Tymczasowo wyłącz usługi przy pomocy msconfig oraz usługę Windows update - wykonałem bez rezultatu

Porada nr 3: Usuń pliki HP - w "Usługach" wyłączyłem sterownik PML oraz sterownik sieciowy HP, ale nie mogę znaleść dwóch plików HP z rozszetrzeniem dll na komputerze, by je usunąć

(ścieżka C/Windows/system32).

Porada nr 4: Sprawdzić czy mam aktualną wersję instalaora Windows - tak mam, sprawdzone

W związku z powyższym proszę o pomoc i inne porady jak rozwiązać ten problem.


(system) #2

W przypadku urządzeń HP z reguły należy najpierw rozpocząć instalację sterowników i oprogramowania (plik stąd: http://ftp.hp.com/pub/softlib/software1 ... plk_NB.exe) bez podłączonego urządzenia. W trakcie procedury instalator powinien w pewnym momencie zarządać podłączenia urządzenia i kontynuowania instalacji. Być może zrobiłeś inaczej?


(Shark13) #3

Procedurę wykonywałem prawidłowo, dwa razy pobrałem instalkę na nowo. Najpierw zaczynałem instalację bez podłączonego urządzenia, a podłączałem je jak instalator tego zarządał, choć z reguły nawet nie docierałem do tego miejsca i wyskakiwał wspomniany błąd.


(Kurp55) #4

Wczoraj instalowałem HP C 4680 i miałem duży problem z jej zainstalowaniem. Przy instalacji sterowników odłącz całkowicie drukarkę od komputera (wyjmij przewód USB).

Przewód podłącz gdy wyświetli się komunikat aby podłączyć urządzenie. W moim przypadku musiałem odinstalować program antywirusowy ( KIS ) gdyż częściowo blokował instalację sterowników. Samo wyłączenie ochrony nic nie dawało. Przewód do drukarki musi być bardzo dobrej jakości.


(Shark13) #5

Drukarkę zawsze mam odłączoną od komputera. Błąd wyskakuje mi już na początku, po 3% instalacji, więc nawet nie docieram do miejsca gdzie pojawia sie komunikat by podłączyć urządzenie. Mam darmowego antywirusa AVG tutaj pobranego, czy on może szkodzić? Był wyłączany przed instalacją tak jak wszystkie inne procesy i programy na kompie i to nic nie dało. Jest sens odinstalowywać go całkiem, na dwóch innych komputerach nigdy nie przeszkadzał?

-- Dodane 12.06.2012 (Wt) 11:22 --

Pożyczyłem płytkę instalacyjną do urządzenia wielofunkcyjnego HP LaserJet 1010 series i też na samym początku instalacji wyskakuje błąd i instalacja cofa się do punktu wyjścia. Wiem już, że problem nie tkwi po winie mojego urządzenia HP (starszy sprzęt i starsze oprogramowanie w stosunku do laptopa), ale coś trzeba pokombinować z ustawieniami kompa by instalacja poszła. Tylko co?

-- Dodane 12.06.2012 (Wt) 13:19 --

PROBLEM ROZWIĄZANY. Odinstalowałem antywirusa i jednocześnie wyłączyłem zaporę Windows i Windows Update, i pomogło.

ZAMYKAM TEMAT