Instalacja Xfce - dziwny problem z pulpitem


(Kpc21) #1

Witam,

dzisiaj mam problem z instalacją menedżera okien Xfce pod systemem openSuSE 10.3.

Sciągnąłem binarki Xfce (pewnie zapytacie się, dlaczego nie skorzystałem z repozytoriów - otóż wolałem wszystko pościągać spod Windowsa zamiast robić to na wolnym jak ślimak KDE). Uruchomiłem instalatora (./nazwa pliku), jednak okazało się, że nie mam wymaganej biblioteki Glib w wersji >= 2.6.0. Najpierw próbowałem ją ściągnąć z reprozytoriów (zypper install glib), jednak w repozytoriach była wersja 1.2.10. Musiałem ją więc skompilować. W pliku .xfce4.installer-log znalazłem link do strony, z której można pobrać Glib w najnowszej wersji (http://www.gtk.org/). Ściągnąłem ją więc i zabrałem się za kompilowanie według tej instrukcji (link z gtk.org): http://library.gnome.org/devel/gtk/unst ... lding.html. Kompilacja przebiegła bez błędów, jednak installer Xfce wciąż wykrywa starą wersję biblioteki.

Teraz moje pytanie:

co mam zrobić aby zainstalować Xfce, najlepiej z binarek (repozytorium nie wchodzi w grę) ??

Zawartość loga z instalacji Xfce:

##

## Started installation of xfce4 at 10:23h

##

## Visit http://forum.xfce.org/ if you have problems using this installer.

##


# Environment variables

PATH is set to "/opt/kde3/bin:/home/USER/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin:/bin:/usr/bin:/usr/local/ssl/bin:/usr/local/bin:/opt/openssl/bin:/usr/local/openssl/bin:/usr/pkg/bin:/usr/ucb:/usr/X11R6/bin:/usr/X11R6/bin:/usr/openwin/bin:/usr/local/bin:/opt/local/bin:/usr/pkg/bin:/opt/gnome2/bin:/opt/gnome/bin:/opt/xfce4/bin:/opt/xfce/bin:/root/local/bin:/root/xfce/bin:/root/xfce4/bin"

PKG_CONFIG_PATH is set to ":/usr/lib/pkgconfig:/usr/lib/pkgconfig"


## Checking for usable C compiler

gcc --version

gcc (GCC) 4.2.1 (SUSE Linux)

Copyright (C) 2007 Free Software Foundation, Inc.

This is free software; see the source for copying conditions. There is NO

warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


## Checking for usable C++ compiler

g++ --version

/tmp/xfce4-4.4.2-installer/bootstrap.sh: line 57: g++: command not found

## Checking for GNU make

gmake --version

GNU Make 3.81

Copyright (C) 2006 Free Software Foundation, Inc.

Ten program jest darmowy; warunki kopiowania są opisane w źródłach.

Autorzy nie dają ŻADNYCH gwarancji, w tym nawet gwarancji SPRZEDAWALNOŚCI

lub PRZYDATNOŚCI DO KONKRETNYCH CELÓW.


Ten program został zbudowany dla i686-pc-linux-gnu


## Checking for package config tool

pkg-config --version

0.21


## Checking for GLib (GModule) >= 2.6.0

pkg-config --atleast-version=2.6.0 glib-2.0 gmodule-2.0
 Please install GLib 2.6.0 or above and the GLib development files. It is
 important that you install GModule, which is part of GLib as well. GLib
 can be downloaded from http://www.gtk.org/.

[/code]

Poprzedni tytuł tematu (do 25.04.2008 godz. 15:47):

Instalacja Xfce a biblioteka Glib - błąd - openSuSE 10.3


(matiit) #2

Jak kmpilujesz glib’a to daj przy configure tak:

./configure --prefix=/usr

(Kpc21) #3

Czy jeśli już go skompilowałem, mogę po prostu przenieść pliki, czy muszę kompilować go od nowa, a zawartość tamtego katalogu usunąć ??

//To mój 1100 post na tym forum :wink: A pierwszy od chyba miesiąca - dawno ty nie wchodziłem


(Fisiu) #4

Widzę, że co poniektórzy wolą drogę pod górkę…

Jak nie chcesz instalować spod KDE, to uruchom system w trybie init3. Wystarczy dopisać “3” w opcjach uruchamiania. Komputer uruchomi się bez środowiska graficznego, wtedy zaloguj się jako root i uruchom “yast2”. Dodaj sobie repozytoria XFCE i instaluj.

Zdecydowania prostsze i szybsze rozwiązanie.

Pozdrawiam.


(Kpc21) #5

Problem w tym, że Yast pod konsolą zamula mi tak samo jak w trybie graficznym.

Skorzystałbym z Zyppera, ale jak dodać do niego repozytoria ??


(Fisiu) #6

Zamula? A jaki masz net?

Jak chcesz dodać repozytorium za pomocą zypper to

man zypper

No i tu masz co i jak → http://en.opensuse.org/Zypper/Usage

Czytanie nie boli.


(Kpc21) #7

Teraz mam inny problem.

Gdy usunę coś z pulpitu lub coś na nim zapiszę, na pulpicie tego nie widać. Mam tylko to, co w /home/NAZWA/Desktop było wcześniej, przed restartem systemu. W /home/NAZWA/Desktop te pliki się pojawiają. Czy możecie mi pomóc ??

Dodam jeszcze, że ostatnio po wejściu do folderu Smietnik (tak w ogóle to dlaczego na pulpicie mam 2 “kubły”: Śmietnik i Kosz ??), pulpit w Xfce zmienił się w ten z KDE. To znaczy, że cały menedżer okien był z Xfce, a tylko sam pulpit (tapeta, ikony i funkcje - mogłem zaznaczać ikony przez przeciągnięcie myszką, co w pulpicie z Xfce było niemożliwe) zmienił się na ten z KDE. To tak, jakby załadowały się po części oba środowiska (i tak pewnie się stało). Czy możecie wytłumaczyć to zjawisko ??