Instalacja z pakietów deb w Kubuntu


(Kefas) #1

Witam!

Używam systemu Kubuntu 6.06.

Pobrałem sobie programy z rozszerzeniem deb.

Po wpisaniu komendy instalacyjnej pojawił się błąd. Czego mi brakuje ?

Oto tekst skopiowany z konsoli:

root@piotr-desktop:/home/piotr# dpkg -i cairo-clock_0.3.2-1_i386.deb

(Odczytywanie bazy danych ... 81086 plików i katalogów obecnie zainstalowanych.)

Przygotowanie do zastąpienia cairo-clock 0.3.2-1 (wykorzystując cairo-clock_0.3.2-1_i386.deb) ...

Rozpakowanie pakietu zastępującego cairo-clock ...

dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie cairo-clock:

 cairo-clock zależy od librsvg2-2 (>= 2.13.4); jednakże:

  Pakiet librsvg2-2 nie jest zainstalowany.

 cairo-clock zależy od librsvg2-2 (>= 2.13.93); jednakże:

  Pakiet librsvg2-2 nie jest zainstalowany.

dpkg: błąd przetwarzania cairo-clock (--install):

 problemy z zależnościami - pozostawiony nieskonfigurowany

Wystąpiły błędy podczas przetwarzania:

 cairo-clock

Gdzie masz szukać pakietów librsvg2-2 ? Podobny problem występuje z inną aplikacją z rozszerzeniem deb.:

root@piotr-desktop:/home/piotr/Downloads# dpkg -i foobillard-3.0a_pl.i386.deb

(Odczytywanie bazy danych ... 81086 plików i katalogów obecnie zainstalowanych.)

Przygotowanie do zastąpienia foobillard 3.0a_pl-2 (wykorzystując foobillard-3.0a_pl.i386.deb) ...

Rozpakowanie pakietu zastępującego foobillard ...

dpkg: problemy z zależnościami uniemożliwiają skonfigurowanie foobillard:

 foobillard zależy od libxaw8 (>> 6.8.0); jednakże:

  Pakiet libxaw8 nie jest zainstalowany.

dpkg: błąd przetwarzania foobillard (--install):

 problemy z zależnościami - pozostawiony nieskonfigurowany

Wystąpiły błędy podczas przetwarzania:

 foobillard

Próbowałem wprowadzić komendę z parametrem -f (konsola mi to zasugerowała) ale nie pomaga. Proszę o wskazówki.


(Myszonus) #2

Może sprawdź sudo apt-get install librsvg2-2.


(Kefas) #3

Właśnie stosowałem tą komendę którą Ty podałeś ale niestety nie znalazł nic.

Oczywiście repozytoria edytowałem( korzystałem ze źródeł podanych na forum ubuntu.)


(Myszonus) #4

A jakie masz repo ? skąd ? z ubuntu.pl - ale masz do wersji 6.06 ?


(Kefas) #5

Tak repozytoria są z forum ubuntu.pl. Oczywiście są do mojej wersji dystrybucji czyli 6.06 LTS