Jak to zrobić w excelu?


(lubelmar) #1

Mam następujący problem. Chce w excelu przeliczyć liczbe godzin razy stawkę za godzine. Problem tkwi w tym ze jezeli w dniu pracuje 4 godziny lub mniej to stawka jest 5 zł a jezeli wiecej to 4 zł i wszystko by było ok, gdyby w przypadku 0 godzin nie liczył stawki 5 zł. Jak zrobić lub co dopisać zeby w przypadku 0 godzin nic nie wpisywał w stawkę, albo stawkę 0 wtedy w formatowaniu warunkowym wyklucze z pokazywania to 0?? Proszę o pomoc i pozdrawiam


(sdar) #2

Nie bradzo rozumiem o co Ci chodzi. Przecież jeżeli liczba godzin wynosi 0 to pomnożona przez 5 zł i tak da zero. W czym więc problem?

Opisz proszę sprawę dokładniej albo zamieśc w poście zrzut tabeli z jakiej korzystasz.


(Asterisk) #3

Jeżeli komórkę A1 wpiszesz dane,

a w komórkę A2 formułę

=JEŻELI(A1=0;"";JEŻELI(A1>4;"4";"5"))

uzyskasz ten efekt


(lubelmar) #4

Funcja jest taka że JEZELI suma godzin jest mniejsza od 4 to stawka 4zł (prawda) jezeli nie to 5 zł (fałsz), w związku z tym gdy godziny są 0 to też stawka wskakuje 4 zł, a chce żeby była wtedy 0 lub wogóle.

Złączono Posta : 09.09.2006 (Sob) 21:32

ok. asterisk to o tą formułę chodziło jest tak jak chciałem, dzięki wielkie

Złączono Posta : 09.09.2006 (Sob) 22:26

a może wiecie jak do tego na końcu dołączyć zł, bo format> komórki> walutowe nie działa. Pewnie dlatego ze to funkcja


(Skiff) #5

Można wpisać zamiast

=JEŻELI(A1=0;"";JEŻELI(A1>4;"4";"5"))

=JEŻELI(A1=0;"";JEŻELI(A1>4;"4 zł";"5 zł"))

tylko wówczas możesz zapomnieć o wszystkich operacjach liczbowych, ponieważ te ciągi będą interpretowane jako tekst.