Klaster na Debianie , problem z benchmarkami


(ant0n) #1

Zbudowałem sobie klaster z kilku starych blaszaków. Postępowałem wg wskazówek zawartych na www.debianclusters.org . Udało się, komputery "widzą się" i liczą wspólnie zadania. Problem pojawił się, gdy chciałem zainstalować oprogramowanie do przeprowadzenia testów wydajnościowych tegoż to ustrojstwa. Znalazłem bardzo fajną paczkę stworzoną do tego celu:

http://icl.cs.utk.edu/hpcc/

Ale tutaj wyłożyłem się na dobre i nie mam zielonego pojęcia jak to skompilować i jak przeprowadzić instalację :frowning:

Napotykam błędy kompilatora, które mówią o nie odnalezieniu potrzebnych plików z pakietów BLAS (http://www.netlib.org/blas/) oraz VSIPL (http://www.vsipl.org/). Nie mam już pomysłów jak zainstalować te benchmarki ;-(

Czy jest tutaj może ktoś na tyle "obcykany", by mi pomógł rozwiązać problem? W "polskim internecie" temat klastrów jest bardzo słabo poruszany i jest mało informacji dostępnych na ten temat. Znalazłem sporo informacji na witrynach uniwerków w Stanach Zjednoczonych. Parę razy nawet pisałem do ludzi zajmującymi się tymi projektami, ale bez odpowiedzi :-/

Czy jest ktoś chętny, by mi pomóc?


(Kaka') #2

Pokaż dokładny błąd wywalany przez kompilator.


(Brtx) #3

Wydaje mi się, iż biblioteki blas i vispl muszą być skompilowane i zainstalowane przed HPCC

Inne benchmarki: http://www.netlib.org/benchweb/hpc.html

Jeden z ciekawszych z w/w stronki, HPL Linpack: http://www.netlib.org/benchmark/hpl/


(ant0n) #4

Dzięki za zainteresowanie tematem.

Barmazu: To, że BLAS i VISPL muszą być zainstalowane wcześniej to wiem, ale nie wiem jak tego dokonać :-/ Umiem instalować programy ze źródeł, ale tych bibliotek nie umiem :frowning:

Jutro wkleję co mi się pokazuje, bo dziś już nie mam energii na działanie i myślenie.


(Brtx) #5

Ściągnąłem BLAS ze strony HPL Linpack i nie wiem w czym problem.

Jest Makefile, wiec robisz po prostu make (bez ./configure), możesz zrobić też

make DESTDIR=

Jeśli rzuca błędami - pokaż je.

PS.: Do kompilacji wymagany jest g77 (staroć gcc3, poniżej pakiety jakie musiałem doinstalować)

gcc3.3

gcc3.3-cpp

gcc3.3-g77

libg2c0


(ant0n) #6

Widocznie mam mniej doświadczenia :-/ Spróbuję wieczorem po pracy. Dzięki!

-- Dodane 14.08.2009 (Pt) 23:39 --

Jakby ktoś miał podobne problemy, to rozwiązanie tutaj: http://forum.dug.net.pl/viewtopic.php?id=14454