Kompilacja gimpshopa


(matiit) #1

Nie moge skompilować gimpshopa :confused:

przy ./configure wyskakuje:

checking for GLIB - version >= 2.4.5... no

*** Could not run GLIB test program, checking why...

*** The test program failed to compile or link. See the file config.log for the

*** exact error that occured. This usually means GLIB is incorrectly installed.

apt-get install glib nie znajduje niczego


(Bartmarian) #2

w gentoo jest glib

dev-libs/glib

      Latest version available: 2.12.11

      Latest version installed: 2.12.11

      Size of files: 2,856 kB

      Homepage: http://www.gtk.org/

      Description: The GLib library of C routines

      License: LGPL-2

do wyboru mam:

ls /usr/portage/dev-libs/glib

ChangeLog glib-2.10.3.ebuild glib-2.12.4-r1.ebuild glib-2.12.9.ebuild metadata.xml

files glib-2.10.3-r1.ebuild glib-2.12.6.ebuild glib-2.8.6.ebuild

glib-1.2.10-r5.ebuild glib-2.12.11.ebuild glib-2.12.7.ebuild Manifest

znaczy w apt-owym distro nazywa się inaczej, może:

apt-cache search glib

?


(matiit) #3

ok było to libglib…

Teraz jest taki problem.

checking for GTK+ - version >= 2.4.4... no

*** Could not run GTK+ test program, checking why...

*** The test program failed to compile or link. See the file config.log for the

*** exact error that occured. This usually means GTK+ is incorrectly installed.

configure: error: Test for GTK+ failed. See the file 'INSTALL' for help.

Nawet doinstalowałem GNOME i tak nie działa.


(Bartmarian) #4

nie wiem jak apt’em sprawdzic czy GTK+ jest, napewno się da,

jeżeli jest, to może “./configure --help” wypisze czy nie trzeba

np podać opcji gdzie GTK+ siedzi (ale sobie improwizuję), a może

wersja jest niższa od 2.4.4 ?


(matiit) #5

Może ktoś wie coś więcej

w ./configure --help nie pisze nic.

Proszę jeszcze kogoś o pomoc.


(Me) #6

Pakiety dev do GTK zainstalowane??


(matiit) #7

Ok doinstalowałem “kilka” pakietów.

Tylko zatrzymało mnie to:

checking for LIBART... configure: error: Package requirements (libart-2.0) were not met:


No package 'libart-2.0' found


Consider adjusting the PKG_CONFIG_PATH environment variable if you

installed software in a non-standard prefix.

wynik dpkg -l

root@2[gimp-2.2.11]# dpkg -l | grep libart

ii libart-2.0-2 2.3.17-1 Library of functions for 2D graphics - runtime f

ii libarts1c2a 1.5.3-0ubuntu0.1 aRts sound system core components

ii libartsc0 1.5.3-0ubuntu0.1 aRts sound system C support library

root@2[gimp-2.2.11]#

(Me) #8

apt-get install libart-2.0-2


(matiit) #9

To samo…


(El Presidento) #10

W źródle, masz plik readme albo install i tam masz wszystkie zależności jakie musisz zainstalować, jak nie szukasz na stronie programu. Bo pokazujesz każdy komunikat, o braku jakiegoś pakietu :x

Czytanie nie boli


(matiit) #11

El Presidento

Zainstalowałem to libart ale nie chce i tak ruszyć

Edit

Ok. Okazało się że libarta musiałem skompilować. Gdy instalowałem z paczki to gimpshop go nie widział.

Na razie robi się make 8)

Już 2 godziny się robi :confused: