Mambo // błąd SQL


(Uziom1986) #1

Podczas instalacji Mambo 4.5.4 PL, po podaniu danych do bazy, wyskakuje następujący błąd:

Wyprzedzając ew. pytania:

  • wszystkie chmody nadane,

  • serwer to mlodzi.pl


(Szuman) #2

A próbowałeś powtórzyć instalację? Rozumiem, że wywala ci to po tym kroku instalatora, który pyta cię o bazę?

Usuń obecną bazę i powtórz instalację. Pamiętaj o tym, że dane mają być poprawne: jeśli niczego nie sknocisz, to nie ma bata żeby się nie udało! Instaluj Mambo na czystej bazie, bez żadnych tabel, bo instalator sam tworzy potrzebne tabele. Miałem kiedyś podobny błąd przy Joomla (pochodny CMS Mambo) i wtedy właśnie instalowałem na istniejącej już bazie. Jeśli ty też tak robisz, to tak jak napisałem: zainstaluj na czystej bd, a później w pliku configuration.php zamienisz bazy. A najlepiej, jak poszukasz pomocy na forum Mambo, bo tam więcej speców :wink:

A tak poza tym, to na twoim miejscu zdecydowałbym się na najnowszą Joomla! - 1.0.10 - praktycznie to samo, co Mambo, ale za to prawdziwa rewolucja w zakresie bezpieczeństwa :wink: Są trzy poziomy bezpieczeństwa do wyboru i wyobraź sobie, że najniższy stopień, to ten, który obowiązywał w starszych wersjach (które były niczym innym jak przechrzczonym Mambo). Pomyśl o tym, bo zapewniam cię, że warto


(Uziom1986) #3

Tak, błąd wyskakuje kiedy instalator powinien przystąpić do drugiego kroku. Wielokrotnie próbowałem powtarzać instalację, po wcześniejszym wyczyszczeniu bazy danych, ale nic z tego...


(Szuman) #4

nie wiem co ci doradzić, najlepiej poszukaj pomocy na którymś z forum Mambo. Mimo wszystko stawiałbym na złe dane wpisywane w instalatorze, np. nazwę i hasło roota zamiast nazwy i hasła użytkownika utworzonego i przypisanego wcześniej do danej bazy. A nie próbowałeś instalować z automatu? Tzn. za pomoca takich narzedzi jak Fantastico - w panelu serwera często są takie narzędzia, za pomoca których 2-3 kliknięciami instalujesz cały skrypt. Jeśli masz dostęp do czegoś takiego, to zainstaluj w ten sposób, a później zrobisz sobie upgrade do 4.5.4 nadpisując pliki.


(Uziom1986) #5

szuman - błędu przy wpisywaniu nie ma, bo w takim wypadki instalator w ogóle nie otworzy kolejnej strony, tylko wyrzuci błąd. Spróbuję poszukać gdzie indziej.


(Szuman) #6

powinieneś od razu zacząć od forum Mambo - tak na chłopski, zdrowy rozum to najrozsądniejsze wyjście... :roll:


(Uziom1986) #7

Tamto Forum trąci myszką. Ostatnie posty były sprzed kilkunastu dni, a ja potrzebowałem doraźnej pomocy...


(L337 Crew) #8

rakos może pobrałeś jakąś 'złą' wersje mambo ?? :mrgreen:

Nieraz wystarczy zły klik i :x ....


(Szuman) #9

Może pobrał najnowszą 4.5.4, bo gdzies mi się obiło o uszy, że instalator jest dość kapryśny :wink:


(Uziom1986) #10

Fakt - pobrałem 4.5.4, ale to już nie istotne. Temat do zamknięcia, zaistalowałem PHP Fushion i nie było problemów...


(Szuman) #11

zatem życzę powodzenia w łataniu dziur :slight_smile: