Naprawianie bad sektorow


(system) #1

Witam

Mam do was pytanie

czy da się w jakiś sposób naprawić bad sektory na dysku twardym. Ostatnio sprawdzałem dysk programem diagnostycznym i wykrył mi takowe.


(Rkizeweter) #2

Nie da się - można je po prostu wyłaczyć z użytkowania (przy pomocy programu) - co niestety zwalnia wszystko - ale cóż.


(Cosik Ktosik) #3

W zasadzie tylko Remap, instrukcja.

Odradzam stosowanie programu HDD Regenerator: http://www.elektroda.pl/rtvforum/topic939301.html


(system) #4

to pewnie one są przyczyna pojawiania się niebieskiego ekranu i resetu komputera


(Cosik Ktosik) #5

Jest to możliwe (głównie błędy 0x0000007A, 0x0000007B).

Aby dowiedzieć się czego dotyczył bluescreen, odczytaj plik DMP. Zrób to wg tej instrukcji :arrow: Klik

Daj raport na forum wg tych zasad :arrow: viewtopic.php?f=16&t=253052


(Kamil2993) #6

hmm.. kiedyś widziałem taki filmik na youtubie jak usuwać bad-sectory z twardziela.Podobno pomagało w 90 % przypadków.

...

O znalazłem !

To

i to :


(Poniaatowski) #7

HDD Regenerator - kilka mc temu wyskoczyły mi dokładnie 2 bad sectory i tym programem wyleczyłem. Kilka razy format robiłem i dalej jest ok.


(system) #8
Microsoft (R) Windows Debugger Version 6.9.0003.113 X86

Copyright (c) Microsoft Corporation. All rights reserved.



Loading Dump File [C]

Mini Kernel Dump File: Only registers and stack trace are available


Symbol search path is: ***Invalid***

****************************************************************************

* Symbol loading may be unreliable without a symbol search path. *

* Use .symfix to have the debugger choose a symbol path. *

* After setting your symbol path, use .reload to refresh symbol locations. *

****************************************************************************

Executable search path is: 

*********************************************************************

* Symbols can not be loaded because symbol path is not initialized. *

* *

* The Symbol Path can be set by: *

* using the _NT_SYMBOL_PATH environment variable. *

* using the -y argument when starting the debugger. *

* using .sympath and .sympath+ *

*********************************************************************

Unable to load image ntoskrnl.exe, Win32 error 0n2

*** WARNING: Unable to verify timestamp for ntoskrnl.exe

*** ERROR: Module load completed but symbols could not be loaded for ntoskrnl.exe

Windows XP Kernel Version 2600 (Service Pack 2) MP (2 procs) Free x86 compatible

Product: WinNt, suite: TerminalServer SingleUserTS Personal

Kernel base = 0x804d7000 PsLoadedModuleList = 0x8055c700

Debug session time: Sun Aug 31 17:27:02.390 2008 (GMT+2)

System Uptime: 0 days 0:11:25.113

*********************************************************************

* Symbols can not be loaded because symbol path is not initialized. *

* *

* The Symbol Path can be set by: *

* using the _NT_SYMBOL_PATH environment variable. *

* using the -y argument when starting the debugger. *

* using .sympath and .sympath+ *

*********************************************************************

Unable to load image ntoskrnl.exe, Win32 error 0n2

*** WARNING: Unable to verify timestamp for ntoskrnl.exe

*** ERROR: Module load completed but symbols could not be loaded for ntoskrnl.exe

Loading Kernel Symbols

...............................................................................................................

Loading User Symbols

Loading unloaded module list

...............

*******************************************************************************

* *

* Bugcheck Analysis *

* *

*******************************************************************************


Use !analyze -v to get detailed debugging information.


BugCheck 19, {20, e206bb11, e206c331, d041706}


***** Kernel symbols are WRONG. Please fix symbols to do analysis.


*************************************************************************

******

******

***Your debugger is not using the correct symbols***

******

***In order for this command to work properly, your symbol path***

***must point to .pdb files that have full type information.***

******

***Certain .pdb files (such as the public OS symbols) do not***

***contain the required information. Contact the group that***

***provided you with these symbols if you need this command to***

***work.***

******

***Type referenced: nt!PVOID***

******

*************************************************************************

*************************************************************************

******

******

***Your debugger is not using the correct symbols***

******

***In order for this command to work properly, your symbol path***

***must point to .pdb files that have full type information.***

******

***Certain .pdb files (such as the public OS symbols) do not***

***contain the required information. Contact the group that***

***provided you with these symbols if you need this command to***

***work.***

******

***Type referenced: nt!_KPRCB***

******

*************************************************************************

*************************************************************************

******

******

***Your debugger is not using the correct symbols***

******

***In order for this command to work properly, your symbol path***

***must point to .pdb files that have full type information.***

******

***Certain .pdb files (such as the public OS symbols) do not***

***contain the required information. Contact the group that***

***provided you with these symbols if you need this command to***

***work.***

******

***Type referenced: nt!KPRCB***

******

*************************************************************************

*************************************************************************

******

******

***Your debugger is not using the correct symbols***

******

***In order for this command to work properly, your symbol path***

***must point to .pdb files that have full type information.***

******

***Certain .pdb files (such as the public OS symbols) do not***

***contain the required information. Contact the group that***

***provided you with these symbols if you need this command to***

***work.***

******

***Type referenced: nt!_KPRCB***

******

*************************************************************************

*************************************************************************

******

******

***Your debugger is not using the correct symbols***

******

***In order for this command to work properly, your symbol path***

***must point to .pdb files that have full type information.***

******

***Certain .pdb files (such as the public OS symbols) do not***

***contain the required information. Contact the group that***

***provided you with these symbols if you need this command to***

***work.***

******

***Type referenced: nt!KPRCB***

******

*************************************************************************

*************************************************************************

******

******

***Your debugger is not using the correct symbols***

******

***In order for this command to work properly, your symbol path***

***must point to .pdb files that have full type information.***

******

***Certain .pdb files (such as the public OS symbols) do not***

***contain the required information. Contact the group that***

***provided you with these symbols if you need this command to***

***work.***

******

***Type referenced: nt!_KPRCB***

******

*************************************************************************

*** WARNING: Unable to verify timestamp for win32k.sys

*** ERROR: Module load completed but symbols could not be loaded for win32k.sys

*************************************************************************

******

******

***Your debugger is not using the correct symbols***

******

***In order for this command to work properly, your symbol path***

***must point to .pdb files that have full type information.***

******

***Certain .pdb files (such as the public OS symbols) do not***

***contain the required information. Contact the group that***

***provided you with these symbols if you need this command to***

***work.***

******

***Type referenced: nt!_KPRCB***

******

*************************************************************************

*************************************************************************

******

******

***Your debugger is not using the correct symbols***

******

***In order for this command to work properly, your symbol path***

***must point to .pdb files that have full type information.***

******

***Certain .pdb files (such as the public OS symbols) do not***

***contain the required information. Contact the group that***

***provided you with these symbols if you need this command to***

***work.***

******

***Type referenced: nt!_KPRCB***

******

*************************************************************************

*********************************************************************

* Symbols can not be loaded because symbol path is not initialized. *

* *

* The Symbol Path can be set by: *

* using the _NT_SYMBOL_PATH environment variable. *

* using the -y argument when starting the debugger. *

* using .sympath and .sympath+ *

*********************************************************************

*********************************************************************

* Symbols can not be loaded because symbol path is not initialized. *

* *

* The Symbol Path can be set by: *

* using the _NT_SYMBOL_PATH environment variable. *

* using the -y argument when starting the debugger. *

* using .sympath and .sympath+ *

*********************************************************************

Probably caused by : win32k.sys ( win32k+1818 )


Followup: MachineOwner

---------

(Cosik Ktosik) #9

0x19 BAD_POOL_HEADER, są tu dwie główne przyczyny: błąd alokacji pamięci lub bad sektory. W Twoim przypadku, oczywiście to drugie.


(Blotny) #10

Zależy jaki BadSector, czy przez błąd w systemie, czy mechaniczny. Jak w systemie to SanDisk (wbudowany). A HDD Regenerator toooooo... ekchm, według mojej znajomości angielskiego nie czyści on dysku (przynajmniej w tej wersji co ja ją miałem).


(Rkizeweter) #11

Kiedyś to jakimś Nortonem to robiłem, ale myślę, że powinien wystarczyć format (tylko nie szybki) partycji w celu zidentyfikowania bad sectorów.


(Himmak5g) #12

Ale jakim nortonem???


(system) #13

format w moim przypadku nic nie pomoże gryz robiłem już to dwukrotnie

dziękuje za pomoc spróbuje wyzerować dysk tak jak było to napisane w instrukcji wyżej poleconego programu


(Cosik Ktosik) #14

Koniecznie po operacji zerowania, użyj komendy Remap. I naprawdę radzę nie używać programu HDDRegenerator, czemu przeczytaj podany wyżej link.

Po wszystkim, podaj odczyt danych SMART dysku.


(Vicuss) #15

Yyy... Mi się wydaje, że zwykły Windows ChceckDisc wystarczy :?...


(korkodyl) #16

Tak czytam to i zastanawiam się na jakiej podstawie stawiacie diagnozy, kiedy nikt z Was nie widział nawet SMART-a dysku nie mówiąc już o jakimś skanie powierzchni?

@ Autor tematu, daj screena zakładki Smart (health) z "jakiegokolwiek" (najlepiej MHDD http://www.elektroda.pl/rtvforum/viewto ... d+faq&sid=) programu do diagnostyki. Później zobaczymy co da się zrobić.


(system) #17

prosze bardzo smart log

[PRE]HDD: SAMSUNG HD321KJ; FW: CP100-10; SN: S0MQJDPP610496

--------------------------------------------------------

            Name Val Worst Raw

Att # 1 : Read error rate : 100 100 0  

Att # 3 : Spin up time : 100 100 5504  

Att # 4 : Number of spin-up times : 99 99 1070  

Att # 5 : Reallocated sectors count : 253 253 0  

Att # 7 : Seek error rate : 253 253 0  

Att # 8 : Seek time performance : 253 253 0  

Att # 9 : Power-on time : 100 100 4047  

Att # 10 : Spin-up retries : 253 253 0  

Att # 11 : Calibration retries : 253 100 0  

Att # 12 : Start/stop count : 100 100 565  

Att # 187 : Unknown : 77 77 24  

Att # 188 : Unknown : 253 253 0  

Att # 190 : Unknown : 70 58 30  

Att # 194 : HDA Temperature : 148 112 30  

Att # 195 : Hardware ECC recovered : 100 100 529032  

Att # 196 : Reallocate event count : 253 253 0  

Att # 197 : Current pending sectors : 100 100 1  

Att # 198 : Offline scan UNC sectors : 253 253 0  

Att # 199 : Ultra ATA CRC Error Rate : 200 200 0  

Att # 200 : Write error rate : 253 100 0  

Att # 201 : Unknown : 253 100 0  

Att # 202 : Unknown : 253 253 0  

[/PRE]

postaram się jeszcze dziś zrobić skanowanie dysku


(JNJN) #18

Jeśli narzędzie producenta dysku nie poradzi sobie z naprawą - dysk wymiana.

http://forum.idg.pl/lofiversion/index.php/t10073.html


(Blotny) #19

Kolejny Samsung siada... Mam nadzieje, że te seria F1 lepsza jest...

Może w razie czego nie kupować nowego, a jedynie jeśli ma gwarancję to go oddać?


(system) #20
[PRE]

50 ERR INDX CORR DREQ DRSC WRFT DRDY BUSY AMNF T0NF ABRT IDNF UNCR BBK 00

 [SAMSUNG HD321KJ] [625,142,448] [625,142,447] [EST: 00:01] 

°±°±±°±°°±°°±°°±°°±°°±°±±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°± ACT [37834 kb/s]  

°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°˛°°±°°±°°±°°±°°±°±°°±°°±°°±°° ° <3ms : 2202593   

±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°˛°±°°±°°±°°±° ± <10ms : 243314    

°±°°±°°±°±°°±°°˛°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°± ˛ <50ms : 5632      

°°±°°±°°±°±±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°° Ű <150ms:           

±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±° Ű <500ms:           

°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°± Ű >500ms:           

°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°° ? TIME :            

±°°±°°±°°±°°±°°˛°±±°±°°±°°±°°±°°±°°±°±±°±°°±°°±°°±°°±°°±°°± x UNC : 1         

°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°° ! ABRT :            

±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±° S IDNF :            

°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°± A AMNF :            

°°±°±°°±°°±°°±°°±°°±°°±°±±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°° 0 T0NF :            

±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±° * BBK :            

°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°± [100.0%] [100.0%]

°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°±°°±°°±°° Error: 129147855    

±°°±°°±°°±°±°°±°°±°°±°°±°°±°°±°                                                 



Time spent: 01:25:31                                                            



 | Scan a drive : | 11:25:28 

[/PRE]

a to efekt skanowania

czy moglibyście mi powiedzieć coś więcej o usterce?

miałem racje z tymi bad sektorami czy może to jest inna wada ?