.NET Framework-jak zaaktualizowac najnowszą wersję?


(system) #1

mam 1.1 wersje + polski patch

i chciałem zmienić sobie na wyższą wersję np. 3.5

ze względu iż nie działają mi pewne programy

jak poprawnie dokonac zmiany?

trzeba odinstalowac stare komponenty?

proszę o pomoc


(lord_ko) #2

nic nie musisz odinstalowywać, wszystko się zainstaluje bez problemu, nawet z windows update.


(Mater93) #3

musisz miec chyba tak:

1.1, 1.1 SP1, 2.0, 3.0., 3.5


(Agatonster) #4

Bebok_13

Poczytaj - Konkretne tematy… ze zwróceniem szczególnej uwagi na pierwszy post.

Proszę poprawić tytuł tematu na konkretny, mówiący o problemie.

W celu dokonania zaleconej korekty - proszę użyć przycisku ac7a4cd89050aa6e.gif przy poście otwierającym ten temat.

Zignorowanie zalecenia będzie skutkowało usunięciem tematu do Kosza.


(Skiff) #5

To jest na pewno błędny pogląd. Sprawdź jakie wersje .NET Framwork potrzebują Twoje programy i instaluj tylko te co są Tobie potrzebne, ponieważ wersje frameworka nie są ze sobą kompatybilne - jeżeli program wymaga wersji 1.1 to zainstalowanie np. 3.0 nic Tobie nie da, musisz mieć 1.1 (lub 1.1 SP1 - to tylko zestaw poprawek). Wiem, że to programy od MS, ale lepiej sobie niepotrzebnie nie zaśmiecać komputera.

Według mojej wiedzy to teraz ciężko spotkać program, który wymagał by frameworka wyższego niż 2.0, więc radziłbym doinstalować .net 2.0 SP1, ale znowu: tylko, gdy jakiś program wyraźnie jego wymaga.

Prawdopodobnie jakiś program u Ciebie używa starej wersji - 1.1, więc raczej go zostaw (chyba, że jesteś pewien, że nie masz już programu, który używa tej wersji).

Tutaj masz link do wersji 1.1:

http://www.microsoft.com/downloads/deta … layLang=en

1.1 SP1 jako jedyny - wersja 1.1 posiada osobno 1.1 i SP1 - reszta pakietów SP1 posiada już wersję podstawową :

http://www.microsoft.com/downloads/deta … 3353618b38

2.0 SP1:

http://www.microsoft.com/downloads/deta … layLang=en

3.0 SP1:

http://www.microsoft.com/downloads/deta … layLang=en

3.5:

http://www.microsoft.com/downloads/deta … layLang=en

Aha i jeszcze jedno: nie opłaca się instalować polskich pakietów językowych, gdyż są to wyłącznie tłumaczenia błędów zgłaszanych przez frameworki, które w większości przypadków nie są pokazywane - błędy te są obsługiwane przez programy korzystające z frameworków.