Nie można odczytać partycji NTFS


(kijek) #1

Cześć, chciałem wejść na partycję sformatowaną jako NTFS, lecz wywala mi:

Nie można zamontować urządzenia.

Otrzymany komunikat błędu:

$LogFile indicates unclean shutdown (0, 0)

Failed to mount '/dev/hdb1': Operation not supported

Mount is denied because NTFS is marked to be in use. Choose one action:

Choice 1: If you have Windows then disconnect the external devices by

clicking on the 'Safely Remove Hardware' icon in the Windows

taskbar then shutdown Windows cleanly.

Choice 2: If you don't have Windows then you can use the 'force' option for

your own responsibility. For example type on the command line:

mount -t ntfs-3g /dev/hdb1 /media/hdb1 -o force

Or add the option to the relevant row in the /etc/fstab file:

/dev/hdb1 /media/hdb1 ntfs-3g defaults,force 0 0

Co zrobić, aby odczytywało tą partycję ?


(Sawyer47) #2

Przecież masz w komunikacie błędu opis problemu i możliwe rozwiązania, więc w czym problem?


(Rkizeweter) #3

A jak ją zamontowałes??


(kijek) #4

Z angielskim u mnie nie najlepiej.

A dysk nie jest zamontowany.


(Kamil321) #5

Do komendy, którą montujesz dodaj -o force i wskaż system plików przez -t ntfs-3g tak jak masz napisane w komunikacie czyli np.:

mount -t ntfs-3g /dev/hdb1 /media/hdb1 -o force

i powinno pójść...


(kijek) #6

Sorry, czytać mi się nie chciało dokładnie, jak przeczytałem propozycję 2, to załapałem.


(Sawyer47) #7

W skrócie: najpewniej masz system Windows na drugim dysku/partycji. System Windows został niepoprawnie zamknięty, partycja NTFS jest oznaczona jako będąca w użyciu i ntfs-3g - sterownik systemu plików NTFS w twoim systemie - nie montuje jej automatycznie. Rozwiązaniem jest uruchomienie systemu Windows i poprawne jego zamknięcie. Są tam też instrukcje w przypadku kiedy nie posiada się systemu Windows, ale Ty raczej masz, bo po co byłaby Ci partycja NTFS.


(kijek) #8

Tak, wiem, przeczytałem.