openSuse - zintegrowana k. graficzna GeForce 6100


(Kowalik2000) #1

Witam.

Mam linux openSuse 10.2 i mam pytanie: jak zainstalować sterowniki od mojej karty jaką jest zintegrowana na płycie Abit GeForce 6100?

// Poprawiłem tytuł wątku.

Kaka'


(Krzychuu) #2

xtion może to:

:arrow: http://pl.opensuse.org/SDB:Instalacja_s ... kow_NVIDIA

:arrow: http://jakilinux.org/newsy/latwa-instal ... -nvidiati/

:arrow: http://portal.suse.pl/wiki/index.php/In ... _sterowników_do_kart_graficznych_Nvidia

:arrow: http://pl.opensuse.org/NVIDIA


(Kowalik2000) #3

zrobiłem tak jak było napisane w tym ostatnim linku, ale dalej strona przy przewijaniu sie tnie i nie mogę ustawić w ogóle rozdzielczości, a zalecana do mojego monitora to 1440x900


(matiit) #4

a zobacz czy się zainstaloiwały

glxinfo | grep direct

Zrobiłeś wszystko jak było w tutorialu?


(Kowalik2000) #5

a jak to sprawdzić?

tak, zrobiłem wszytsko tak jak było opisane


(matiit) #6

wpisz to w konsoli


(Kowalik2000) #7

wpisałem i wyświetliło:

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Error: couldn't find RGB GLX visual

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

co mam zrobić, aby grafika poprawnie działała?

// Poprawiłem Twój post - pamiętaj aby używać tagów code i quote, które zwiększają czytelność postów.

Kaka'


(matiit) #8

Poprawnie zainstalować sterowniki.

Naprawde dużo jest tego w internecie...

Najlepsze dla CIebie porady będą na forum distra którego używasz :slight_smile:

Powodzenia w szukaniu


#9

Pokaż co zwraca polecenie

cat /etc/X11/xorg.conf | grep driver

(Kowalik2000) #10

nic nie pokazuje

co robić?


#11

Dobra, inaczej, pokaż cały plik /etc/X11/xorg.conf


(Kowalik2000) #12

pokazało: bash: /etc/X11/xorg.conf: Brak dostępu

a jestem zalogowany na root


#13

Otwórz to w jakimś edytorze tekstowym (np. kwrite, kate itp) i wklej tutaj to co zobaczysz.


(Kowalik2000) #14

wpisywałem to w Terminal Gnome

gdzie znajde te edytory?


(matiit) #15

xtion

wpisz tak:

su

podajesz hasło

kwrite /etc/X11/xorg.conf

#16

Jeżeli używasz Gnome'a, to użyj gedit zamiast tych które podałem.


(Kowalik2000) #17

oto co pokazało:

# /.../

# SaX generated X11 config file

# Created on: 2007-08-13T01:05:09+0200.

#

# Version: 8.1

# Contact: Marcus Schaefer , 2005

# Contact: SaX-User list 

#

# Automatically generated by [ISaX] (8.1)

# PLEASE DO NOT EDIT THIS FILE!

#

Section "Files"

  FontPath "/usr/share/fonts/misc:unscaled"

  FontPath "/usr/share/fonts/local"

  FontPath "/usr/share/fonts/75dpi:unscaled"

  FontPath "/usr/share/fonts/100dpi:unscaled"

  FontPath "/usr/share/fonts/Type1"

  FontPath "/usr/share/fonts/URW"

  FontPath "/usr/share/fonts/Speedo"

  FontPath "/usr/share/fonts/PEX"

  FontPath "/usr/share/fonts/cyrillic"

  FontPath "/usr/share/fonts/latin2/misc:unscaled"

  FontPath "/usr/share/fonts/latin2/75dpi:unscaled"

  FontPath "/usr/share/fonts/latin2/100dpi:unscaled"

  FontPath "/usr/share/fonts/latin2/Type1"

  FontPath "/usr/share/fonts/latin7/75dpi:unscaled"

  FontPath "/usr/share/fonts/baekmuk:unscaled"

  FontPath "/usr/share/fonts/japanese:unscaled"

  FontPath "/usr/share/fonts/kwintv"

  FontPath "/usr/share/fonts/truetype"

  FontPath "/usr/share/fonts/uni:unscaled"

  FontPath "/usr/share/fonts/CID"

  FontPath "/usr/share/fonts/ucs/misc:unscaled"

  FontPath "/usr/share/fonts/ucs/75dpi:unscaled"

  FontPath "/usr/share/fonts/ucs/100dpi:unscaled"

  FontPath "/usr/share/fonts/hellas/misc:unscaled"

  FontPath "/usr/share/fonts/hellas/75dpi:unscaled"

  FontPath "/usr/share/fonts/hellas/100dpi:unscaled"

  FontPath "/usr/share/fonts/hellas/Type1"

  FontPath "/usr/share/fonts/misc/sgi:unscaled"

  FontPath "/usr/share/fonts/xtest"

  FontPath "/opt/kde3/share/fonts"

  FontPath "unix/:7100"

  InputDevices "/dev/gpmdata"

  InputDevices "/dev/input/mice"

EndSection


Section "ServerFlags"

  Option "AllowMouseOpenFail" "on"

EndSection


Section "Module"

  Load "dbe"

  Load "type1"

  Load "freetype"

  Load "extmod"

  Load "glx"

  Load "v4l"

EndSection


Section "InputDevice"

  Driver "kbd"

  Identifier "Keyboard[0]"

  Option "Protocol" "Standard"

  Option "XkbLayout" "pl"

  Option "XkbModel" "pc104"

  Option "XkbRules" "xfree86"

EndSection


Section "InputDevice"

  Driver "mouse"

  Identifier "Mouse[1]"

  Option "Buttons" "5"

  Option "Device" "/dev/input/mice"

  Option "Name" "ImPS/2 Generic Wheel Mouse"

  Option "Protocol" "explorerps/2"

  Option "Vendor" "Sysp"

  Option "ZAxisMapping" "4 5"

EndSection


Section "Monitor"

  DisplaySize 409 256

  HorizSync 30-82

  Identifier "Monitor[0]"

  ModelName "VIEWSONIC VA1912WSERIES"

  Option "DPMS"

  VendorName "VSC"

  VertRefresh 43-85

  UseModes "Modes[0]"

EndSection


Section "Modes"

  Identifier "Modes[0]"

  Modeline "1280x1024" 105.15 1280 1360 1496 1712 1024 1025 1028 1059

  Modeline "1280x1024" 86.25 1280 1328 1360 1440 1024 1027 1034 1052 +HSync -VSync

EndSection


Section "Screen"

  DefaultDepth 16

  SubSection "Display"

    Depth 16

    Modes "default" 

  EndSubSection

  Device "Device[0]"

  Identifier "Screen[0]"

  Monitor "Monitor[0]"

EndSection


Section "Device"

  BoardName "Framebuffer Graphics"

  BusID "0:13:0"

  Driver "fbdev"

  Identifier "Device[0]"

  VendorName "VESA"

EndSection


Section "ServerLayout"

  Identifier "Layout[all]"

  InputDevice "Keyboard[0]" "CoreKeyboard"

  InputDevice "Mouse[1]" "CorePointer"

  Option "Clone" "off"

  Option "Xinerama" "off"

  Screen "Screen[0]"

EndSection


Section "DRI"

    Group "video"

    Mode 0660

EndSection


Section "Extensions"

EndSection

co mam teraz zrobić?


(Fazerxlo) #18

sprawdź jeszcze to:

http://www.susek.info/article/Nvidia_3D ... acja.shtml

upewnij się że twoja karta jest obsługiwana

bo teraz sterownik masz fbdev

i nie masz

dri