PHP5, a gdzie MySQL ?!


(3dm Racek) #1

Zainstalowałem sobie php5 [z instalatora] na serwerze MS IIS 5.1, jednak ta wersja nie obsłuje MySQL :expressionless:

Czy to tylko u mnie występuje taki błąd ??

Czy trzeba ściągać ZIPA ?? :roll:

Za pomoc z góry thx.


(inż. Piniol) #2

zip'a raczej nie bo z tej strony -> http://www.php.net/downloads.php wynika że obsługa MySQL'a jest wbudowana :roll:


(3dm Racek) #3

Nie ma tu nic o MySQL, albo mam słabe okulary :cry:

Zaznaczam, że chodiz i o v5.


(inż. Piniol) #4

"W tej chwili aktualną wersją PHP jest 5.0.2, która ukazała się 25 września 2004. PHP 5 opiera się na nowym Zend Engine w wersji 2.0. W stosunku do PHP 4, w sposób widoczny rozszerzono możliwości programownia obiektowego (podobnego do programowania obiektowego w języku Java lub C++), do tej pory zaniedbanego w PHP, od nowa napisano wsparcie dla XML, dodano SQLite, jednak nie dołączono bibliotek klienckich dla bazy danych MySQL. Zgodnie z wyjaśnieniami w FAQ, podczas kompilacji należy wykorzystać blibliotekę libmysqlclient zainstalowaną już w systemie"


(3dm Racek) #5

Gdzieś Ty to znalazł ?? :lol:


(lazikar) #6

Tak dla informacji. Ważne jezeli chodzi o PHP

Odkryto poważną dziurę w PHP, pozwala ona na odczyt dowolnych plików z serwera.

Dokładny opis znajdziecie na stronie http://www.securityfocus.com/archive/1/ ... 04-12-19/0