Piekelne ovh


(Fąfel) #1

ja się męczę, już chcem dodać nowy temat że coś co powinno działać niedziała, ale nagle myśle: kiedyś miałem jakieś konto na lycosie. wchodze ftp zgrywam na serwer odpalam w Operze i........... działa

precz z 60free :evil: :evil: :evil: :evil: :evil: :evil: :evil:

ku przestrodze młodych webmasterów.....


(system) #2

Ale że co?


(system) #3

Fąfel , nie ma co porównywać, 60free jest nieskończenie lepsze od lycosa, co ci tam przeszkadzało?


(Fąfel) #4

A mianowicie ten banalny skrypt niedziala:

<? 

if ($page=="first") 

	{include("1.txt");


	} else if ($page=="second") {

	include("2.txt");


	} else if ($page=="third") 

	{include("3.txt");


	} else {


	include("1.txt");	


	}

?>

niewiem, moze to safemode?


(xantio) #5
<? 

$page=$_GET['page'];


if ($page=="first") 

   {include("1.txt"); 


   } else if ($page=="second") { 

   include("2.txt"); 


   } else if ($page=="third") 

   {include("3.txt"); 


   } else { 


   include("1.txt");    


   } 

?>

Wina leży po stronie samego skryptu. Ten co zamieściłem powinien działać, jest to spowodowane nie safemode ino przez to, że ze względów bezpieczeństwa w wiekszosci zaleca się stosowanie register_globals na off. Wystarczy dodać na początku skryptu.

$page=$_GET['page'];

Jeśli zmienna ma być pobierana z adresu.

$page=$_POST['page'];

Jeśli zmienna ma być pobierana z formularza.

Pozatym nie lepiej zastosować funkcje switch.


(Fąfel) #6

Halleluja :!:

Może troszkę przegiełem :mrgreen:

Zresztą cięzko było znaleźć serwer bez reklam, te z reklamami rozwalały stronę

Ogromne podziekowania dla xantio :mrgreen: