Płynne nagrywanie pulpitu


(Adrian Gorny2) #1

Witam. Mam problem. :frowning:

Chciałbym nagrać filmik z pulpitu (taki jakby poradnik) w rozdzielczości 1280x1024 żeby miał 50-60 FPS.

A więc pobieram przykładowy program, ustawiam w opcjach np. 60 FPS, nagrywam.

Włączam film i co widzę? Widzę zacinający się film wyglądający mniej więcej na 24 FPS, który we właściwościach ma napisane "60 FPS".

Czego to może być wina?

Uprzedzę odpowiedź na Wasze pytanie odnośnie mojego sprzętu itp.:

Procesor: Intel Core 2 Quad 4x2.66Ghz

RAM: 2x2GB DDR3-1333 GoodRam (Dual-Channel)

Karta graficzna: GAINWARD GTX 260 Golden Sample 896MB 448-bit

Dysk twardy: 500GB Seagate Barracuda 7200.11 ST3500320AS

System: Windows 7 Ultimate 64-bit

PS.: Na mniejszych rozdzielczościach nagrywania (np. 320x320) filmik jest bardzo płynny - widać pełne 60 FPS.


(Tensor125) #2

Przecież wystarczy 30 FPS do płynnej animacji


(Adrian Gorny2) #3

Rzecz w tym, że nie mogę uzyskać nawet 30 FPS. :confused:

W grach normalnie nagrywa z prędkością jaką chcę, ale na pulpicie to nawet 30 nie osiąga.

Tak jak pisałem. We właściwościach jest 60 FPS, a zacina jakby było 22 albo mniej.


(Pioruns) #4

Jakiego programu używasz?

Ile miejsca na dysku zajmuje taki przykładowy plik wideo utworzony w tym programie?

Czy program ten kompresuje od razu dane w locie? Jeśli tak, to może procesor nie wyrabiać. Jesli nie, to może dysk nie wyrabiać już podczas zapisu lub odczytu (gdy otwierasz filmik).


(Adrian Gorny2) #5

Użyłem programu Camtasia Studio 7.

Jednominutowy plik wideo utworzony w tym programie

(przy opcji "Full Frames, Uncompressed") zajmował niecałe 10 GB.

Jego bitrate wynosiło ( :!: )1259650 kb/s i ten filmik się zacinał.

Jednak po skompresowaniu filmu w Camtasia Studio 7, kodekiem "Microsoft Video 1" plik wideo zmniejszył się do 68 MB.

Jego bitrate wynosi 8602 kb/s i jest teraz odtwarzany w miarę płynnie. :slight_smile:

Tylko jak jest na filmiku np. minimalizowanie, odminimalizowywanie, zmaksymalizowanie itp. to trochę przycina ten filmik,

ale to nie jest wielki problem.


(Pioruns) #6

No tak właśnie podejrzewałem. Żaden zwykły dysk nie wyrobi z odczytem 1.2 GB/s :slight_smile:

Kodeki zapewne możesz użyć jakieś lepsze niż to MS Video1, poszukaj tam w opcjach Camtasia Studio, lub doinstaluj niezbędne kodeki z internetu, np. XviD czy coś.


(Adrian Gorny2) #7

Czytałem właśnie, że ten MS Video 1 to jest taka lipa. :slight_smile:

Zainstalowałem K-Lite Codec's Pack i potem jeszcze osobno XviD, ale nie widzę żadnych nowo zainstalowanych kodeków

w Camtasia Studio, ani w innych programach do kompresji filmów. (Chyba, że te programy swój zainstalują to widzę go).