Pomoc w stworzeniu sieci w programie network lab simulator


(Kacz0r) #1

Witam,

http://hostuje.net/file.php?id=daafd6c3553ffc3121c14f632317f2d8


(roobal) #2

Napisz z czym masz problem, napisz co Ci nie działa. Pojęcie “coś” to może być problem z routingiem, switchingiem, problem z protokołem IP, albo okablowaniem, więc fajnie by było jakbyś napisał co nie działa, bo tak to Ci nikt nie pomoże. Niestety nie posiadam takiego programu, więc nie mam możliwości sprawdzenia co Ci nie działa, a gotowca też Ci nie wyślę. Jeśli program jest dostępny dla systemu Linux, podaj link do instalki, wówczas postaram się go zainstalować i sprawdzić co źle zrobiłeś.


(Kacz0r) #3

Programu nie trzeba instalować wystarczy go pobrać i rozpakować, w tym pliku który podałem up wystarczy go odpalić i w programie kliknąć aby sprawdził poprawność sieci. Po sprawdzeniu program nam wypisuje co jest nie tak, niestety nie potrafię zanalizować/poprawić błędy (pracuje w tym programie pierwszy raz). Program można poprać z http://netsimk.com/


(roobal) #4

Program nie jest dostępny na Linuksa, a pod Wine działa strasznie wolno, a nie mam pod ręką Windows, więc poprawek Ci nie zrobię. Podstawowe błędy, które wypisał program. W routerach Cisco, jeśli port jest administratively down, oznacza to, że nie został on podniesiony, w routerach Cisco, interfejsy są domyślnie wyłączone, czyli brak polecenia no shutdown. Masz również błędną adresację oraz zduplikowane adresy. Brak również działającego protokołu routingu dynamicznego i jeśli nie dodałeś tras statycznych, sieć nie bedzie działać poprawnie. Hosty nie potrafią się skomunikować z bramą domyślną, co może być spowodowane albo błędną adresacją, albo wyłączonym interfejsem routera.

Program jeszcze ostrzega i przypomina o tym, że jak użyjesz klasowego protokołu routingu, możesz mieć nieciągłość na granicach sieci. W tym przypadku należy użyć protokołu bezklasowego, a także wyłączyć automatyczną sumaryzację tras.

Podstawowe błędy w konfiguracji routerów (tak na przyszłość nadaj routerom nazwy - polecenie hostname, albo chociaż nadaj etykiety na schemacie logicznym sieci), zaznaczyłem pogrubieniem.

Router>en

Router#sh run

Building Configuration…

Current Configuration : 667

!

version 12.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname Router

!

!

!

!

interface FastEthernet0/0

ip address 13.19.24.0 255.255.252.0

no ip directed-broadcast

!

!

interface FastEthernet0/1

no ip address

no ip directed-broadcast

shutdown

!

!

interface Serial0/0

ip address 204.201.180.32 255.255.255.248

no ip directed-broadcast

clockrate 8000

!

interface Serial0/1

no ip address

no ip directed-broadcast

shutdown

!

interface Serial0/2

no ip address

no ip directed-broadcast

shutdown

!

no ip classless

ip route 192.168.10.0 255.255.255.0 204.201.180.34

!

line con 0

line aux 0

line vty 0 4

!

end

Router#

Na pozostałych routerach popełniasz te same błędy. Pierwsza rzecz, to zła adresacja, host nie może mieć ani adresu sieci, ani adresu rozgłoszeniowego. Co do trasy statycznej, o ile wszystkie adresy są routowalne, czyli prywatne i publiczne, o tyle tu powinieneś zastosować NAT. Możesz routować z sieci 192.168.x.x do sieci 100.x.x.x, ale w prawdziwej sieci takie pakiety zostaną odrzucone przez pierwszy lepszy firewall, bo one nie mają prawa istnieć w internecie, dlatego tu powinieneś zastosować NAT.