Problem z AWN, upiekszanie Ubuntu


(Rico25) #1

Witam, korzustając z tego poradnika upiekszanie-ubuntu-poradnik-dla-poczatkujacych-t259690.html upiekszałem Ubuntu, zatrzymałem się na pkkt 13, gdyż kiedy wpisuje odpowiednią komende, terminal nie ściąga plików ponieważ 402 Not Found, czy coś takiego, czyli pliki zostały usunięte, szukałem inne linki które pobierają AWN lecz niestety, wszystkie wygasły.


(roobal) #2

Jaka wersja Ubuntu? AWN jest w najnowszych wersjach Ubuntu domyślnych repozytoriach, więc nie trzeba dodawać tych z PPA.

Pozdrawiam!


(Rico25) #3

wersja 2.22.3

Niestety w tutaj nie ma AWN

E: Nie udało się odnaleźć pakietu avant-window-navigator-trunk

Kopiuje to co trzeba lecz linki prawdopodobnie wygasły


(roobal) #4

Ale to chyba piszesz o wersji Gnome, bo wątpię abyś pisał o wersji kernela a nie Ubuntu. Skoro masz tak stare Gnome to masz i starszą wersję Ubuntu, dodaj w takim razie te repozytoria z poradnika ale w taki sposób:

sudo echo "deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main

deb-src http://ppa.launchpad.net/awn-testing/ubuntu hardy main" >> /etc/apt/sources.list'

Pozdrawiam!


(Rico25) #5

E: Typ 'sudo' jest nieznany w linii 62 listy źródeł /etc/apt/sources.list

Ściągnołem paczke z oficjalnej strony AWN i zainstalowałem go, lecz niestety gdy nacisne na ikonke program sie włącza i odrazy wyłącza.


(RubasznyRumcajs) #6
  1. jaka wersje ubuntu?

2.

deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main

deb-src http://ppa.launchpad.net/awn-testing/ubuntu hardy main

to miało być wklejone w sources.list

  1. odinstaluj tego AWN i zainstaluj wersje z repozytorium, a jak nie- to odpal ów program z terminala i patrz jakie błędy wywala (na 90% brak jakieś zależności)

(roobal) #7

Mój błąd, na końcu przypadkowo wkradł się niepotrzebny apostrof, powinno być tak:

sudo echo "deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main

deb-src http://ppa.launchpad.net/awn-testing/ubuntu hardy main" >> /etc/apt/sources.list

Gdyby był brak zależności to w ogóle by się nie uruchomił o ile w ogóle by się zainstalował ale bez logów z terminala to się można tylko domyślać co jest przyczyną problemu :slight_smile:

Pozdrawiam!


(Rico25) #8

roobal, po wpisaniu do source.list tego co wpisałeś wychodzi

E: Typ 'sudo' jest nieznany w linii 62 listy źródeł /etc/apt/sources.list


(roobal) #9

Pokaż zawartość pliku sources.list, wpisz w terminalu takie polecenie:

cat /etc/apt/sources.list

I wklej to co pojawi się w terminalu tutaj na forum.

Pozdrawiam!


(Rico25) #10
#deb cdrom:[Ubuntu 9.10 _Karmic Koala_ - Release i386 (20091028.5)]/ karmic main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to

# newer versions of the distribution.


deb http://pl.archive.ubuntu.com/ubuntu/ karmic main restricted

deb-src http://pl.archive.ubuntu.com/ubuntu/ karmic main restricted


## Major bug fix updates produced after the final release of the

## distribution.

deb http://pl.archive.ubuntu.com/ubuntu/ karmic-updates main restricted

deb-src http://pl.archive.ubuntu.com/ubuntu/ karmic-updates main restricted


## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu

## team. Also, please note that software in universe WILL NOT receive any

## review or updates from the Ubuntu security team.

deb http://pl.archive.ubuntu.com/ubuntu/ karmic universe

deb-src http://pl.archive.ubuntu.com/ubuntu/ karmic universe

deb http://pl.archive.ubuntu.com/ubuntu/ karmic-updates universe

deb-src http://pl.archive.ubuntu.com/ubuntu/ karmic-updates universe


## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 

## team, and may not be under a free licence. Please satisfy yourself as to 

## your rights to use the software. Also, please note that software in 

## multiverse WILL NOT receive any review or updates from the Ubuntu

## security team.

deb http://pl.archive.ubuntu.com/ubuntu/ karmic multiverse

deb-src http://pl.archive.ubuntu.com/ubuntu/ karmic multiverse

deb http://pl.archive.ubuntu.com/ubuntu/ karmic-updates multiverse

deb-src http://pl.archive.ubuntu.com/ubuntu/ karmic-updates multiverse


## Uncomment the following two lines to add software from the 'backports'

## repository.

## N.B. software from this repository may not have been tested as

## extensively as that contained in the main release, although it includes

## newer versions of some applications which may provide useful features.

## Also, please note that software in backports WILL NOT receive any review

## or updates from the Ubuntu security team.

# deb http://pl.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse

# deb-src http://pl.archive.ubuntu.com/ubuntu/ karmic-backports main restricted universe multiverse


## Uncomment the following two lines to add software from Canonical's

## 'partner' repository.

## This software is not part of Ubuntu, but is offered by Canonical and the

## respective vendors as a service to Ubuntu users.

# deb http://archive.canonical.com/ubuntu karmic partner

# deb-src http://archive.canonical.com/ubuntu karmic partner


deb http://security.ubuntu.com/ubuntu karmic-security main restricted

deb-src http://security.ubuntu.com/ubuntu karmic-security main restricted

deb http://security.ubuntu.com/ubuntu karmic-security universe

deb-src http://security.ubuntu.com/ubuntu karmic-security universe

deb http://security.ubuntu.com/ubuntu karmic-security multiverse

deb-src http://security.ubuntu.com/ubuntu karmic-security multiverse

sudo echo "deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main

deb-src http://ppa.launchpad.net/awn-testing/ubuntu hardy main" >> /etc/apt/sources.list

(roobal) #11

Zrób tak, uruchom terminal i wpisz tam:

sudo gedit /etc/apt/sources.list

I wywal z pliku te dwie ostatnie linijki:

I wklej tam to:

deb http://ppa.launchpad.net/awn-testing/ubuntu hardy main

deb-src http://ppa.launchpad.net/awn-testing/ubuntu hardy main

Zapisz zmiany i wykonaj w terminalu:

sudo apt-get update

Po odświeżeniu listy repozytoriów już powinieneś mieć możliwość instalacji AWN poleceniem:

sudo apt-get install avant-window-navigator

Lub podobnie.

Pozdrawiam!

PS. Tak na przyszłość, lepiej by było jakbyś takie rzeczy umieszczał w tagach BBCode :slight_smile:


(Rico25) #12

'System=>Preferencje=>Awn Manager' się odpala jednak 'System=>Preferencje=>Awn Manager' sie nie odpala i nie moge ustawic nic


(roobal) #13

Uruchom w terminalu i wklej na forum błędy ale pamiętaj, w BBCode to wklej :slight_smile:

Pozdrawiam!


(Rico25) #14

Prawdopodobnie to jest to:

Warning: Screen isn't composited. Please run compiz (-fusion) or another compositing manager.

(roobal) #15

Compiz domyślnie u Ciebie działa, tj. czy masz włączone efekty wizualne? Sprawdź, klikając PPM na pulpicie, wybierz Zmień tło pulpitu i przejdź do zakładki Efekty wizualne i zobacz czy jest zaznaczona jedna z opcji: Normalne lub Dodatkowe.

Jeśli instalowałeś Compiza własnoręcznie wg poradnika to spróbuj zrobić tak jak proponuje ostrzeżenie, czyli wpisz w terminalu compiz --replace i wklej kolejne błędy na forum, jeśli się pojawią.

Pokaż jeszcze wynik polecenia:

glxinfo | grep direct

I polecenia:

glxgears -info

I napisz jaką masz kartę graficzną.

Pozdrawiam!


(Rico25) #16

po wpisaniu compiz --replace

Checking for Xgl: not present. 

xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log 

Detected PCI ID for VGA: 

Checking for texture_from_pixmap: not present. 

Trying again with indirect rendering:

Checking for texture_from_pixmap: present. 

Checking for non power of two support: present. 

Checking for Composite extension: present. 

Checking screen 1Comparing resolution (1366x768) to maximum 3D texture size (4096): Passed.

Checking for Software Rasterizer: present. 

Software rasterizer detected, abortingaborting and using fallback: /usr/bin/metacity

Efekty wizualne mam wyłączone i niemoge włączyć ani dodatkowych ani normalnych, pisze Efekty pulpitu nie mogły zostać włączone Polecenie glxinfo | grep direct

direct rendering: Yes

Polecenie glxgears -info

GL_RENDERER = Software Rasterizer

GL_VERSION = 2.1 Mesa 7.6

GL_VENDOR = Mesa Project

GL_EXTENSIONS = GL_ARB_copy_buffer GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_half_float_pixel GL_ARB_imaging GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shading_language_120 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_depth_bounds_test GL_EXT_draw_range_elements GL_EXT_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_shared_texture_palette GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_swizzle GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_3DFX_texture_compression_FXT1 GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ATI_blend_equation_separate GL_ATI_envmap_bumpmap GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATI_fragment_shader GL_ATI_separate_stencil GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_resize_buffers GL_MESA_texture_array GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_fragment_program GL_NV_light_max_exponent GL_NV_point_sprite GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_NV_vertex_program1_1 GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGI_texture_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays

1339

Karta graficzna to HD4570 512mb


(roobal) #17

No to już połowa sukcesu :slight_smile:

Ten problem nie raz pojawiał mi się pod Debianem ale nie potrafię go na dzień dzisiejszy rozwiązać ale wiem że kiedyś coś zdziałałem przy pomocy xorg.conf. Skoro masz działającą akcelerację 3D to czy instalowałeś sterowniki własnościowe od ATI czy korzystasz z otwartych?

Pozdrawiam!


(Rico25) #18

Nie, nie instalowałem żadnych sterowników.


(roobal) #19

Zobacz czy są dostępne i je zainstaluj :slight_smile: Szukaj w System > Administracja > Sterowniki.

Pozdrawiam!


(Rico25) #20

Roobal, mówił Ci ktoś że jesteś genialny?

Efekty się włączyły, wszystko śmiga, dzięki.