Problem z botowaniem


(Paszczak900) #1

Witam mam problem z Windowsem XP posiadam 2 dyski 1 ATA i 2 SATA, a problem polega na tym ze Windowsa mam zainstalowanego na dysku SATA a botuje go z ATA i jak odłączę dysk ATA i próbuje odpalić Windows to wyskakiwało ze nie ma pliku NTLDR. Plik ten wgrałem z naprawy Windows używając komendy "copy x:\i386\NTLDR c:" po skopiowaniu tego pliku użyłem komend "fixboot" i "fixmbi". Po restarcie wyskakuje mi teraz taki komunikat

"

Nie można uruchomić systemu Windows z powodu sprzętowego błędu konfiguracji dysku.

Nie można dokonać odczytu ze wskazanego dysku startowego.

Sprawdź ścieżkę oraz dysk.

Sprawdź w dokumentacji systemu Windows oraz w instrukcji obsługi sprzętu dodatkowe informacje na temat konfiguracji dysku.

"

Nie mam pojęcia co robić dalej nigdzie nie mogę znaleźć podobnego przypadku. Dodam za jak podłącze oba dyski to wszystko działa dobrze.

Dysk ATA mam podzielony na 3 partycje:

C: pisze ze jest systemowa

E:

F: sa to partycje logiczne

Dysk SATA mam podzielony na 4 partycje także:

I: partycja logiczna

G: partycja aktywna

D: rozruch (na niej mam Windowsa)

H: partycja logiczna

Nazwy partycji brałem z: narzędzia systemowe->zarządzanie komputerem->zarządzanie dyskami

Wiem ze się rozpisałem ale możne ktoś wie co mam z tym zrobić ponieważ dysk ATA muszę wyjąc z komputera na jakiś czas.


(Pan Ziombl) #2

edytuj boot.ini, bo tam masz przypisane z którego dysku i której partycji ma być rozruch systemu


(Paszczak900) #3

to nic nie daje. Znalazłem właśnie coś podobnego na innym forum ale nie wiem o com chodzi.

http://forum.pclab.pl/t366430.html


(Tomasz Paziewski) #4

Może skopiuj ten boot.ini na partycję dysku SATA?


(Paszczak900) #5

nic nie daje przed chwila próbowałem :frowning:


(Pan Ziombl) #6

miałem to samo na linuksie, tylko format i ponowna instalacja systemu rozwiązała problem


(Paszczak900) #7

ale za bym wolał jakiś problem bez ponownej instalacji możne ktoś wie jak to naprawić


(Irabuntu) #8

Może spróbuj reset bios-u i edycja boot.ini


(Cosik Ktosik) #9

Pokrótce, po odłączeniu dysku zmieniają się litery przypisane partycjom na podpiętym dysku. Natomiast wszystkie ścieżki odwołują się pod stare litery. Tak, więc raczej kicha.


(Pan Ziombl) #10

rób formata, odświeżysz sobie kompa


(Paszczak900) #11

właśnie mi chodzi o to żeby nie robić formata. Jakbym chciał zrobić format to nawet bym tu nie pisał.


(Pan Ziombl) #12

napisz jakie masz dyski, na którym jest windows i dokładnie jakie nazwy partycji na tych dyskach , no i na której partycji jest windows


(Paszczak900) #13

ATA 160GB ma 3 partycje

C

E

F

SATA 500GB ma 4 partycja

D na tej partycji jest Windows

G

H

I


(Pan Ziombl) #14

boot loader]

timeout=30

default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

chyba tak powinieneś mieć ustawione


(Paszczak900) #15

mam tak ustawione i jest to samo


(Pan Ziombl) #16

boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect

może tak zobacz