Problem z Harmonogram Zadań - nie mogę wlaczyć


(Hehe 91) #1

Więc jak w temacie, nie mogę włączyć tej usługi. Mam ją zatrzymaną i chcę ją włączyć bo strasznie długo sie uruchamia komp :confused: (prog. na pasku zadań).

Typ uruchomienia: Automatyczny, Stan usługi: Zatrzymano. I tu się zaczynają problemy :confused: Gdy chcę wziąść na Uruchom to wyskakuje mi taki błąd: sadauz6.jpg

W Podglądzie zdarzeń jest tak:

Typ zdarzenia: Błąd

Źródło zdarzenia: Service Control Manager

Kategoria zdarzenia: Brak

Identyfikator zdarzenia: 7023

Data: 2007-03-06

Godzina: 07:37:40

Użytkownik: Brak

Komputer: PC

Opis:

Usługa Harmonogram zadań zakończyła działanie; wystąpił następujący błąd:

Parametr jest niepoprawny.

Aby znaleźć więcej informacji, zobacz http://go.microsoft.com/fwlink/events.asp w Centrum pomocy i obsługi technicznej.

Pomocy :slight_smile:


(strażak) #2

W jakich okolicznościach nastąpiło zatrzymanie usługi i na jakim systemie?

Sprawdzałeś kompa pod kątem szkodników?


(Hehe 91) #3

Nie wiem w jakich okolicznościach. Winxp! Założyłem inny temat z innym problemem, przy okazji zapytałem się czego tak wolno ładują się programy w pasku zadań po załadowaniu Windowsa, okazało się że katalog prefetch się nie zapełnia http://forum.dobreprogramy.pl/viewtopic.php?t=139261. W połowie lutego formatowałem dysk... Dłuższy czas nie skanowałem kompa, jak coś może to dać to zrobię tak.


(Edlib) #4

usuń pliki z folderu C:\Documents and Settings\All Users\Dane aplikacji\Microsoft\Crypto\RSA\S-1-5-18, system je odtworzy;

sprawdż we właściwościach usługi, w zakładce logon konto, z którego startuje(powinno być lokalne konto, zezwalaj usłudze itd. powinno być zaznaczone); jeśli nie pomoże zarejestruj schedsvc.dll, w uruchom

regsvr32 schedsvc.dll i ENTER

(folder może być ukryty!)


(Hehe 91) #5

Nic nie pomogło :/, a gdy próbuje zarejestrować ten plik to wyskakuje mi taki błąd:

sssssdsjk5.jpg

Help :PP


(Edlib) #6

upewnij się, że usługi zdalne wywoływanie procedur i usługi kryptograficzne są włączone i ustawione na automatyczny start;

spróbuj jeszcze raz uruchomić usługę, a następnie wpisz do uruchom cmd,

i w wierszu polecenia sc query schedule i Enter, powinny pojawić się

informacje o przyczynie błędu; jeśli nie zmieniałeś żadnych plików systemowych wpisz do uruchom

sfc /scannow

być może dll(może to być też rsaenh.dll)jest uszkodzona

w bazie danych Microsoftu, do której odsyłał link pod błędem, jest

dużo o tym błedzie, ale żaden artykuł nie odnosi się do harmonogramu,

większość do usług sieciowych

ps. przed skanowaniem możesz przenieść schedsvc.dll na inną partycję,

wtedy powinna zostać skopiowana z płytki, jeśli nadal nie będzie działać,

zarejestruj ją


(Hehe 91) #7

Ta usługa Zdalne (...) jest włączona. Gdy wpisuje to sc query schedule

mam takie coś: omffasdfasfsafanx0.jpg

Przeskanowałem i nic... Jakieś inne propozycje? :slight_smile:


(Edlib) #8

jeśli masz zaporę, to upewnij się, że porty 115 i 135 nie są zablokowane - z jakichś dziwnych względów muszą być dostępne, żeby harmonogram działał(choć z nich nie korzysta); spróbuj jeszcze zarejestrować rsaenh.dll, możesz też spróbować skopiować schedsvc.dll ręcznie z płytki

(jest w i386, po skopiowaniu musisz ją rozpakować - w cmd wpisz

expand ścieżka do dll X:\windows\system32, wcześniej przenieś dll z system32 w inne miejsce) - X - partycja systemowa

jeśli nie podziała pozostaje ci tylko naprawa systemu, choć nie wiem czy warto, bo opinie, czy rzeczywiście prefetch przyśpiesza start itd. są bardzo różne

ps. wczoraj natknąłem się na wątek na zagranicznym forum z dokładnie

takim samym problemem, skończył się dokładnie tak jak prawdopodobnie

skończy się ten .. czyli niczym(choć był znacznie dłuższy)

sprawdż jeszcze dla świętego spokoju wpis Start w kluczu

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Schedule

powinno być 2


(Hehe 91) #9

Gdzie powinno być 2? http://img404.imageshack.us/img404/9121 ... 22uyl3.jpg

I w firewallu mam tak: http://img114.imageshack.us/img114/5075 ... 2u2yo5.jpg

To nie wiem co robić :smiley:


(Edlib) #10

w rejestrze wszystko w porządku( wartość Start = 2)

co do zapory - nie używam, nie wiem czy ma jakąś opcję blokuj porty lub coś w tym stylu, ale jeśli to zapora windows, to mało prawdopodobne, aby

domyślnie blokowala porty używane przez usługi- sprawdż, czy ma opcję zablokowane, zamknięte porty itd.

spróbuj jeszcze usunąć plik SchedLgU.Txt z windows, to log tej usługi

(jeśli będzie)

jeśli koniecznie chcesz sprawdzić to prefetch to, jak napisałem, pozostanie

ci naprawa systemu - w zasadzie jest to bezpieczne(wszystkie ustawienia

i twoje pliki pozostaną nienaruszone), ale mogą pojawić się problemy podczas samego procesu naprawy i według niektórych system po naprawie nie jest już tak stabilny( choć z własnego doświadczenia nie

mogę tego potwierdzić - mam wlaśnie system po naprawie i nie zauważyłem, by był mniej stabilny niż przed)