Problem z instalacją FF 3.0 RC1 {libgnomevfs-WARNING}


(system) #1

Otóż wpisałem w konsoli:

bartek46op@bartek46op-desktop:~$ cd /home/bartek46op/Pulpit/firefox

bartek46op@bartek46op-desktop:~/Pulpit/firefox$ ./firefox


(firefox-bin:6428): libgnomevfs-WARNING **: Przestarzała funkcja. Modyfikacje przez użytkownika bazy MIME nie są więcej obsługiwane.

FIrefox oczywiście się pojawił ale ten błąd w Terminalu - kilka ich wyskoczyło. Po wyłaczeniu FF nadal mam w systemie FF 3b5. W czym moze tkwic błąd? System Ubuntu 8.04 HH.


(Kaka') #2

To jest tylko warning, więc nie trzeba w jakiś szczególny sposób się tym przejmować. Jeżeli chcesz się tego pozbyć, poszperaj o tym na Google.

Czy dobrze rozumiem - chciałeś zrobić aktualizację z B5 do RC1?


(system) #3

Tak, aktualizację do 3.0 RC1

Uwierz mi, szukałem w google i nic nie znalazłem na ten konkretny temat! Dodam że 3b5 nieraz mi się wyłącza na filmikach z youtube,wrzuta. Ot tak sobie - wyłącza się program jakbym klinał {X]. Zadnego komunikatu, nic.


(Kaka') #4

To powiedz jeszcze czy B5 była instalowana poprzez paczkę .deb, czy może ściągnąłeś Firefoksa ze strony twórców i po prostu rozpakowałeś?


(system) #5

Standardowo wgrana do systemu który dostałem na płytce.

Wiec co polecasz? Jesli dużo grzebania z tym 3.0 RC1 dużo to co zrobić z 3b5 żeby przy filmach się nie wyłączało? W linuxie jestem początkujący.


(Kaka') #6

No moment, tak nie zaktualizujesz Fiefoksa zainstalowanego z paczki .deb, do tej wersji, którą pobrałeś. Musiałbyś zainstalować paczkę .deb z nową wersją (albo pobierzesz skądś taką paczkę, albo sam skompilujesz i zbudujesz). Możesz także skompilować czyste źródła Fx i zainstalować via make install (ale szczerze odradzam ten sposób).

Możesz także zrobić dowiązanie (/usr/bin/firefox) do RC1, bądź po prostu porobić sobie skróty do RC1, którego ściągnąłeś.

W dniu 17.05.2008 , o godzinie 20:13 został dopisany post przez Kaka'

Pamiętaj, że Fx 3 nie jest jeszcze stable.


(system) #7

Chyba spróbuje skompilować i zbudowac ta paczke.


(Kaka') #8

No to jak już budujesz paczkę, polecam do tego celu dpkg, a nie checkinstall. Jednak osobiście, bądź co bądź, radziłbym zrobić sobie po prostu dowiązanie.


(system) #9

Najpierw dowiązanie skoro tak radzisz. (a to trzeba podmieniać jakieś pliki czy jak?)


(matiit) #10

Jak będziesz kompilował i nie będziesz wiedział jakie sobie dać opcje przy configure (ja tak miałem, bo jest pełno tych opcji), to sobnie zobacz PKGBUILDA firefoksa z AUR ( http://aur.archlinux.org).


(Kaka') #11

# ln -s -f /home/bartek46op/Desktop/firefox/firefox /usr/bin/firefox

(system) #12

Jak robie ten skrot to otwiera mi nadal 3b5 i jeszcze wyskakuje coś do tego:


(Kaka') #13

pokaż:

$ ls -la /usr/bin/firefox

(system) #14


(Kaka') #15

Masz taki katalog w $HOME i czy jest on tym od RC1?


(system) #16

Mam plik "skrypt powłoki" z nazwą firefox - nie firefox-3.0

Dodam, że gdy otworze plik: /usr/bin/firefox-3.0 w edytorze tekstowym znalazłem fragment:

APPNAME=firefox

MOZDIR=$HOME/.mozilla

LIBDIR=/usr/lib/[b]firefox-3.0b5[/b]

DROPPED=abandoned

(Kaka') #17

Coś mi tu nie gra - dowiązanie wskazuje na katalog, a nie plik. Wykonałeś polecenie podane przeze mnie (to ln -s -f ...) czy może je zmieniłeś?


(system) #18

Zrobie jeszcze raz od początku .

W dniu 17.05.2008 , o godzinie 21:45 został dopisany post przez bartek46op

Zrobiłem dokładnie tak:

jak widać:

wpisałem więc

i wyszło:

Może jednak sprobować te paczki .deb?


(Morietto) #19

a jak aktualizowałeś tego firefoxa?? poprzez terminal czy opcję w przeglądarce?? przeglądarka powinna sama się zaktualizować i nie powinieneś ingerować w nic.. ja sobie zrobiłem obok bety wcześniejszą paczkę z 3 rc1 bo można było ściągnąć wcześniej a 2 dni później firefox 3b5 zaktualizował się sam więc tamtą usunąłem... w ubuntu firefox 3b5 jest preinstalowany..ja bym polecał odinstalowac lisa i zainstalować jeszcze raz

sudo apt-get autoremove firefox-3.0



potem

sudo apt-get install firefox-3.0

moim zdaniem nie trzeba tu nic kombinować i kompilować ;]


(system) #20

Gdy klikam w Pomoc >> opcja Sprawdź dostepność aktualizacji jest niedostepna tj. jest napisana na szaro i klikanie w nią nic nie da.

Dobra przeinstalowałem. Teraz głosu w systemie nie mam :(.