Problem z kompilacją wxwidgets


(Crack32) #1

Witam. W moim Ubuntu podczas próby skompilowania wxwidgets dla GTK pokazuje mi się to:

Jak załatwić ten problem? Nie za bardzo wiem, gdzie szukać tej wartości.


#2

Przecież wyraźnie jest napisane czego Ci brakuje


(Crack32) #3

Bardzo fajnie, tylko jest pewien problem. Do kompilacji GTK potrzebuję m.in Glib i atk. Przy kompilacji atk-1.9.1 pojawia się taki komunikat, mimo, że wcześniej skompilowałem Glib 2.12.0 i nie pojawiał się żaden błąd:

configure: error:

*** GLIB 2.5.7 or better is required. The latest version of

*** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is installed

*** but not in the same location as pkg-config add the location of the file

*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

Rozumiem, że muszę wstawić ścieżkę do pliku glib-2.0.pc do wartości PKG_CONFIG_PATH. Tylko jak to zrobić?


(Deathspell666) #4

Nie wiem jakiej dystr korzystasz, ale sciagnij wersje developerskie tych biblotek "gtk.glip" w pakiecie beda mialy nazwe np gtk-2.X.X-dev