Problem z odtwarzaniem MKV


(Neo096) #1

Witam!

Mam poważny problem z odtwarzaniem plików w formacie .mkv . Ściągnąłem koncert w formacie .mkv zainstalowałem kodeki matroska i k-lite codecs, odtwarzam kmplayer. Ale problem polega na tym że podczas odtwarzania obraz jest odtwarzany później niż dźwięk. :frowning: Niestety znacznie zmniejsza to przyjemność oglądania. Proszę o szybką pomoc. Dziękuje za wszelkie rady i podpowiedzi. [-o<


(Seba86mu) #2

Nie powinno instalować się kilka pakietów kodeków na raz.

Odinstaluj kodeki, które instalowałeś do tej pory (START -> Panel sterowania -> Dodaj/Usuń programy). Uruchom ponownie komputer.

Pobierz i zainstaluj FFDShow.


(Neo096) #3

No niestety tak jak mówiłeś odinstalowałem wszystkie kodeki i po uruchomieniu ponownym komputera zainstalowałem FFDShow. Niestety występuje ciągle ten sam problem. ;-( Plik który odtwarzam co jakiś czas przycina się i wtedy właśnie obraz "spowalnia" i nie nadąża za ścieżką audio. :confused: zauważyłem że dzieje sie też to w filmach o rozszerzeniu .avi czy .mpg. #-o Prosze o pomoc. :?


(Placio74) #4

Ale... The KMPlayer w większości przypadków korzysta z 'wewnętrznych' dekoderów (o ile użytkownik nie zmieni tego w konfiguracji).

A jakie są właściwości tego pliku MKV?

Skorzystaj z opcji Info o mediach... (Media Info...)

Sprawdź odtwarzanie tylko z niezbędnymi filtrami.

  • Wideo (Zaawansowane) (Video (Advanced)) > Tryb super prędkości (SuperSpeed Mode)

Zmień używany dekoder wideo.

Jeśli w tym MKV jest H.264/AVC, a masz zainstalowany w systemie CoreAVC...

  • Opcje (Options) > Ustawienia... (Preferences...) > Użycie dekodera (Decoder Usage) > Wewnętrzny dekoder wideo (Internal Video Decoder) > wyłącz H.264 i AVC1

  • Opcje (Options) > Ustawienia... (Preferences...) > Użycie dekodera (Decoder Usage) > Zewnętrzny dekoder wideo (External Video Decoder) > Szukaj zewnętrznych dekoderów (External Decoder Search) > zaznaczone H.264 i AVC1 > Skanuj i dodaj (Add after Scan) > OK > dla H.264 Wideo (H.264 Video) i AVC1 Wideo (AVC1 Video) zmień Nie rób nic (Do Nothing) na CoreAVC Video Decoder

I ewentualnie zmień używany splitter dla MKV.

Jeśli masz zainstalowany w systemie Haali Media Splitter...

  • Opcje (Options) > Ustawienia... (Preferences...) > Filtr źródłowy (Source Splitter) > Reszta (The Rest) > Ustawienia Splittera Haali (Haali's Splitter Settings), zaznacz Matroska

BTW... The KMPlayer korzysta przede wszystkim z libavcodec - podobnie jak ffdshow.

Dekoder CoreAVC jest nieco 'szybszy' od libavcodec przy dekodowaniu H.264/AVC (mi wychodziło ok. 20% różnicy obciążenia CPU).