Problem z plikem NTLDR i bootowaniem z CD-ROMu


(Jakmie) #1

Witam, mam problem z komputerem. Mialem zainstalowanego na twardzielu Win XP. Po pewnym czasie zlego uzytkowania zaczął system świrować, a jako ze ja orlem w naprawianiu nie jestem, to postanowilem zrobic reinstalke. Niestety, podczas instalacji systemu wywalilo prad w okolicy. Po odzyskaniu sprawnosci podczas uruchamiania komputera wyswietla sie komunikat " brak pliku NTLDR. Wcisnij ctrl+alt+del aby zrestartowac. Domyslilem sie, ze jest to plik odpowiedzialny za startowanie systemu, wiec postanowilem sformatowac dysk twardy. Po pierwszym formacie dalej wyswietlal sie ten komunikat, wiec myslalem, ze cos zle zaznaczylem. Niestety, po kolejnych formatach dalej wyswietla się ten sam błąd. W biosie ustawilem bootowanie na cd, lecz nic to nie daje, nie chce startowac z plyty, caly czas od razu wyswietla sie ten komunikat. Wiec do konsoli nie mam się jak dostac, system nie chce sie instalowac :/. Co mam robić, POMOCY!


(Maniooo666) #2

Witam na forum.

Ten temat już się wielokrotnie przewijał, więc pewnie któreś z archiwalnych rozwiązań powinno okazać się skuteczne.

Użyj szukajki:

http://forum.dobreprogramy.pl/search.php

Wpisz:

brak pliku ntldr

Dodatkowo zaznacz opcję Szukaj wszystkich słów.

Jak masz ochotę na dalszą lekturę, to oczywiście google:

brak pliku ntldr

Powodzenia i w razie czego - pisz.


(Jakmie) #3

hmmm, google przejrzalem wczesniej, kilka tematow z tego forum tez. I wszedzie niestety sa odpowiedzi dla sytuacji, gdzie Windows jest zainstalowany. A ja mam kompletnie sformatowany dysk twardy ! A CD-ROM nie chce bootowac przed HDD, mimo ze jest ustawiony na poczatek. Napewno jest to bootowalny naped, bo juz nim kiedys instalowalem, plyta tez nie jest uszkodzona, bo na innym kompie instalowalem z tej plyty Windowsa wczoraj.


(Maniooo666) #4

Witam,

najczęstsze błędy to:

Ludzie mają pewność a jednak często tego nie przestawili.

Może została zrobiona kopia niebootowalna?

Sam się ostatnio z czymś takim spotkałem, niedopatrzenie, a kosztowało wiele czasu...

Wierzę.

Wiesz, że to zdanie w pewnych okolicznościach może działać na Twoją niekorzyść na forum dobreprogramy?

Czy możesz na 100% sprawdzić, czy system się z tej płyty zabootuje na innym kompie?

I 3 razy sprawdź BIOS.


(Jakmie) #5

Co do BIOS-a, wszystko jest ustawione tak jak powinno. Czyli CD na pierwszym miejscu, HDD na ostatnim (nie moge ustawic tak, zeby np. HDD wogole niebylo).

Wydaje mi sie, ze problem tkwi w tym, ze sprzet ma juz swoj wiek...

Sprawdzilem tą plyte z windowsem, pozyczylem od kumpla jego plyte, aby sie upewnic. I ta pozyczona plyta tez nie dziala.

Dzięki za pomoc Maniooo, wyglada na to ze problem rozwiazal sie sam... Nie wyswietla mi się juz na szczescie ten komunikat. Windy i tak nie moge zainstalowac(dalej nie bootuje z CD), no ale przynajmniej to sie juz nie wyswietla...

Pozdrawiam


(JNJN) #6

Sprawdź czy bios widzi napęd CD przy starcie kompa,podmień taśmę lub napęd CD na inny,jeśli napęd CD jest na jednej taśmie z dyskiem przepnij napęd na II kanał IDE zworka ustawiona na nim na Master.

A odłącz kompa od zasilania 230 V.

Wyjmij baterię biosu na 30 minut przy okazji zrób konserwację kompa, sprawdź wszystko,włóż baterię i ustaw bios i zapisz Save.

Obowiązkowo usuń z dysku wszystkie partycje ma być jak nowy,załóż i sformatuj systemową i próba instalacji XP.

http://forum.dobreprogramy.pl/viewtopic ... instalacja

http://forum.dobreprogramy.pl/viewtopic.php?t=42381

http://forum.dobreprogramy.pl/viewtopic.php?t=25048


(Jakmie) #7

no ok. Zrobione wszystko tak jak kazales. BIOS widzi i naped i HDD, twardziel po kilku formatach (NTFS). BIOS-a wczoraj aktualizowalem, wiec wszystko jest ustawione na nowo. Każdy pasek, zworka wpieta tak, jak powinna (mam nadzieje :slight_smile: ). I na usta niestety dalej cisnie sie slowo na cztery litery :frowning: . Nie wiem czemu, ale nie hula :frowning:

edit : a dodatkowo wrocil teraz znowu ten glupi blad :confused:


(Slawolp) #8

A jak podłączysz ten dysk do innego komputera też tak się dzieje, czy tylko na Twoim?


(Maniooo666) #9

Witam,

Ale czy sprawdziłeś swoją płytę u kolegi?

Znaczy, czy wetknąłeś ją w jego napęd i czy instalator systemu odpalił się z płyty?

Bo może być taka sytuacja, że jego płyta nie jest bootowalna,

a system instaluje on sobie z użyciem dyskietki systemowej.

Wtedy sprawdzasz u siebie dwie niebootowalne płyty, co prowadzi do takich rezultatów.

Sprawdź te płyty u kogoś innego. To może sporo wyjaśnić.

Porada MS mówi, że należy zassać jakiś plik:

http://support.microsoft.com/kb/320397/pl

Link do niego:

http://www.autourdupc.com/Logiciel/NT4/ ... update.exe

Rzucam to na wszelki wypadek, bo to się tyczy chyba sytuacji, gdy mamy zainstalowany system.

Zrobiłeś wszystko to, o co prosił JNJN?

Przede wszystkim - czy wyjąłeś baterię i wróciłeś BIOS do domyślnych ustawień?

Może masz specjalne menu od bootowanie na starcie (np. pod klawiszem F11).

Sprawdź.

Może tak by się dało odpalić płytę (wątpię).

Podstawa - upewnij się, że płyty są na pewno bootowalne.

Na dokładkę kilka linków po angielsku:

http://support.microsoft.com/kb/318728

I jeszcze jedno: obadaj, czy nie umarł Ci napęd CD.

Załatw jakiegoś bootowalnego Linuxa i odpal.

To tak na wszelki wypadek.

Niby BIOS go wykrywa, ale lepiej być pewnym.


(Jakmie) #10

Witam,

Sprawa przedstawia sie nastepujaco:

Podpialem dysk twardy do innego kompa. Problem dalej wystepuje, ale po wlozeniu do napedu CD z Win normalnie zaczyna sie instalacja systemu.

Po przelozeniu dysku twardego do mojego kompa windows z cd nie startuje. Zrobilem wszystko tak jak polecil JNJN, łącznie z wyciagnieciem baterii i ustawianiem biosa na nowo. Wydaje mi sie, ze problem lezy gdzies pomiedzy biosem a plyta glowna - cos musi byc juz zepsute na amen. Podlaczam różne napedy cd-rom ( ze wszystkich kiedys instalowalem windowsy), bios je wykrywa, ale nie chca bootowac. Płytki tez są dobre. Jakby ktoś wątpił-oryginałki, w dodatku sprawdzane czy bootuja (przeciez wczesniej mialem zainstalowanegoo windowsa). Również na innym komputerze sprawdzalem czy bootuja, i dzialaja jak nalezy. Czyli moj problem nie polega na braku pliku ntldr, tylko problem tkwi w bootowaniu. Swoją drogą, jednostka centralna jest firmy Gateway, wiec tutaj wszystko jest :slight_smile: specjalne. Nie znalazlem menu bootowania, w biosa wchodzi sie F1 i to wszystko :slight_smile: Aha, BIOS jest zaktualizowany do najnowszej wersji :slight_smile:

Pozdrawiam


(Darek130475) #11

Odepnij od dysku taśme i zasilanie. Pozostaw sam napęd cd i spróbuj z niego zabootować.


(Jakmie) #12

Niestety, nie bootuje. Z innego cd-rom tez nie....


(Darek130475) #13

W takim razie są trzy możliwości:

  1. BIOS nie posiada możliwości bootowania z CD

  2. Nie ustawiłeś kolejności bootowania na CD

  3. Jakaś awaria sprzętowa płyty głównej.

Jak aktualizowałeś bios to masz pewnie pliczek z nim. Udostępnij go. Gdzieś

w necie są emulatory biosu. Zobaczymy jakie są w nim ustawienia.

Co do komunikatu o braku pliku NTRDL to zgłasza bootloader Windows XP. Jest on ustawiony w pierwszym sektorze na dysku w pierwszych 512 bajtach. Widocznie formaty windosowe go nie ruszają. Można by spróbować sformatować dysk jakimś programem linuxowym.


(Jakmie) #14
http://rapidshare.com/files/48293009/BIOS.rar.html

tutaj wrzucilem tego BIOSa, emulatora zadnego nie znam...