Problem z protokołem MTP pod Windows XP Pro SP2


(Mariosti*) #1

Problem polega na tym że wszelakie urządzenia przenośne korzystające z wymienionego w temacie protokołu nie łączą się poprawnie z moim komputerem (w menadżerze urządzeń pojawiają się dokładnie te urządzenia z wykrzyknikami, nic nie daje doinstalowywanie do nich sterowników).

Zreinstalowałem sterowniki do płyty głównej bez efektu.

Testowałem różne porty usb bez efektu.

Testowałem dwa różne urządzenia korzystające z tego protokołu, bez efektu.

Na laptopie obok nie ma oczywiście żadnego problemu, na pc'cie obok też nie ma problemu, co ciekawe pc'et obok ma podobną konfigurację, płyta główna też na nf2 ultra 400, ale mostek południowy to mcp, podczas gdy u mnie jest mcp-t (w teorii to drugie ma poporstu dodatkowo fire wire, soundstorma i inny kontroler sieciowy).

Szukałem jakiś ogólnych sterowników do usb, ale xp sp2 ma je odrazu ze sobą i wyskakiwał komunikat o tym że w systemie są już nowsze.

Dodatkow problem w tym że nie wiem od kiedy jest ten problem, bo dawniej nie miałem żadnych "portable device's".


(Technik Elektro) #2

a nie został zainstalowany mobile phone tools od Motoroli ??

telefon komórkowy ??


(Mariosti*) #3

No np. telefon komórkowy, albo odtwarzacz mp3, miałem zainstalowany właśnie "samsun pc studio", razem z nim zestaw różnych sterowników, tak czy siak porównując to pc studio i mtp - przez mtp jest kilkakrotnie szybszy transfer i mam tylko to co potrzebuję czyli wymianę plików z komputerem tak jakby to był flash. No a problem z tym pc studio jest taki że po jego instalacji mp3'ki nie moge podłączyć za nic, a po deinstalacji tego pc'studio (również jego sterowników) nie widać żadnej poprawy...

Za jakiś czas zrobie sobie pewnie reinstall, ale dobrze byłoby wiedzieć jak temu zaradzić..


(Technik Elektro) #4

naprawa jest możliwa jest potrzebne usunięcie całej obsługi systemu zarządzania USB z poziomu rejestru systemu windows. kiedyś to robiłem, dość skomplikowana procedura.

proponuję zrobić kopię rejestru oraz utworzyć punkt przywracania systemu a następnie usunąć cały klucz :

HKLM -> SYSTEM -> CurrentControlSet -> ENUM -> USB.

mogą być jeszcze kolejne klucze USBXXXXXXX je też można skasować.

w razie problemów -> f8 i ostatnia dobra konfiguracja, załaduje się ControlSET01 itp.

pewnie nie tylko ale można spróbować i uruchomić ponownie komputer.


(Mariosti*) #5

Hmmm... nie moge tam nic usunąć... Sprawdziłem i moduł firewalla monitorujący rejestr wyłączyłem i nic to nie dało, czy może z trybu awaryjnego trzeba to usuwać?


(Technik Elektro) #6

prawy właściwości -> nadaj sobie prawa Pełna Kontrola.


(Mariosti*) #7

Bez efektu :?


(Technik Elektro) #8

nie udało się usunąć gałęzi ?? czy przeinstalowanie obsługi USB nic nie dało ??


(Mariosti*) #9

Prawa własności nic nie dały, bo już miałem pełne, dodatkow próbowałem je odznaczać i znowu zaznaczać i też nic nie dało.


(Technik Elektro) #10

zaraz napiszę jak tylko się zaloguję na xp.

użytkownik z prawami administratora -> prawym na gałąź USB -> uprawnienia -> kliknij użytkownicy Wszyscy -> Pełna kontrola, Zezwalaj OK -> usuń klucz przed chwileczką sprawdzałem.


(Mariosti*) #11

Próbowałem też to odpalać z systemowego konta administratora i dalej nic... bardzo dziwne... chyba sobie jednak daruje i reinstalke zrobie...