Problem z UDP socket w vista x64


(Mkp0) #1

Witam,

Sytuacja pojawiła się nagle tzn. gdy chciałem skonfigurować serwer DHCP w routerze tak aby przydzielał adresy >192.168.1.2, a samemu nastawić sobie na sztywno 192.168.1.2 tak aby nie było problemów z przekierowywaniem portów. Zrobiłem więc tak, w międzyczasie zrestarowałem kompa i... Lipa totalna rzekłbym nawet katastrofa: eMule wyrzuca problem "Error: Server UDP socket: Failed to create UDP socket - parametr jest nie poprawny" na starcie, przy czym przy próbie podłączenia do serwera, w logach jest błąd:

"2007-04-30 17:56:40: Connecting to DonkeyServer No1 (62.241.53.2:4242)...

2007-04-30 17:56:40: Error while connecting to DonkeyServer No1 (62.241.53.2:4242): Error 10038: Próbowano przeprowadzić próbę na obiekcie, który nie jest gniazdem.

2007-04-30 17:56:40: Fatal Error while trying to connect. Internet connection might be down

2007-04-30 17:56:40: Automatic connection to server will retry in 30 seconds",

żeby tego było mało to Opera i Firefox odmówiły współpracy, konnekt też. Przeglądarki wyrzucają błąd z połączeniem, a konnekt wraz z dopiskiem o owym sockecie UDP...

Przywrócenie poprzednich konfiguracji nie pomaga, punktów przywracania systemu nie posiadam, na googlach nie moge znaleźć rozwiązania. Jesteście więc moją ostatnią nadzieją przed zrobieniem formata...

P.S. Po odpaleniu drugiej instalki visty na kompie wszystko działa ładnie i co jeszcze ciekawe, to IE działa bez zażutu...


(Mrooveq) #2

w zasadzie ani opera ani firefox, ani chyba nawet konnekt nie używa do normalnej pracy protokołu udp, jedyne do czego go mogą użyć to zapytanie dns, może tu jest problem?

poza tym reszta objawów jest taka jak przy odłączonym kablu(?) albo braku adresów z dhcp, choć wtedy windows konfiguruje się do 169.254.x.y i takie komunikaty się nie pojawiają.

co oznacza druga instalka visty? robiłeś reinstall i zaczęło działać?


(Mkp0) #3

Dzięki za porady, chociaż dalej nie moge znaleźć rozwiązania, to naprowadziłeś mnie chociaż na ścieżkę...

Drugia instalka visty = vista z drugiego dysku

P.S. problem z połączeniem z dns-ami to chyba nie jest bo jak wpisuje adresy ip w opere to jest to samo // dobrze mówie czy piernicze głupoty?

Dodam jeszcze, że ten błąd wyskakuje odrazu po naciśnieciu entera, nie ładuje nic tylko wyświetla odrazu

"You tried to access the address http://216.239.39.99/, which is currently unavailable. Please make sure that the Web address (URL) is correctly spelled and punctuated, then try reloading the page."

Po zamknięciu opery wyskakuje okienko że wystąpił błąd w programie i zostanie zamknięty - tak samo jak w emule, konnekcie i firefoxie


(Mrooveq) #4

a windows defender, albo jakiś dodatkowy firewall?

co pokazuje 'ipconfig /all' odnośnie używanej przez Ciebie karty sieciowej?


(Mkp0) #5

Windows defender aktualizuje się normalnie i działa. NOD32 wyrzuca błąd failed to open socket przy próbie aktualizacji. Firewalla nie mam, bo jestem za routerem.

ipconfig /all pokazuje:

Konfiguracja IP systemu Windows


   Nazwa hosta . . . . . . . . . . . : Macieqqq-PC

   Sufiks podstawowej domeny DNS . . :

   Typ węzła . . . . . . . . . . . . : Hybrydowy

   Routing IP włączony . . . . . . . : Nie

   Serwer WINS Proxy włączony. . . . : Nie

   Lista przeszukiwania sufiksów DNS : domain_not_set.invalid


Karta Ethernet Połączenie lokalne:


   Sufiks DNS konkretnego połączenia : domain_not_set.invalid

   Opis. . . . . . . . . . . . . . . : NVIDIA nForce Networking Controller

   Adres fizyczny. . . . . . . . . . : 00-01-29-D4-82-6E

   DHCP włączone . . . . . . . . . . : Tak

   Autokonfiguracja włączona . . . . : Tak

   Adres IPv6 połączenia lokalnego . : fe80::2446:32d3:92ea:eacf%9(Preferowane)


   Adres IPv4. . . . . . . . . . . . . : 192.168.1.2(Preferowane)

   Maska podsieci. . . . . . . . . . : 255.255.255.0

   Dzierżawa uzyskana. . . . . . . . : 30 kwietnia 2007 20:45:47

   Dzierżawa wygasa. . . . . . . . . : 1 maja 2007 20:45:47

   Brama domyślna. . . . . . . . . . : 192.168.1.1

   Serwer DHCP . . . . . . . . . . . : 192.168.1.1

   Identyfikator IAID DHCPv6 . . . . : 150995241

   Serwery DNS . . . . . . . . . . . : 194.204.159.1

                                       217.98.63.164

                                       192.168.1.1

   NetBIOS przez Tcpip . . . . . . . : Włączony


Karta tunelowa Połączenie lokalne* 2:


   Stan nośnika . . . . . . . . . . .: Nośnik odłączony

   Sufiks DNS konkretnego połączenia :

   Opis. . . . . . . . . . . . . . . : Karta Microsoft ISATAP

   Adres fizyczny. . . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP włączone . . . . . . . . . . : Nie

   Autokonfiguracja włączona . . . . : Tak


Karta tunelowa Połączenie lokalne* 6:


   Stan nośnika . . . . . . . . . . .: Nośnik odłączony

   Sufiks DNS konkretnego połączenia :

   Opis. . . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

   Adres fizyczny. . . . . . . . . . : 02-00-54-55-4E-01

   DHCP włączone . . . . . . . . . . : Nie

   Autokonfiguracja włączona . . . . : Tak

(Mrooveq) #6

a jak mu ustawisz adres IP który dostawałeś poprzednio?

bo może aplikacje próbują ustawić sobie socket na nieistniejącym adresie?

albo jak mu ręcznie przypiszesz adres (bez dhcp)?

albo wpisz mu cokolwiek do sufiksów przeszukiwania dns, choć jeśli to by rozwiązało sprawę, to byłby typowy bug;)


(Mkp0) #7

Niestety nic nie pomaga :frowning:


(Mrooveq) #8

hmm nie wiem czy w viście jest coś takiego (nie miałem okazji sprawdzić), ale może jeśli jest, to sprawdź w trybie awaryjnym z obsługą sieci czy działa, czy wciąż tak samo jest.


(Mkp0) #9

Jest tak samo tj. IE działa, ale cała reszta nie :frowning:


(Mrooveq) #10

a IE działa na wszystkim co mu wpiszesz? czy może wyświetla tylko strony z cache'a?

sprawdź jakieś strony fbi, nasa albo jakieś na które na pewno nie wchodziłeś jeszcze.


(Mkp0) #11

Takie żeczy to sprawdzam na początku. Czytam to forum z IE więc...


(Mrooveq) #12

a jak mu odinstalujesz antywirusa i wyłączysz defendera? albo jakąś kontrolę rodzicielską?

nic mi innego nie przychodzi do głowy na razie...


(Mkp0) #13

Cóż, więc zabieram się do reinstalacji... pier*** viśta, ale i tak wole ją od xp :slight_smile: