Problem ze stroną


(Piotr Z18) #1

Wiatm mam problem, mianowicie nie wiem dlaczego na mojej stronie nie ma polskich znaków? Proszę o pomoc. Link do strony http://www.kosmetyki.za.pl Z góry dziękuje


(m@teo) #2

nie wiem jak ty ale u mnie w FF jest dobrze :stuck_out_tongue:


(P Sk) #3

witam,

ustaw kodowanie znaków na: automatyczny lub ISO-8859-2

i powinno być dobrze :smiley:


(adam9870) #4

Polskie znaki wstawiaj według tej tablicy, a będą się wyświetlać:

http://webdesign.art.pl/atelier/ISO_8859-2.html

sam akurat robię stronkę i gdy nie wyświetlają się polskie znaki to wstawiam według tej tablicy i jest ok :smiley:

Jeszcze na początku strony wstaw:


(adpawl) #5

Musisz przekonwertować tekst np. programem Ogonki97

...było o nim np. w tym temacie:

http://forum.dobreprogramy.pl/viewtopic ... t=ogonki97

...albo wstawiaj ręcznie z tablicy, tak jak podał adam9870

Właściwie, to wszystko zależy w czym robisz stronke ...każdy lepszy edytor (np. Pajączek) konwertuje znaki w tle :wink:

BTW

...A co, nie ma? :lol:


(adam9870) #6

Nie zawsze po wstawieniu tego kodu jest poprawne kodowanie wszystkich polskich znaków. Ja akurat piszę stronę w notatniku i nie jest poprawne kodowanie po wstawieniu tego kodu :stuck_out_tongue: musze wstawiać z tablicy i dopiero wtedy jest :smiley:


(adpawl) #7

Bo to jest tylko deklaracja informująca o zastosowanym kodowaniu znaków. Jeżeli jednak tekst jest w innym standardzie niż zadeklarowany, to krzaczki właśnie takie wyjdą.

Dlatego właśnie kodowanie tekstu musi odpowiadać temu zadeklarowanemu w META. :wink:

A zatem należy jak już wyżej pisane:

-ręcznie pozmieniać znaki specjalne według tabeli

-przekonwertować tekst np. programem ogonki97

-przy tworzeniu/edycji stronek korzystać z web edytora z prawdziwego zdarzenia

...i wszystko na temat. :roll:


(lazikar) #8

Problem gdzie???

W przegladarce czy kodzie strony.

Mi się wyswietla ok.


(adpawl) #9

Mnemam, że mowa o tym:

...przynajmniej u mnie tak to wygląda :?