Radeon x1300-sterowniki-problem


(Kornicameister) #1

walczę z tą kartą od wieków

ostatnio na ubuntu 6.06 zainstalowałem sterowniki skryptem envy

ale teraz na 6.10 nie mogę nawet skryptu zainstalować :frowning:

mam kilka pytań :

  1. czy jest jakiś sposób na instalacje envy ??

  2. moja karta to sterowniki otwarte czy zamknięte (myślę, że zamknięte jak dla niej, ale chce się upewnić)

poszukam w necie sposobów na instalacje sterowników do karty, ale poproszę też o wasze sugestie, oczywiście na mojego redeon`a

kiedyś pamiętam, bo nie udanej zmianie w pliku konfiguracyjnym xorg, padły mi x, a próba zmian na poprzednią wersje, zakończyła się fiaskiem (próba w trybie tekstowym, poprzez alt+ctrl+f1, o ile dobrze pamiętam). Wyskakiwało mi, że nie mogę się połączyć z serwerem x :?

  1. Jak w przypadku padnięcia x, poradzić sobie z tym problem, aby prawidłowo przywrócić system :-x

(Me) #2

sudo apt-get install fglrx

potem otworz xorg.conf i ustaw driver w sekcji grafiki na fglrx (pewnie bedzie mesa wpisna tam). Zastap to co bedzie w Driver wlasnie tym fglrx

Złączono Posta : 14.04.2007 (Sob) 9:10

tylko przed edycja zrob:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_back

Jak padna X'y po zmaianch to zrobisz:

sudo cp /etc/X11/xorg.conf_back /etc/X11/xorg.conf


(Kornicameister) #3

backup robie w recovery mode, który mogę wybrać w grubie

czy po nieudanym załadowaniu systemu i wrzuceniu sekwencji klawiszy

alt+ctrl+F2

(Me) #4

normalnie w systemie. jak jestes zalogowany.

zrob tylko to co napisalem, a bedzie dobrze:

czyli:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_back

Potem podmieniasz Driver na fglrx (w sekcji od grafiki)

restart systemu alboalt+ctrl+backspace

Jak padna X'y po zmaianch to zrobisz:

sudo cp /etc/X11/xorg.conf_back /etc/X11/xorg.conf


(system) #5

Hehe no wlasnie ja mam karte X700 i poddałem się a próbowałem wszystkiego. Jezeli masz taki problem jak ja ze swoja karta to nie mecz się bo to nic nie da tylko czas stracisz. Zadziwiające jest to że na 6.06 wszystko było ok a na 6.10 juz jest beznadziejnie. Ale mam pocieszenie teraz mam OpenSuse 10.2 i az się zdziwiłem ze sa w nim zamkniete sterowniki do ATI polecam zero zabawy czysta satysfakcja wszystko działa idealnie :lol:


(Me) #6

X700 dziala na otwartych sterownikach ktore sa duuuuuuuuuzo lepsze.

na 6.10 Ubuntu z POWODZENIEM uruchomilem moja x1300 na fglrx i robie to na kazdej dystrybucji (gentoo/arch/slack/frugalware/Debian/Vector)

Jesli beda CI sie "zawieszaly" X'y to daj znac na to tez jest sposob ;]


(system) #7

Aha ludzie tak dla scisłości ja mówi o ATI RADEONIE X700 Mobility :smiley: Nie wiem jak to jest z innymi wynalazkami ale na otwartych sterach działało to u mnie w Ubuntu 6.06 a juz ubuntu 6.10 nawet nie chciał się włączyć z płyty liveCD po zniknięciu okna ładowania wyskakiwał czarny ekran najgorsze, że tam w wersji 6.10 coś pozmieniali i nie dało się edytować Xorg.conf na vese a potem doinstalować zamknięte stery :confused: tryb bezpieczny tez nie odpalił, została tylko alternatywna płytka. Na niej zainstalowałem zamkniete sterowniki ale 3D nie udało mi się odpalic. Takie moje przykre doświadczenie z Ubuntu, po którym powiedziałem sobie ze nie kupie już wiecej żadnego sprzetu ATI :wink:


(Kornicameister) #8

ja też nie kupuje nigdy więcej ati ;]

pod koniec roku zamierzam cyknąć sobie coś z serii 7, albo 8 jak dobrze stanieje :lol:


(Me) #9

No ja tez mowilem o X700 Mobility jak i o x1300 Mobility.

A co do:

100% sie z Toba zgadzam.


(Kornicameister) #10
E: Nie udało się odnaleźć pakietu fglrx

co to znaczy :? nie mam w repozytoriach ?? czy też nie może tego znaleźć na dysku, skoro wyświetlił

E:

, bo to chyba jest litera dysku ps. posiadam plik z repozytoriami z forum.ubuntu.pl, gdzie wybrałem te dla ubuntu 6.10 edgy eft więc co jest nie tak tym razem :-x