Sprawdzanie liczb w Exelu


(Bolkowice10) #1

Jak w Exelu sprawdzić czy dana liczba należy do jakiegoś przedziału? np: w kolumnie A mam liczbe jakąś i powiedzmy ze jest ona z przedziałyu od 100-130 to wyświetla jakiś napis. Proszę o szybką pomoc


(system) #2

LICZ.JEŻELI(A1;"<10")-LICZ.JEŻELI(A1;">4")

Dla przedziału (4;10)

Tylko zamiast A1 musisz podać jakiś zakres


(Bolkowice10) #3

a co z wyświetleniem napisu gdzy do tego przedziału mam coś napisane?

-- Dodane 02.04.2009 (Cz) 20:03 --

np mam 3 wartości: (0;50) i do tego jest tekst blablabla, kolejny przedział (51;100) tekst eeee, i ostatni (101;200) pppp

i teraz np w kolumnie A1 mam liczbe 59 to powinno wyświetlić sie eeeee, w A2 mam 180 to powinno sie wyświetlić pppp i teraz jak to zrobić?


(system) #4

Zastosuj funkcję =JEŻELI(I(A2>2;A2<7)=1;$C$1;$C$2) i w C1 wpisz pożądany tekst a w C2 gdy nie spełnia tego(nie należy do zbioru).

Korzystasz z Excela więc "I" nazywa się inaczej, masz to w funkcjach logicznych, oba argumenty muszą być prawdziwe.


(Jharla) #5

:arrow: skoro wartosci w kolumnie A to w kolumnie B wpisz i skopiuj do dołu

=JEŻELI(A1>0;JEŻELI(A1<51;"blablabla";JEŻELI(A1<101;"eee";JEŻELI(A1<201;"pppp";"za duża")));"za mała")

=JEŻELI(jakiś-warunek;jeśli-prawda;gdy-fałsz)