Ster. Nvidia wymaga nowszego jądra a jest ono zaktualizowane


(kijek) #1

Witam. Podczas próby zainstalowania sterowników graficznych pod systemem Fedora 13 otrzymuję błąd związany z nieaktualnym jądrem systemu.

[root@blaszak kijek]# yum install kmod-nvidia

Wczytane wtyczki: presto, refresh-packagekit

Ustawianie procesu instalacji

Rozwiązywanie zależności

--> Wykonywanie sprawdzania transakcji

---> Pakiet kmod-nvidia.i686 1:256.53-1.fc13 zostanie zainstalowany

--> Przetwarzanie zależności: kmod-nvidia-2.6.34.6-47.fc13.i686 >= 1:256.53-1.fc13 dla pakietu: 1:kmod-nvidia-256.53-1.fc13.i686

--> Wykonywanie sprawdzania transakcji

---> Pakiet kmod-nvidia-2.6.34.6-47.fc13.i686.i686 1:256.53-1.fc13 zostanie zainstalowany

--> Przetwarzanie zależności: kernel-uname-r = 2.6.34.6-47.fc13.i686 dla pakietu: 1:kmod-nvidia-2.6.34.6-47.fc13.i686-256.53-1.fc13.i686

--> Przetwarzanie zależności: nvidia-kmod-common >= 1:256.53 dla pakietu: 1:kmod-nvidia-2.6.34.6-47.fc13.i686-256.53-1.fc13.i686

--> Wykonywanie sprawdzania transakcji

---> Pakiet kmod-nvidia-2.6.34.6-47.fc13.i686.i686 1:256.53-1.fc13 zostanie zainstalowany

--> Przetwarzanie zależności: kernel-uname-r = 2.6.34.6-47.fc13.i686 dla pakietu: 1:kmod-nvidia-2.6.34.6-47.fc13.i686-256.53-1.fc13.i686

---> Pakiet xorg-x11-drv-nvidia.i686 1:256.53-1.fc13 zostanie zainstalowany

--> Przetwarzanie zależności: xorg-x11-drv-nvidia-libs(x86-32) = 1:256.53-1.fc13 dla pakietu: 1:xorg-x11-drv-nvidia-256.53-1.fc13.i686

--> Przetwarzanie zależności: livna-config-display >= 0.0.21 dla pakietu: 1:xorg-x11-drv-nvidia-256.53-1.fc13.i686

--> Przetwarzanie zależności: nvidia-xconfig dla pakietu: 1:xorg-x11-drv-nvidia-256.53-1.fc13.i686

--> Przetwarzanie zależności: libnvidia-glcore.so.256.53 dla pakietu: 1:xorg-x11-drv-nvidia-256.53-1.fc13.i686

--> Przetwarzanie zależności: livna-config-display dla pakietu: 1:xorg-x11-drv-nvidia-256.53-1.fc13.i686

--> Przetwarzanie zależności: livna-config-display dla pakietu: 1:xorg-x11-drv-nvidia-256.53-1.fc13.i686

--> Przetwarzanie zależności: nvidia-settings dla pakietu: 1:xorg-x11-drv-nvidia-256.53-1.fc13.i686

--> Wykonywanie sprawdzania transakcji

---> Pakiet kmod-nvidia-2.6.34.6-47.fc13.i686.i686 1:256.53-1.fc13 zostanie zainstalowany

--> Przetwarzanie zależności: kernel-uname-r = 2.6.34.6-47.fc13.i686 dla pakietu: 1:kmod-nvidia-2.6.34.6-47.fc13.i686-256.53-1.fc13.i686

---> Pakiet livna-config-display.noarch 0:0.0.24-1.fc13 zostanie zainstalowany

---> Pakiet nvidia-settings.i686 0:1.0-6.fc13 zostanie zainstalowany

---> Pakiet nvidia-xconfig.i686 0:1.0-4.fc13 zostanie zainstalowany

---> Pakiet xorg-x11-drv-nvidia-libs.i686 1:256.53-1.fc13 zostanie zainstalowany

--> Przetwarzanie zależności: libvdpau(x86-32) >= 0.3 dla pakietu: 1:xorg-x11-drv-nvidia-libs-256.53-1.fc13.i686

--> Wykonywanie sprawdzania transakcji

---> Pakiet kmod-nvidia-2.6.34.6-47.fc13.i686.i686 1:256.53-1.fc13 zostanie zainstalowany

--> Przetwarzanie zależności: kernel-uname-r = 2.6.34.6-47.fc13.i686 dla pakietu: 1:kmod-nvidia-2.6.34.6-47.fc13.i686-256.53-1.fc13.i686

---> Pakiet libvdpau.i686 0:0.4-1.fc13 zostanie zainstalowany

--> Ukończono rozwiązywanie zależności

Błąd: Pakiet: 1:kmod-nvidia-2.6.34.6-47.fc13.i686-256.53-1.fc13.i686 (rpmfusion-nonfree-updates)

          Wymaga: kernel-uname-r = 2.6.34.6-47.fc13.i686

          Zainstalowano: kernel-2.6.33.3-85.fc13.i686 (@released/$releasever)

              kernel-uname-r = 2.6.33.3-85.fc13.i686

          Zainstalowano: kernel-2.6.34.6-54.fc13.i686 (@updates)

              kernel-uname-r = 2.6.34.6-54.fc13.i686

          Dostępne: kernel-PAE-2.6.33.3-85.fc13.i686 (fedora)

              kernel-uname-r = 2.6.33.3-85.fc13.i686.PAE

          Dostępne: kernel-PAE-2.6.34.6-54.fc13.i686 (updates)

              kernel-uname-r = 2.6.34.6-54.fc13.i686.PAE

          Dostępne: kernel-PAEdebug-2.6.33.3-85.fc13.i686 (fedora)

              kernel-uname-r = 2.6.33.3-85.fc13.i686.PAEdebug

          Dostępne: kernel-PAEdebug-2.6.34.6-54.fc13.i686 (updates)

              kernel-uname-r = 2.6.34.6-54.fc13.i686.PAEdebug

          Dostępne: kernel-debug-2.6.33.3-85.fc13.i686 (fedora)

              kernel-uname-r = 2.6.33.3-85.fc13.i686.debug

          Dostępne: kernel-debug-2.6.34.6-54.fc13.i686 (updates)

              kernel-uname-r = 2.6.34.6-54.fc13.i686.debug

 Można spróbować użyć --skip-broken, aby obejść problem

 Można spróbować wykonać polecenie: rpm -Va --nofiles --nodigest

To dziwne, ponieważ zaktualizowałem jądro poleceniem

yum update kernel*

Tak więc jak zainstalować te sterowniki?

PS. Po aktualizacji jądra nie mogę ustawić rozdzielczości 1920x1080.


(roobal) #2

Pokaż wynik polecenia uname -r.

Pozdrawiam!


(kijek) #3
2.6.34.6-54.fc13.i686

(roobal) #4

Krótko mówiąc (pisząc) masz zbyt nową wersję jądra :slight_smile:

Błąd: Pakiet: 1:kmod-nvidia-2.6.34.6-47.fc13.i686-256.53-1.fc13.i686 (rpmfusion-nonfree-updates)

          Wymaga: kernel-uname-r = 2.6.34.6-47.fc13.i686

Powinieneś mieć zainstalowane 2.6.34.6-47 widocznie pod tę wersję kompilowany był sterownik.

Pozdrawiam!


(kijek) #5

Pobrałem więc i zainstalowałem te ze strony Nvidii. Pojawił się jednak mały problem, otóż gdy tylko zmienię rozdzielczość ekranu, ta wraca do domyślnej po ponownym uruchomieniu komputera. Próbowałem zmieniać ją przez NVIDIA X Server Settings, po czym zapisywać ustawienia do pliku xorg.conf, jednak bez skutku. Co więc zrobić, aby rozdzielczość po ponownym uruchomieniu pozostawała taka sama?