SUSE 11.0 Apache2+PHP5 - Error (111): Connection Refused


(Spwmarluk) #1

Witam,

W związku z brakiem wskazówek co do wątku http://forum.dobreprogramy.pl/viewtopic.php?f=14&t=321878 , zdecydowałem się na zainstalowanie Apache. Obsługa PHP 'jakby' ruszyła, ale niestety nadal coś jest nie tak.

Serwer www potrzebny mi jest tylko i wyłącznie do wyświetlania logów ze squida za pomocą SARG i SqStat1.20. Ten drugi wymaga właśnie PHP.

1.

Po wywołaniu strony w PHP, otrzymuję komunikat - "Error (111): Connection Refused".

Wcześniej, na thttpd widziałem tylko kod strony w przeglądarce.

Jak można sprawdzić, co powoduje zrywanie / odrzucanie połączenia?

2.

Jak odpalałem strony w html przez thttpd, to jak w jakimś nadrzędnym katalogu nie było pliku index.html , to otrzymywałem widok coś jak FTP i mogłem sobie chodzić po podkatalogach, aż do napotkania index.html, co powodowało wyświetlanie strony.

Teraz Apache mówi, że nie znalazł index.html i nic nie wyświetla. Muszę podać pełną ścieżkę z użyciem dużych i małych liter aby dostać się do index.html, co niestety utrudnia pracę.

Jak skonfigurować Apache, żeby działał podobnie jak thttpd w tym przypadku?


(Atsuki) #2

ad 1. A czy mowia cos jeszcze logi samego apacha? Masz zainstalowane php5, libapache2-php5 (taka jest na debianie/ubuntu.. sprawdz jaka na twoim distro) i czy masz dodana obsluge php do configa apacha.

ad 2. Jezeli chcesz aby ci listowalo katalog w wypadku braku zdeklarowanych plikow index to do virtualhost dodaj Options +Indexes. badz ta regulke ustawiasz w pliku .htaccess w katalogu glownym virtualhosta, jak ma dzialac ze wszystkimi podkatalogami.


(Spwmarluk) #3

error_log - nie mówi nic na temat tego zapytania

access_log - wypisuje tylko, że:

Moje_IP - - [data] "GET /sqstat-1.20/sqstat.php HTTP/1.1" 200 365 "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.1 (KHTML, like Gecko) Iron/2.0.168.0 Safari/530.1"

Mam zainstalowane poprzez yast2:

apache2 - Version: 2.2.8-28.4, Installed: 2.2.8-28.4

apache2-mod_php5 - Version: 5.2.9-0.1, Installed: 5.2.6-0.8

php5 Core Files - Version: 5.2.9-0.1, Installed: 5.2.6-0.8
  • jeszcze jakieś rozszerzenia do php W którym miejscu w konfigu i co mam wpisać, żeby powiązać go z PHP?

Mam wpisane w httpd.conf :

Include /etc/apache2/mod_autoindex-defaults.conf

o to chodzi?


(Atsuki) #4

co do apache, z logow wynika, ze serwer dziala dobrze, wyslal strone (swiadczy o tym kod 200 + to ze nie ma nic w error logu) skierowaloby mnie to bardzie ku stwierdzeniu ze masz zablokowane porty, sprawdz firewall/czy cos nie blokuje portu ktory wykorzystuje np te twoje narzedzie.

co do listowania. nie nie to. plik htaccess albo wpis virtualhosta -> sites-available, musisz dodac to regulke co napisalem wczesniej.


(Spwmarluk) #5

Teraz nie mam dostępu do maszyny, ale firewall mam wyłączony (sprawdzałem w yast2, bo to pierwsze co mi przyszło do głowy:)

Dopiero zaczynam zabawę z Apache i muszę chyba trochę poczytać o tej konfiguracji, bo będę jeszcze potrzebował założyć hasełka na dostęp do niektórych podkatalogów (o ile się da...)


(matiit) #6

Da się, załatwisz to poprzez .htaccess i .htpasswd

Np:

:arrow: http://blog.rabinek.pl/2006/07/15/katalog-z-haslem/


(Atsuki) #7

tu masz liste bledow, ktore obecnie obsluguje apache -link. Nie ma na nim 111. Serwer www dziala dobrze. Sprawdz co chce zrobic twoj plik php, gdzie co chce otworzyc/zapisac/wejsc/dostac sie etc.


(Spwmarluk) #8

Więc tak:

Znalazłem jakiś faq do SqStat1.20 i jest napisane, że jak dostaję "Connection Refused", to mam sprawdzić, czy da się podłączyć telnetem z maszyny klienckiej do portu squida ( w tym przypadku 3128 ). No i oczywiście, się nie da:/ Jak lokalnie (squid) odpalę telnet, to mam połączenie. Jak odpalę przeglądarkę na squidzie, to wtedy strona w PHP już działa. Wszystko wskazuje na to, że coś mi blokuje połączenie telnetem. Firewall dla Internal Zone jest wyłączony. Ma ktoś pomysł co może blokować?

-- Dodane 09.04.2009 (Cz) 13:32 --

No i okazało się, że pomimo, że dla Internal Zone jest wyłączony firewall, to i tak porty są blokowane. Po dopisaniu dodatkowej linii ( FW_TRUSTED_NETS ) w konfiguracji firewall'a (odblokowanie portu 3128 dla TCP) wszystko zaczęło śmigać:slight_smile:

AD.2

Listowanie katalogów zadziałało po dopisaniu do pliku default-server.conf w :

Options Indexes

(Kaka') #9

atsuki ,

Rejestrując się na niniejszym forum zobowiązałeś się przestrzegać jego regulaminu. Niestety, w tym momencie łamiesz go ponieważ nie używasz polskich znaczków (ą, ę, ź, ż, ć, ó, ł, ń). Proszę więc o poprawienie wszystkich swoich postów w tym temacie pod kątem polskich znaczków, przy użyciu przycisku zmien.gif